Fordmods Logo

high oil pressure 

 

Page 1 of 1 [ 5 posts ] 

 
 Post subject: high oil pressure
Posted: Mon Nov 07, 2005 10:05 am 
Stock as a Rock
Offline

Age: 34

Posts: 118

Joined: 5th Nov 2004

Gallery: 5 images

Ride: BA XR6 Turbo

Location: Sydney
NSW, Australia

Hi all,

Was driving over the weekend and my oil pressure gauage rose into the red. Not sure why, pulled over and checked for leaks but nothing. There are no tappet noises or anything. Only happened the once, but all weekend it was one bar down from being in the red.w

Oil is about 7000kms old....

Any suggestions?

Thanks

 

_________________

fast1

Top
 Profile  
 
 
Posted: Mon Nov 07, 2005 2:03 pm 
Getting Side Ways
Offline
User avatar

Age: 54

Posts: 4102

Joined: 18th Nov 2004

Gallery: 10 images

Ride: PX2 Ranger 4x4 XLT Dual CAB

Location: Carrum Downs
VIC, Australia

High oil pressure is not such a bad thing like low pressure is. Mine also drifts occasionally into the red zone, but generally runs at around the 3/4 mark when at operating temp. Keep an eye on it, if its consistently in the high red zone then you may have a problem.

These Oil pressure gauges are also known to be inaccurate often caused by a poor earth connection. Or it could be that your oil is the wrong viscosity, try a thinner oil.

 

_________________

Image
She's meanness put to music and the b**ch is born to run!
Like the sign says, "speed's just a question of money. How fast can you go?"

Top
 Profile  
 
 
Posted: Mon Nov 07, 2005 11:04 pm 
Getting Side Ways
Offline
User avatar

Age: 43

Posts: 695

Joined: 5th Nov 2004

Gallery: 7 images

Ride: 2008 WQ Fiesta XR4

Location: Adelaide.
SA, Australia

Two things I'd check.
1. Make sure the sender wire is connected properly and the connection is clean.
2. If that is all good and the gauge still reads high, put a new sender in, they are avail. from Ford and aren't too dear.
My oil gauge was occasionally reading high for no reason and I replaced the sender. Problem solved.

Darin.

 

_________________

2008 WQ Fiesta XR4
2007 LS Focus CL

Top
 Profile  
 
 
Posted: Thu Nov 10, 2005 1:29 am 
Parts Gopher
Offline

Age: 31

Posts: 55

Joined: 4th Nov 2005

Ride: EF Fairmont

Location: canberra
ACT, Australia

i would suggest change your oil, an oil change should be done every 5oookm regardless, which is what i would do. Plus the oil pressure gauge in the instrument cluster is just an indicator like everything else in instrument cluster inc. the speedo. but my oil pressure gauge is always round the 3/4 mark.

 

_________________

ROTOR is ROTOR spelt backwards!!!

Top
 Profile  
 
 
Posted: Thu Nov 10, 2005 9:16 am 
Getting Side Ways
Offline
User avatar

Age: 43

Posts: 451

Joined: 29th Nov 2004

Gallery: 1 images

Ride: XR8(EF) & XR8BOSS290 Ute(FG)

Location: Sydney
NSW, Australia

Could have a sticky by-pass valve in the oil-pump :!:

 

_________________

________________________________________

Better off with not enough traction than not enough power.

Top
 Profile  
 
Display posts from previous:
Sort by  
 Page 1 of 1  [ 5 posts ] 

Who is online

Users browsing this forum: No registered users and 42 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

 

 

It is currently Sat Dec 16, 2017 5:02 pm All times are UTC + 11 hours

 

 

(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names