Fordmods Logo

I NEED HELP! ENGINE RUNNING ROUGH 4.0LTR EF 

 

Page 1 of 1 [ 5 posts ] 

 
 Post subject: I NEED HELP! ENGINE RUNNING ROUGH 4.0LTR EF
Posted: Tue Mar 14, 2006 6:16 pm 
Smokin em up
Offline

Age: 34

Posts: 254

Joined: 16th Dec 2004

Ride: AU XR6

Location: vic
VIC, Australia

hey guys i have got a ef gli 4ltr auto, the previous owner installed a big bosch 404 fuel pump , the car has been running fine, today the petrol light came on and and then the car started playing up , it hesitates under load and has no power , wont rev like its starving for fuel , , maybe the pump ran dry or sucked up some s**t ? i dont kknow , but it wont drive properly now and rev properly, any help much appreciated
Top
 Profile  
 
 
Posted: Tue Mar 14, 2006 6:17 pm 
Smokin em up
Offline

Age: 34

Posts: 254

Joined: 16th Dec 2004

Ride: AU XR6

Location: vic
VIC, Australia

and yes i put fuel in it.
Top
 Profile  
 
 
Posted: Tue Mar 14, 2006 6:29 pm 
Getting Side Ways
Offline
User avatar

Age: 32

Posts: 3687

Joined: 4th Mar 2005

Gallery: 23 images

Ride: XR6 Turbo

Location: Taree
NSW, Australia

fuel pump rooted?

 

_________________

SS Inductions CAI, K&N Filters, M-spec FMC, Turbosmart BOV, 8psi capa tune, X-force cat.

Mods going on: Nizpro springs, bosch 040 pump + Walbro gss341, 600cc injectors, PWR transcooler, 20% Underdrives, 15psi Actuator, Kingspring SSL's, 15psi tune.....More coming

Top
 Profile  
 
 
Posted: Tue Mar 14, 2006 6:32 pm 
Smokin em up
Offline
User avatar

Age: 29

Posts: 223

Joined: 1st Jan 2006

Gallery: 3 images

Ride: AU 1 Tonner

Location: Kariong
NSW, Australia

check your filter
check the flow by removing the fuel line and placing it into a container disconnect the spark and crank for 15 secs
also check if your fuel pressure reg is working disconnect the vaccum hose and it should flow more fuel

 

_________________

To be old and wise you first have to be young and stupid

Top
 Profile  
 
 
Posted: Tue Mar 14, 2006 6:33 pm 
Getting Side Ways
Offline
User avatar

Age: 32

Posts: 3687

Joined: 4th Mar 2005

Gallery: 23 images

Ride: XR6 Turbo

Location: Taree
NSW, Australia

lol yeah what Evil 1 ton said.

 

_________________

SS Inductions CAI, K&N Filters, M-spec FMC, Turbosmart BOV, 8psi capa tune, X-force cat.

Mods going on: Nizpro springs, bosch 040 pump + Walbro gss341, 600cc injectors, PWR transcooler, 20% Underdrives, 15psi Actuator, Kingspring SSL's, 15psi tune.....More coming

Top
 Profile  
 
Display posts from previous:
Sort by  
 Page 1 of 1  [ 5 posts ] 

Who is online

Users browsing this forum: Google [Bot], Google Adsense [Bot] and 18 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

 

 

It is currently Tue Dec 19, 2017 2:13 am All times are UTC + 11 hours

 

 

(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names