Fordmods Logo

idle drop and has stalled on me a couple of times EL xr6 

 

Page 1 of 1 [ 3 posts ] 

 
 Post subject: idle drop and has stalled on me a couple of times EL xr6
Posted: Fri Feb 22, 2013 10:49 pm 
Oompa Loompa
Offline

Age: 26

Posts: 36

Joined: 22nd May 2012

Ride: ford

Location: mel
VIC, Australia

Hi guys I was wondering if I could get some advice on my el xr6
At the moment I am getting a rough idle and has stalled on me a couple of time and at other time it is completely normal
The car isn’t losing power, and when I boot it I goes just fine.
I call up Jim mock, and they believe it to be three things
1. The o2 sensor.
- It’s located under the throttle body, where does it lead to?
2. Timing
3. Engine grounds
- Where are the engine grounds located? And how may are their? Any advice or picture will be helpful.

I am also getting about 420km per 65 litters of 98 fuel. Should I be getting more? And if I change the O2 sensor will it improve it?
I also read up on ford mods about people with the same problem saying to change the coolant temp sensor or getting the codes of the ecu and JIM mock laughed at it and said not to waste my time.
Top
 Profile  
 
 
 Post subject: Re: idle drop and has stalled on me a couple of times EL xr6
Posted: Fri Feb 22, 2013 11:17 pm 
Getting Side Ways
Offline

Age: 34

Posts: 1110

Joined: 27th Dec 2011

Gallery: 6 images

Ride: ef falcon futura

Power: 154 rwkw

Location: Koo Wee Rup
VIC, Australia

firstly, the o2 sensor is located in the exhaust, not under the throttle body (thats the intake air temp sensor) but it could still be your problem. if it is your problem, your fuel economy will improve.
is your isc working? (does your idle drop/nearly stall when you have a/c on?)

 

_________________

ef futura, pacemakers, 2.5inch catback, k&n panel filter and 3.45 lsd. extractors/cat, ticky head, custom cam grind, t5. now onto cosmetics.

Top
 Profile  
 
 
 Post subject: Re: idle drop and has stalled on me a couple of times EL xr6
Posted: Sun Feb 24, 2013 12:13 am 
Oompa Loompa
Offline

Age: 26

Posts: 36

Joined: 22nd May 2012

Ride: ford

Location: mel
VIC, Australia

its doesn't change having the A/C on, its just a little rocky when idling. not to sure what it could really be and i don't want to change things if they don't need it as the cost adds up. i was hoping to hook up the ecu and get a diagnostics on its codes though jim mock said it would not read the problem.

any body know where the engine ground wire are?
Top
 Profile  
 
Display posts from previous:
Sort by  
 Page 1 of 1  [ 3 posts ] 

Who is online

Users browsing this forum: No registered users and 32 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

 

 

It is currently Thu Dec 14, 2017 2:16 pm All times are UTC + 11 hours

 

 

(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names