Fordmods Logo

Idle problem with new cam... 

 

Page 2 of 2 [ 21 posts ] Go to page Previous  1, 2

 
Posted: Mon Feb 13, 2006 12:14 am 
Getting Side Ways
Offline

Posts: 6449

Joined: 11th Nov 2004

USELESS wrote:
It sounds like the valves are not closing to me.If it is a regrind..your mechanic should have shimmed it better.If it is new then make sure you have installed new springs.That cam has some big lift.


there would be no lifter noise if the vlaves were not closing.

 

_________________

PERMANENTLY BANNED

Top
 Profile  
 
 
 Post subject: yeah...
Posted: Mon Feb 13, 2006 12:29 am 
Stock as a Rock
Offline

Age: 34

Posts: 105

Joined: 11th Sep 2005

Ride: Falcon GLI

Location: Perth
WA, Australia

The cam is for EA to ED. The guy at CM performance said it's all the same. I don't believe he's correct.

I'll look on the throttle body for the screw, just in case I need it, but I seriously think the other cam will run better with the standard ECU. I think the one I have might be just a bit too wild. I didn't want to spend heaps, because it's not worth it unless you go all the way then. Just a tweak here and there and she'll run nice.

Yeah, I dunno about the lifter noise. It's a bit suss, but I think it's safe to blame the cam, as I have standard springs. But it still doesn't really make sense to me.
Top
 Profile  
 
 
Posted: Mon Feb 13, 2006 10:01 pm 
Getting Side Ways
Offline
User avatar

Posts: 916

Joined: 27th Nov 2004

Gallery: 4 images

Ride: EL Futura

Location: Berri
SA, Australia

2222549 if it has 528thou of lift will need better springs.

After reshimming my RPD/Alted stage 3 cam on the weekend my car ticked like a bastard! It takes about 10 mins of sedate driving around to get the HLA's pumped up and the tick to go away, this is quiet normal if he bled any of the HLA's. But being a mechanic he should know this.

If you suspect a valve isn't closing properly (you should hear it when its cranking over, sounds really sus - trust me, i've heard this sound 3 times too many) then do a compression test on your cylinders, that will tell all.

 

_________________

5 Speed EL Futura
Stock as a rock*
Image
A1 Oils - Synthetic lubricants: www.a1oils.com.au
* A rock that has been Alted

Top
 Profile  
 
 
 Post subject: alright!
Posted: Tue Feb 14, 2006 3:15 am 
Stock as a Rock
Offline

Age: 34

Posts: 105

Joined: 11th Sep 2005

Ride: Falcon GLI

Location: Perth
WA, Australia

Glad to hear the ticking is normal, at least for a while. The mechanic happens to be my friend, and yeah, he's pretty fussy about doing a good job. He also did bleed the lifters he told me.

My new cam, the 2222519 is coming in tomorrow. It has about 490 thou lift, which the standard springs should be able to cope with. The reason I'm adament about getting it is because it has slightly longer duration which, I've heard, works better with LPG. That and the fact it should idle well, and that it is designed to run well with an EF-EL standard ECU. Sounds like I can't go worng, but we'll see!
Top
 Profile  
 
 
Posted: Tue Feb 14, 2006 1:19 pm 
Getting Side Ways
Offline
User avatar

Age: 35

Posts: 516

Joined: 20th Dec 2004

Gallery: 4 images

Ride: EL Manual

Location: S.E. Melbourne
VIC, Australia

Like I mentioned in the other thread. When I first got this cam it would not idle at all untill I got my chip. It would constantly stall unless you had your foot on the throttle, 'learning' was out of the question.
The specs on Crows website are different to what you actually get, check the sheet that came with your cam.

 

_________________

Manual EL Gli.
Mods: Crow Stg3, Chiptorque Dynotune. Lukey Exhaust. DBA slotted rotors, EBC Pads. Whiteline Low Susp. EL GT Swaybars, ROH Envy 17 x235 wheels. Vehicle Datalogger Display V2.0,

Top
 Profile  
 
 
 Post subject: strange
Posted: Tue Feb 14, 2006 2:13 pm 
Stock as a Rock
Offline

Age: 34

Posts: 105

Joined: 11th Sep 2005

Ride: Falcon GLI

Location: Perth
WA, Australia

it's a bit sus if they advertise different specs than what the specs actually are :? .

Well, I'm banking on the fact the new cam will work better. It's not as lumpy. I don't want to go a chip; it's not worth it for me. If I do, I may as well turn it into a race car.
Top
 Profile  
 
Display posts from previous:
Sort by  
 Page 2 of 2  [ 21 posts ]  Go to page Previous  1, 2

Who is online

Users browsing this forum: No registered users and 33 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

 

 

It is currently Sat Dec 16, 2017 9:00 pm All times are UTC + 11 hours

 

 

(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names