Fordmods Logo

idleing high for no reason 

 

Page 1 of 1 [ 5 posts ] 

 
 Post subject: idleing high for no reason
Posted: Mon Nov 16, 2009 6:08 pm 
Getting Side Ways
Offline

Age: 26

Posts: 1109

Joined: 4th Sep 2009

Ride: 92 EB s

Location: DORRIGO
NSW, Australia

Ok. I have recently put a pod filter and new throttlecable in my car.
As of saturday itwas spluttering at idle. Going from 400rpm to almost stall then up to 400 again.
I was told to clean my isc out. Did that and now she is idleing at 1100 down to 900 and sounds like staling and back up again.
If I tap the accelerator it rides itself up to 1500 and goes down really slowly.
I replaced the plugs today (old ones were rooted) and cleaned the throttle body. Didn't do anything bar make it start nicer.
I looked for the idle adjuster,found a screw with a spring on it. It can make it faster but even when its fully out it dosnt lower it at all.
Im stumped.

On friday I did some skids in the wet. But nothing past 4500 to 5000rpm.

Any ideas of what's doin it.

Also pretty getting hot in the engine bay. Full oil and coolant.

I want my idle back :(
Top
 Profile  
 
 
 Post subject: Re: idleing high for no reason
Posted: Fri Nov 20, 2009 3:21 am 
Stock as a Rock
Offline
User avatar

Age: 26

Posts: 122

Joined: 19th Nov 2009

Gallery: 2 images

Ride: 1994 ED XR6, 2003 BA XR8

Location: Traralgon South
VIC, Australia

make sure that your new cable isn't holding the butterfly in the TB open a little bit more than it should, just unhook it from the TB and see if that makes a difference

 

_________________

98%of city drivers will say ''holly s**t'' befor going into a ditch in a snowstorm and 98%of country drivers will say ''hold my beer and watch this''

Top
 Profile  
 
 
 Post subject: Re: idleing high for no reason
Posted: Sat Dec 19, 2009 11:13 am 
Getting Side Ways
Offline
User avatar

Age: 35

Posts: 963

Joined: 14th Jul 2007

Gallery: 3 images

Ride: AU fairmont ghia

Location: Back in
ACT, Australia

i dont know what its called but there is a hose comin from the engine, check to see if its loose that could cause it to rev high

 

 

Attachments:
19122009011.JPG
19122009011.JPG [ 23.02 KiB | Viewed 21 times ]

 

_________________

AU FAIRMONT GHIA: 5.0 Dealer ordered SVO mods ( seeking clarification ATM), tickford suspension.

Top
 Profile  
 
 
 Post subject: Re: idleing high for no reason
Posted: Sat Dec 19, 2009 12:29 pm 
Getting Side Ways
Offline
User avatar

Age: 30

Posts: 824

Joined: 10th May 2007

Ride: Xr6 Turbo

Location: Melbourne
VIC, Australia

yeah check all your vac lines this will cause a high idle with revs holding. remove your cable and start the car and see if that changes.

 

_________________


Previous cars


1995 ef futura - nothing special
2003 xr6 turbo 5 -speed 307rwkw

Top
 Profile  
 
 
 Post subject: Re: idleing high for no reason
Posted: Mon Dec 21, 2009 12:39 pm 
Getting Side Ways
Offline

Age: 26

Posts: 1109

Joined: 4th Sep 2009

Ride: 92 EB s

Location: DORRIGO
NSW, Australia

nah no leaks i fixed it, new thermostat (i couldent get one that opened at 82 so 91 will have to do) and new coolant and its fine, weird hey....
Top
 Profile  
 
Display posts from previous:
Sort by  
 Page 1 of 1  [ 5 posts ] 

Who is online

Users browsing this forum: No registered users and 27 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

 

 

It is currently Thu Dec 14, 2017 12:21 pm All times are UTC + 11 hours

 

 

(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names