Fordmods Logo

indecisive cooling & other stuff 

 

Page 1 of 1 [ 14 posts ] 

 
 Post subject: indecisive cooling & other stuff
Posted: Fri Jul 06, 2007 5:53 pm 
Getting Side Ways
Offline
User avatar

Age: 37

Posts: 1421

Joined: 5th Nov 2004

Ride: 98 EL Falcon - Last of the EL's

Location: Muswellbrook
NSW, Australia

ok just a couple of little problems with my EA (cfi):

1: the temperature in the car cant make up it mind on what i wants to do, it will go right up then back to normal, then up it goes again & back to normal all the time.

i have changed the thermostat and i have given the radiator a flush.

2: when its running at its normal temperature and i give it a boot-full or i drive up a hill it starts struggling and all most dies like the timing is out, or its being starved of something.

i have replaced the air filter, the fuel filter, cleaned the carby, and put a bottle of system cleaner through it.

oh and it might be nothing but i have removed the idle speed control motor since it was pissing me off keeping the car revving at 4000rpm ALL the time.

any idears would be helpfull :)

 

_________________

why are women like clouds? eventually they f**k off and its a really nice day.

telling the truth is just lack of imagination

Top
 Profile  
 
 
Posted: Fri Jul 06, 2007 7:19 pm 
Fordmods Junkie
Offline
User avatar

Age: 31

Posts: 1175

Joined: 23rd Mar 2005

Gallery: 6 images

Ride: 1994 ED Fairmont

Location: Brisbane
QLD, Australia

Hmmmmm Main issue would probably be the cfi.... do a MPFI conversion lol

Also make sure u dont use a factory thermostat the 82C with the hole in it is ideal... maybe the CFI comp is rooted comps do play up.

Also how many k's on it... especially going up a hill and struggling you will notice on a tired motor. and a heavy CFI is underpowered already.

 

_________________

1994 ED Fairmont Champaign Gold - AU Series II Intech 4.0L - EL EFI - Thermo Fans - 4.11 LSD - Pacemaker 4480 Into Custom 3" Exhaust - Shift Kit
In Progress: EL 4 Speed Auto- 3000 STALL - To be fitted
EF Tickford Race Spec Head Port- In the shop
Custom SureCam - Chiptorque

Top
 Profile  
 
 
Posted: Fri Jul 06, 2007 7:25 pm 
Getting Side Ways
Offline
User avatar

Age: 37

Posts: 1421

Joined: 5th Nov 2004

Ride: 98 EL Falcon - Last of the EL's

Location: Muswellbrook
NSW, Australia

ebfairmont3.9 wrote:
Hmmmmm Main issue would probably be the cfi.... do a MPFI conversion lol


:lol: why stop there i was reading up on some other threads and this one looks tempting :wink: http://www.fordmods.com/forums/viewtopic.php?t=46794

ebfairmont3.9 wrote:
Also make sure u dont use a factory thermostat the 82C with the hole in it is ideal... maybe the CFI comp is rooted comps do play up.


i have heard that you can use an XF thermostat would that be better?

 

_________________

why are women like clouds? eventually they f**k off and its a really nice day.

telling the truth is just lack of imagination

Top
 Profile  
 
 
Posted: Fri Jul 06, 2007 7:27 pm 
Getting Side Ways
Offline
User avatar

Age: 31

Posts: 4849

Joined: 19th Feb 2005

Gallery: 1 images

Ride: BA Falcon Suzy Across

Power: 178 rwkw

Location: melbourne
VIC, Australia

I had this problem with my EA but never succesfully fixed it. Check your fuel pressure to make sure your fuel pump isn't on its way out. Also, the 2 injectors may need to be professional cleaned.

 

_________________

178.3 rwkw
15.1@96 mph
Now with 3.9 shrooms

Top
 Profile  
 
 
 Post subject: temp
Posted: Fri Jul 06, 2007 7:31 pm 
Getting Side Ways
Offline
User avatar

Age: 32

Posts: 839

Joined: 10th Sep 2006

Gallery: 3 images

Ride: V8 Falcon, Nissan Patrol

Location: Brisbane, Bouncing off 5800RPM
QLD, Australia

start with....
water pump, water galleries or raditior could have crap in them, or possibly collapsed, even thou u have flushed it.

with the thermostat, buy the 81 degree and put a small hole on it.

make sure thermos/fan clutch works properly

now try....
from the way and times it overheats, sounds like the auto (if it is auto) is causing the problem, put on a dedicated oil cooler
or could be an over/under fuel issue and/or timing (dizzy) will also make ur engine hot

 

_________________

1993 Ford Fairmont EB II 5.0L V8 Wagon
1992 Nissan Patrol TI 4.2L Diesel 4x4 Wagon

Top
 Profile  
 
 
Posted: Fri Jul 06, 2007 7:40 pm 
Fordmods Junkie
Offline
User avatar

Age: 31

Posts: 1175

Joined: 23rd Mar 2005

Gallery: 6 images

Ride: 1994 ED Fairmont

Location: Brisbane
QLD, Australia

lol sorry i should have said.... CFI is the main problem... Do a BA Turbo conversion this is the only alternative lol

Id bloody do it if i had a spare 10k lol [/quote]

 

_________________

1994 ED Fairmont Champaign Gold - AU Series II Intech 4.0L - EL EFI - Thermo Fans - 4.11 LSD - Pacemaker 4480 Into Custom 3" Exhaust - Shift Kit
In Progress: EL 4 Speed Auto- 3000 STALL - To be fitted
EF Tickford Race Spec Head Port- In the shop
Custom SureCam - Chiptorque

Top
 Profile  
 
 
Posted: Fri Jul 06, 2007 7:48 pm 
Parts Gopher
Offline

Age: 44

Posts: 78

Joined: 23rd Apr 2007

Gallery: 1 images

Ride: ED GLi

Location: Brisbane
QLD, Australia

EA CFI NUFF SAID
(buy a new car)

 

_________________

and on the eighth day God created the Falcon

Top
 Profile  
 
 
 Post subject: cooling
Posted: Fri Jul 06, 2007 7:50 pm 
Getting Side Ways
Offline
User avatar

Age: 32

Posts: 839

Joined: 10th Sep 2006

Gallery: 3 images

Ride: V8 Falcon, Nissan Patrol

Location: Brisbane, Bouncing off 5800RPM
QLD, Australia

dont worry about CFI, i had an EA CFI Fairmont Sedan (auto), and i did a auto fulid change, new water pump and radiator and drove it hard, only just got into the normal range!!!!, i had the clutch fan on it (new clutch) 12 fin fan, not the 8 or 9 on (12 fin is standard on all cars with factory air cond)

 

_________________

1993 Ford Fairmont EB II 5.0L V8 Wagon
1992 Nissan Patrol TI 4.2L Diesel 4x4 Wagon

Top
 Profile  
 
 
Posted: Fri Jul 06, 2007 7:51 pm 
Fordmods Junkie
Offline
User avatar

Age: 31

Posts: 1175

Joined: 23rd Mar 2005

Gallery: 6 images

Ride: 1994 ED Fairmont

Location: Brisbane
QLD, Australia

noooo dont buy a new car... New motor conversion... EFI change..

Ea's rule a nice big comfy falcon without a s**t of weight to carry around i wish i still had my EB series 1 ( EA with eb skin)

Look good to with the right things done. Or a stock ghia lowered looks good.

People say EA's suck??.. They are thick u can pick up and EA for less then 1k with a good body and put a new motor and efi in for like 1500.. and have a quick car and reliable..Whos the dumbass now. Great value for money. i got my ED for $600 and its a damn good car. Especially with a few little mods :D

 

_________________

1994 ED Fairmont Champaign Gold - AU Series II Intech 4.0L - EL EFI - Thermo Fans - 4.11 LSD - Pacemaker 4480 Into Custom 3" Exhaust - Shift Kit
In Progress: EL 4 Speed Auto- 3000 STALL - To be fitted
EF Tickford Race Spec Head Port- In the shop
Custom SureCam - Chiptorque

Top
 Profile  
 
 
Posted: Fri Jul 06, 2007 7:59 pm 
Parts Gopher
Offline

Age: 44

Posts: 78

Joined: 23rd Apr 2007

Gallery: 1 images

Ride: ED GLi

Location: Brisbane
QLD, Australia

for the cost of a motor conversion you could get a later model e-series and go from there

i also love the EA-ED shape but CFI is totally useless
in my opinion

 

_________________

and on the eighth day God created the Falcon

Top
 Profile  
 
 
Posted: Fri Jul 06, 2007 8:14 pm 
Fordmods Junkie
Offline
User avatar

Age: 31

Posts: 1175

Joined: 23rd Mar 2005

Gallery: 6 images

Ride: 1994 ED Fairmont

Location: Brisbane
QLD, Australia

Well my motor conversion(AU). the buying of my car. rego and roadworthy came to under 2000 and if u got a later e series for 2k it would be a s**t lol but yeah CFI was bad... bloody gutless... 120Kw 3.9L "shudders" a 3.0L pulls that.

 

_________________

1994 ED Fairmont Champaign Gold - AU Series II Intech 4.0L - EL EFI - Thermo Fans - 4.11 LSD - Pacemaker 4480 Into Custom 3" Exhaust - Shift Kit
In Progress: EL 4 Speed Auto- 3000 STALL - To be fitted
EF Tickford Race Spec Head Port- In the shop
Custom SureCam - Chiptorque

Top
 Profile  
 
 
Posted: Sat Jul 07, 2007 1:09 pm 
Getting Side Ways
Offline
User avatar

Age: 37

Posts: 1421

Joined: 5th Nov 2004

Ride: 98 EL Falcon - Last of the EL's

Location: Muswellbrook
NSW, Australia

thanks for the replys fellas, when i sed it was tempting to do a BA motor conversion i was mostly joking :lol:
but back on topic, i think it Might be my fuel pump, cuase when i give it a boot load it struggles then i back off for about a second and get back on it, it goes back to normal.

does that sound like the fuel pump?

 

_________________

why are women like clouds? eventually they f**k off and its a really nice day.

telling the truth is just lack of imagination

Top
 Profile  
 
 
Posted: Tue Jul 17, 2007 5:13 pm 
Getting Side Ways
Offline
User avatar

Age: 37

Posts: 1421

Joined: 5th Nov 2004

Ride: 98 EL Falcon - Last of the EL's

Location: Muswellbrook
NSW, Australia

*Update*

went and got the fuel pump/pressure checked and it all checked out fine, i had the timing re-done (professionally) and its all good, the intake manifold isnt leaking that badly (VERY minor leak) but im happy to report that the cooling system is behaving itself finally, but the struggling problem still stubbornly hangs around any other ideas? oh one more thing, when it is warming up/cold it runs fairly normally its only when it gets up to operating temperature that it starts acting like a pig.

and another problem has popped its head up: my other car's battery drained when i took it for a run (illegally :shock: ) so i went and got my other car and drove it down and left it running as i took the battery out of it and put it into the V8, i put the V8's battery into the six whilst the six was still running so i could charge up the V8's battery, but now the battery light in my 6cyl wont piss off even with a Fully charged battery back in it any ideas on that?

 

_________________

why are women like clouds? eventually they f**k off and its a really nice day.

telling the truth is just lack of imagination

Top
 Profile  
 
 
Posted: Tue Jul 17, 2007 6:05 pm 
Stock as a Rock
Offline

Age: 29

Posts: 181

Joined: 3rd May 2007

Location: pinjarra
WA, Australia

my very first car was cfi ea with a 5sp manual went bloody hard for stock use to waist tyres all day in second cog with 2.92 locker put 3.45 in it and use to eat comodore 5lt all day it was a freak (16 sets in 3 months) only ever brock altanater belts all the time.... the funnyest part was it was a WAGGIN lowered with matress in the back lol
Top
 Profile  
 
Display posts from previous:
Sort by  
 Page 1 of 1  [ 14 posts ] 

Who is online

Users browsing this forum: No registered users and 11 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

 

 

It is currently Tue Dec 12, 2017 6:41 am All times are UTC + 11 hours

 

 

(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names