Fordmods Logo

knock sensor 

 

Page 1 of 1 [ 10 posts ] 

 
 Post subject: knock sensor
Posted: Thu Aug 23, 2007 6:19 pm 
Oompa Loompa
Offline

Age: 35

Posts: 45

Joined: 17th Mar 2005

Gallery: 3 images

Ride: EFII Manual

Location: Sydney
NSW, Australia

hey guys,

hoping someone can help me out. i have had some pinging happening and had my car diagnosed as crank angle sensor and knock sensor failed. had the crank angle sensor sorted out with a major service to compliment butthe knocking has gotten worse and i have looked everywhere for a knock sensor.

Apparently they are obsolete thru ford, repco, auto one etc. does anyone know if there is a aftermarket version made that is still available or what i can do. i dont know what it looks like or how to find and fit it.

any help at all please??

cheers

 

_________________

Im here for a good time not a long one.

Top
 Profile  
 
 
Posted: Thu Aug 23, 2007 6:57 pm 
Getting Side Ways
Offline
User avatar

Age: 46

Posts: 8590

Joined: 5th Nov 2004

Gallery: 5 images

Ride: AU Fairlane 5.0, KE Laser, 01 Kw

Location: Melbourne
VIC, Australia

It's underneath the intake mate, it screws into the block just below the head from memory.
I prob have 1 here somewhere but would have to look tomorrow.
Top
 Profile  
 
 
Posted: Thu Aug 23, 2007 7:26 pm 
Parts Gopher
Offline
User avatar

Posts: 69

Joined: 27th Dec 2006

Ride: EF Wagon

Location: Canberra - not as bad as you think
ACT, Australia

My car had a pinging problem and it turned out I had a set of dud spark plug leads. Changed the leads and put in NGK XR6 (colder) spark plugs and problem fixed.

Might be worth testing your leads for resistance with a multimeter.

Can't guarantee this will fix your problem, but worth checking - and cheap.

Mild mods like compression increases, extractors & air intakes can also cause pinging or make it worse.

 

_________________

96 EF Wagon, PRINS VSI LPG, Wade 1636, 4480's, Redback zorst, Metalcat, 3 angle valve job, .5mm overbore, hypertec pistons, shaved head (because the head was banana shaped when I brought it), Tickford 16" alloys, KYB shocks, 30mm sway bar, 1 1/2 degrees negative camber, tow bar, roof racks.

Top
 Profile  
 
 
Posted: Fri Aug 24, 2007 1:52 pm 
Oompa Loompa
Offline

Age: 35

Posts: 45

Joined: 17th Mar 2005

Gallery: 3 images

Ride: EFII Manual

Location: Sydney
NSW, Australia

hey mate.

unfortunately i have a new set of plugs and leads which i replaced only 3 days ago and it still isnt working..

the diagnostics machine reported a fault with the knock sensor but i thought i might as well replace the leads and plugs.

thanks for help though mate.

will try and find what it looks like.

cheers guys.

 

_________________

Im here for a good time not a long one.

Top
 Profile  
 
 
Posted: Fri Aug 24, 2007 9:18 pm 
Getting Side Ways
Offline

Age: 48

Posts: 429

Joined: 3rd Jan 2005

Ride: AU XR6 with BF Turbo engine

Location: Sydney
NSW, Australia

where in sydney are you? I have a spare knock sensor floating around here somewhere

 

_________________

RIP :( 1x confused Falcon..EL Falcon with full AU running gear...VCT, 5 speed, IRS, AUII front suspension, brakes, and steering RIP

Top
 Profile  
 
 
Posted: Sun Aug 26, 2007 5:16 am 
Oompa Loompa
Offline

Age: 35

Posts: 45

Joined: 17th Mar 2005

Gallery: 3 images

Ride: EFII Manual

Location: Sydney
NSW, Australia

hey mac

im located in hornsby mate but happy to drive if necessary.

cheers to everyone so far for the help.

hopefully come to a cruise soon and not be pinging my a** off.

 

_________________

Im here for a good time not a long one.

Top
 Profile  
 
 
Posted: Sun Aug 26, 2007 1:27 pm 
Getting Side Ways
Offline

Age: 48

Posts: 429

Joined: 3rd Jan 2005

Ride: AU XR6 with BF Turbo engine

Location: Sydney
NSW, Australia

im in mascot on the weekends etc and work in Arncliffe, if you let me know when you might swing by I'll make sure i got it handy

 

_________________

RIP :( 1x confused Falcon..EL Falcon with full AU running gear...VCT, 5 speed, IRS, AUII front suspension, brakes, and steering RIP

Top
 Profile  
 
 
Posted: Tue Aug 28, 2007 10:54 am 
Oompa Loompa
Offline

Age: 35

Posts: 45

Joined: 17th Mar 2005

Gallery: 3 images

Ride: EFII Manual

Location: Sydney
NSW, Australia

hey mac pm sent.

cheers

 

_________________

Im here for a good time not a long one.

Top
 Profile  
 
 
Posted: Tue Aug 28, 2007 12:29 pm 
Smokin em up
Offline

Age: 41

Posts: 220

Joined: 5th Nov 2004

Ride: el futura

Location: melbourne
VIC, Australia

I have a pinging problem aswell, someone told me it was the timing chain.

 

_________________

Image

Top
 Profile  
 
 
Posted: Tue Aug 28, 2007 1:05 pm 
Oompa Loompa
Offline

Age: 35

Posts: 45

Joined: 17th Mar 2005

Gallery: 3 images

Ride: EFII Manual

Location: Sydney
NSW, Australia

hey mac

i am leaving to go up the coast for a few days on wednesday afternoon.

is it possible to swing by tonight and pick it up??

what do you want for it??

to make things easier my mobile is 0402432022

cheers mate

 

_________________

Im here for a good time not a long one.

Top
 Profile  
 
Display posts from previous:
Sort by  
 Page 1 of 1  [ 10 posts ] 

Who is online

Users browsing this forum: No registered users and 31 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

 

 

It is currently Wed Dec 13, 2017 6:59 pm All times are UTC + 11 hours

 

 

(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names