Fordmods Logo

Lack of Power After 3500 RPM - SOLVED!! UNBELIEVABLE PICS!!! 

 

Page 2 of 3 [ 33 posts ] Go to page Previous  1, 2, 3  Next

 
Posted: Thu Mar 02, 2006 10:37 pm 
Getting Side Ways
Offline
User avatar

Posts: 916

Joined: 27th Nov 2004

Gallery: 4 images

Ride: EL Futura

Location: Berri
SA, Australia

Replace your fuel filter. $24 and if nothing else will give you peace of mind.

Mine was shot and made a huge difference to power.

 

_________________

5 Speed EL Futura
Stock as a rock*
Image
A1 Oils - Synthetic lubricants: www.a1oils.com.au
* A rock that has been Alted

Top
 Profile  
 
 
 Post subject: ??
Posted: Fri Mar 03, 2006 8:47 am 
Getting Side Ways
Offline

Posts: 476

Joined: 28th Jan 2005

Ride: 1990 EA Spac

Location: grenfell
NSW, Australia

If u watch the vac unit at the front of the BBM and get someone to start the car, the vac unit should pull in after a few seconds and should only move out at about 3500 rpm. If it moves around when the throttle is moved it sounds like the vac line is connected incorrectly.. see if you can look at a mates and check.

 

_________________

Drive safe, arrive alive

EA Spak EL dash and interior, thermo's,BBM, EF head and cam, superlows,

Top
 Profile  
 
 
Posted: Fri Mar 03, 2006 1:17 pm 
Getting Side Ways
Offline
User avatar

Posts: 916

Joined: 27th Nov 2004

Gallery: 4 images

Ride: EL Futura

Location: Berri
SA, Australia

3800rpm is the magical figure I believe.

 

_________________

5 Speed EL Futura
Stock as a rock*
Image
A1 Oils - Synthetic lubricants: www.a1oils.com.au
* A rock that has been Alted

Top
 Profile  
 
 
Posted: Fri Mar 03, 2006 3:04 pm 
Getting Side Ways
Offline
User avatar

Age: 33

Posts: 3277

Joined: 5th Nov 2004

Gallery: 36 images

Ride: Ronald Mcdonald Mobile

Location: Sydney
NSW, Australia

dsheps83 wrote:
i had something similar to that after around 3 grand the car lost heaps of power went about 130 flayout but when driving around town it seemed normal unless i put my foot in it. it happened to be the cat it had caved in


same happened to me a few months ago

 

_________________

Gooooone - Eb2 Coon - 143RWKW
Now - Mazda MX5 with HKS Supercharger 190RWKW
Crescent Motorsport Liverpool - 9600 6229

Top
 Profile  
 
 
Posted: Fri Mar 03, 2006 10:27 pm 
Getting Side Ways
Offline
User avatar

Age: 37

Posts: 1339

Joined: 7th Nov 2004

Gallery: 3 images

Ride: FGX G6ET

Location: Worrigee
NSW, Australia

OK, I just checked it out...the unit pulls in when the car is idling...then when the revs go over the magic number, it releases as it should...

I checked the gregories, as suggested by Ray (snap0964) and the voltage on the connector that control the valve should be 0V when idling, and battery voltage when revving over the 3800 limit...but mine is oposite, I get battery voltage when idle and 0V when over 3800...Gregories wrong? Could someone verify this? Must be wrong, as my vavle seems to be operating as it should...I'll try replacing the fuel filter tomorrow, see if that does anything...
Self test brings up no faults...havent checked the cat yet...timing is spot on.
Top
 Profile  
 
 
Posted: Sat Mar 04, 2006 1:00 am 
Smokin em up
Offline
User avatar

Age: 31

Posts: 247

Joined: 24th Nov 2005

Location: Brissy
QLD, Australia

i would say it is your fuel pump, my old EB was starting too top out at 140km/hr when overtaking b-double road trains. No more power at all, ended up being the fuel pump. Was okay around town though, hard too diagnose.
Top
 Profile  
 
 
 Post subject: ??
Posted: Sat Mar 04, 2006 8:17 am 
Getting Side Ways
Offline

Posts: 476

Joined: 28th Jan 2005

Ride: 1990 EA Spac

Location: grenfell
NSW, Australia

I think you are measuring the voltage the wrong way. You are measuring using earth/chassis to the wire. But this unit uses positive for its common so you get a reversed reading. It is operating the correct way so dont worry.

 

_________________

Drive safe, arrive alive

EA Spak EL dash and interior, thermo's,BBM, EF head and cam, superlows,

Top
 Profile  
 
 
Posted: Sat Mar 04, 2006 8:41 am 
Getting Side Ways
Offline
User avatar

Age: 32

Posts: 4401

Joined: 25th Mar 2005

Ride: BA XT, BA XR6T, ED Ghia 5.0

Location: Perth
WA, Australia

Accelerator cable not stretched to s**t?

 

_________________

What's the difference between a Holden and a sheep? It's less embarrasing getting out of the back of a sheep..

Top
 Profile  
 
 
Posted: Sat Mar 04, 2006 9:22 am 
Getting Side Ways
Offline
User avatar

Age: 39

Posts: 1434

Joined: 5th Nov 2004

Gallery: 15 images

Ride: ALTED XR6 - ALTED EA - EF TAXI

Location: Sunshine Coast QLD
QLD, Australia

I;d say cat blocked .....

one way to tell, is get someone to stand and the back of the exhuast with some paper, or something, and see if the air flows out the exhuast ... if its the standard cat, I've seen the collaspe many times.
Top
 Profile  
 
 
Posted: Sat Mar 04, 2006 11:23 am 
Technical Contributor
Offline
User avatar

Age: 53

Posts: 5589

Joined: 14th Jan 2005

Gallery: 10 images

Ride: 96 XH/97 EL

Location: South Coast
NSW, Australia

Dave, a bit more info on blocked cats:

http://www.fordmods.com/forums/viewtopi ... highlight=

http://www.fordmods.com/forums/viewtopi ... highlight=

http://www.fordmods.com/forums/viewtopi ... highlight=

Some you've probably read before, but revisiting them wouldn't hurt.

 

_________________

96 XH Longreach 'S': LPG, Alarm, 3.23:1 LSD, Cruise, Trip Comp, ABS, Power Windows, Mid Series Dome Lt, Climate Ctrl
97 EL Futura S/W: LPG, Alarm, LED int Lts, Trip Comp, F/Lane Dome Lt, Climate Ctrl, T5 Conversion

Top
 Profile  
 
 
Posted: Sat Mar 04, 2006 4:01 pm 
Getting Side Ways
Offline
User avatar

Age: 37

Posts: 1339

Joined: 7th Nov 2004

Gallery: 3 images

Ride: FGX G6ET

Location: Worrigee
NSW, Australia

Could this be the probelm....lol......

ImageImage Image Image Image

I have had the car for just over a year so its a bit overdue, but that thing must have been in there for AGES!!!
Just took the car for a quick spin, certainly seems to have solved the problem as far as I can tell....doesnt really surprise me! :D

Oh and thanks for the info on blocked cats, good to know!!! :)
Top
 Profile  
 
 
Posted: Sat Mar 04, 2006 5:16 pm 
ACT Cruise Moderator
Offline
User avatar

Age: 36

Posts: 6275

Joined: 24th Nov 2004

Ride: '06 BF GT-P

Power: 293 rwkw

Location: Canberra
ACT, Australia

Can you say 'never been changed'. That's nasty. Or you (or previous owner) get really s**t fuel.

 

_________________

1998 DL LTD in Sparkling Burgundy, daily, 302W, stereo, slow - 97.5rwkw
2006 BF GT-P in Ego, mods. 293rwkw - 12.427@109 - 0-1000m 24.838@221

Top
 Profile  
 
 
Posted: Sat Mar 04, 2006 6:14 pm 
Getting Side Ways
Offline
User avatar

Posts: 916

Joined: 27th Nov 2004

Gallery: 4 images

Ride: EL Futura

Location: Berri
SA, Australia

AH HA!!!

Do I get 10 points for that one? Told ya! ;) Cus my car was a slug with a blocked fuel filter too.. Fitted a stage 3 cam, and had a dyno run, and lost power :(

 

_________________

5 Speed EL Futura
Stock as a rock*
Image
A1 Oils - Synthetic lubricants: www.a1oils.com.au
* A rock that has been Alted

Top
 Profile  
 
 
Posted: Sat Mar 04, 2006 6:39 pm 
Technical Contributor
Offline
User avatar

Age: 53

Posts: 5589

Joined: 14th Jan 2005

Gallery: 10 images

Ride: 96 XH/97 EL

Location: South Coast
NSW, Australia

Well done Dave - me thinks you're noting down when things are changed/serviced, etc. Might be worth pulling the fuel pump, just to check the pickup gauze doesn't look similar.

 

_________________

96 XH Longreach 'S': LPG, Alarm, 3.23:1 LSD, Cruise, Trip Comp, ABS, Power Windows, Mid Series Dome Lt, Climate Ctrl
97 EL Futura S/W: LPG, Alarm, LED int Lts, Trip Comp, F/Lane Dome Lt, Climate Ctrl, T5 Conversion

Top
 Profile  
 
 
Posted: Sat Mar 04, 2006 6:53 pm 
Getting Side Ways
Offline
User avatar

Age: 58

Posts: 1080

Joined: 5th Nov 2004

Ride: Xf Ghia

Location: Melb
VIC, Australia

I agree whole heartedly!! well diagnosed guys!!

Its normally the most simple things that are overlooked..
weakest link in the chain etc

Simple monitoring of fuel econ etc usually gives it away

Years ago when i used to rally my motor suddenly under performed
whilst squaring corners.. VERY HAIRY!!

After spending numerous hours and money you wouldnot believe what the problem was!!!

Everything pointed to fuel delivery right? throwing the car around corners
surging etc guess what it was!!!!!

:lol: :lol: :lol:

 

_________________

Death to DOOF DOOF!!

Top
 Profile  
 
Display posts from previous:
Sort by  
 Page 2 of 3  [ 33 posts ]  Go to page Previous  1, 2, 3  Next

Who is online

Users browsing this forum: Google [Bot] and 27 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

 

 

It is currently Mon Dec 18, 2017 4:52 pm All times are UTC + 11 hours

 

 

(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names