Fordmods Logo

Lack of Power After 3500 RPM - SOLVED!! UNBELIEVABLE PICS!!! 

 

Page 3 of 3 [ 33 posts ] Go to page Previous  1, 2, 3

 
Posted: Sat Mar 04, 2006 7:46 pm 
Getting Side Ways
Offline
User avatar

Age: 37

Posts: 1339

Joined: 7th Nov 2004

Gallery: 3 images

Ride: FGX G6ET

Location: Worrigee
NSW, Australia

Yep, thanks for the help guys...that filter looks SHOCKING...if it wasn't a Ryco one I would have said it was the original!

Good idea Ray, I might pull the fuel pump and check the gauze out...

I always use premium, usually Optimax...

NOW...please check out my new thread...Ive got another drama...NOT MY WEEK!!! :(
Top
 Profile  
 
 
Posted: Sun Mar 05, 2006 2:24 pm 
Getting Side Ways
Offline
User avatar

Age: 48

Posts: 2537

Joined: 5th Nov 2004

Gallery: 13 images

Ride: EFII Fairmont

Location: Perth
WA, Australia

Man that is so bad, I've reported it as offensive material at imageshack 8-) Unbelievable!
Top
 Profile  
 
 
Posted: Sun Mar 05, 2006 2:48 pm 
Getting Side Ways
Offline
User avatar

Age: 37

Posts: 1339

Joined: 7th Nov 2004

Gallery: 3 images

Ride: FGX G6ET

Location: Worrigee
NSW, Australia

lol!
Top
 Profile  
 
Display posts from previous:
Sort by  
 Page 3 of 3  [ 33 posts ]  Go to page Previous  1, 2, 3

Who is online

Users browsing this forum: No registered users and 13 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

 

 

It is currently Mon Dec 18, 2017 3:29 am All times are UTC + 11 hours

 

 

(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names