Fordmods Logo

Leaking coolant problem HELP! 

 

Page 2 of 2 [ 20 posts ] Go to page Previous  1, 2

 
 Post subject: Re: Leaking coolant problem HELP!
Posted: Fri Jan 28, 2011 4:57 pm 
Fordmods Junkie
Offline
User avatar

Posts: 11739

Joined: 17th May 2005

Gallery: 11 images

Ride: EL Fairmont, VFR400 racer

Power: 144 rwkw

Location: Melbourne
VIC, Australia

teeroy wrote:
dc_todd wrote:
replace heater tap and heater feed hose.


how much am i looking at roughly and wheres the closest ford parts to laverton that i can go to tomorrow.
or where else can i get them?
thanks for the help too.


Head to Bursons or Repco, they should have them in stock. I got mine from Repco. There is one on Millers Rd in Altona...just after you pass Altona Gates. Don't think there is any closer Burson.

Can't remember price, but no more than $30 I would think.

 

_________________

phongus = Post whore 2006
EL XR6 motor, EL ECU + J3 chip, WADE 1673 Camshaft, 3" S/S intake, Pacy 4480, 2.5" Hi flow cat, 2.5" Lukey exhaust.
Max Power = 144.6 rwkw (03/05/2008)

Top
 Profile  
 
 
 Post subject: Re: Leaking coolant problem HELP!
Posted: Fri Jan 28, 2011 10:05 pm 
Tyre Shredder
Offline
User avatar

Age: 25

Posts: 398

Joined: 16th May 2010

Ride: 2010 G6E

Location: Melbourne
VIC, Australia

phongus wrote:
teeroy wrote:
dc_todd wrote:
replace heater tap and heater feed hose.


how much am i looking at roughly and wheres the closest ford parts to laverton that i can go to tomorrow.
or where else can i get them?
thanks for the help too.


Head to Bursons or Repco, they should have them in stock. I got mine from Repco. There is one on Millers Rd in Altona...just after you pass Altona Gates. Don't think there is any closer Burson.

Can't remember price, but no more than $30 I would think.


theres bursons in hoppers on old geelong rd. along with repco and every other parts store imaginable.
so i'm just asking for a EL heater tap and the correct hose yeah?

 

_________________

be good or be good at it.

Top
 Profile  
 
 
 Post subject: Re: Leaking coolant problem HELP!
Posted: Fri Jan 28, 2011 10:25 pm 
Fordmods Junkie
Offline
User avatar

Posts: 11739

Joined: 17th May 2005

Gallery: 11 images

Ride: EL Fairmont, VFR400 racer

Power: 144 rwkw

Location: Melbourne
VIC, Australia

teeroy wrote:
phongus wrote:
teeroy wrote:
dc_todd wrote:
replace heater tap and heater feed hose.


how much am i looking at roughly and wheres the closest ford parts to laverton that i can go to tomorrow.
or where else can i get them?
thanks for the help too.


Head to Bursons or Repco, they should have them in stock. I got mine from Repco. There is one on Millers Rd in Altona...just after you pass Altona Gates. Don't think there is any closer Burson.

Can't remember price, but no more than $30 I would think.


theres bursons in hoppers on old geelong rd. along with repco and every other parts store imaginable.
so i'm just asking for a EL heater tap and the correct hose yeah?


Yeah pretty much. Hopefully they know which hose...if you can also get new clamps.

 

_________________

phongus = Post whore 2006
EL XR6 motor, EL ECU + J3 chip, WADE 1673 Camshaft, 3" S/S intake, Pacy 4480, 2.5" Hi flow cat, 2.5" Lukey exhaust.
Max Power = 144.6 rwkw (03/05/2008)

Top
 Profile  
 
 
 Post subject: Re: Leaking coolant problem HELP!
Posted: Sat Jan 29, 2011 3:45 pm 
Tyre Shredder
Offline
User avatar

Age: 25

Posts: 398

Joined: 16th May 2010

Ride: 2010 G6E

Location: Melbourne
VIC, Australia

hose end was fine, only ended up replacing heater tap, as we found a crack. $17.95 from bursons, so not bad at all.
thanks for the help guys.

 

_________________

be good or be good at it.

Top
 Profile  
 
 
 Post subject: Re: Leaking coolant problem HELP!
Posted: Sat Jan 29, 2011 5:32 pm 
Fordmods Junkie
Offline
User avatar

Posts: 11739

Joined: 17th May 2005

Gallery: 11 images

Ride: EL Fairmont, VFR400 racer

Power: 144 rwkw

Location: Melbourne
VIC, Australia

teeroy wrote:
hose end was fine, only ended up replacing heater tap, as we found a crack. $17.95 from bursons, so not bad at all.
thanks for the help guys.


No problem...hopefully that's all it was :).

 

_________________

phongus = Post whore 2006
EL XR6 motor, EL ECU + J3 chip, WADE 1673 Camshaft, 3" S/S intake, Pacy 4480, 2.5" Hi flow cat, 2.5" Lukey exhaust.
Max Power = 144.6 rwkw (03/05/2008)

Top
 Profile  
 
Display posts from previous:
Sort by  
 Page 2 of 2  [ 20 posts ]  Go to page Previous  1, 2

Who is online

Users browsing this forum: No registered users and 13 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

 

 

It is currently Fri Dec 15, 2017 10:25 am All times are UTC + 11 hours

 

 

(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names