Fordmods Logo

Lifter noise and possible misfiring after cam installed 

 

Page 1 of 1 [ 6 posts ] 

 
 Post subject: Lifter noise and possible misfiring after cam installed
Posted: Sat Jan 28, 2012 11:40 am 
Stock as a Rock
Offline

Posts: 145

Joined: 4th Aug 2010

Ride: BA Ghia '03

Got a wade 1673 regrind cam installed in my EL (with the hybrid head) the other day, however it sounds like it's got a fair bit of lifter noise. How do I go about fixing this? The lifters I used were from the original EL hybrid rocker arms, they fit but seemed a real tight fit, and I am using ED XR6 rocker arms. I have another set but they're from the same ED XR6, same size but they are a tiny little loose. Should I fix the current lifters, or give these other lifters a go, or do I have to get specific lifters for a regrind cam? And how do I tell what lifters need replacing?

Now the exhaust sounds fair lumpy but when driving it makes a popping noise. I had to replace one of my leads (anyway) but it still does it, how do I check if all 6 cylinders are getting proper spark? I am not blowing any smoke out, fuel economy seems fine, and I don't appear to be losing or gaining power at this point.

Cheers.
Top
 Profile  
 
 
 Post subject: Re: Lifter noise and possible misfiring after cam installed
Posted: Sat Jan 28, 2012 11:59 am 
Getting Side Ways
Offline
User avatar

Age: 25

Posts: 4599

Joined: 30th Aug 2010

Ride: BF XR6,

Location: NEWCASTLE
NSW, Australia

Did you put an extra set of shims in for the regrind cam?

 

_________________

BF XR6
xr8 snorkel,typhoon lower snorkel,territory intake pipe,20% underdrive kit,pacemaker extractors,high flow cat,xforce exhaust,t56 conversion hd turbo clutch/ flywheel,m86 3.45 lsd,custom tune187.1rwkw as an auto

Top
 Profile  
 
 
 Post subject: Re: Lifter noise and possible misfiring after cam installed
Posted: Sat Jan 28, 2012 12:01 pm 
Stock as a Rock
Offline

Posts: 145

Joined: 4th Aug 2010

Ride: BA Ghia '03

2 extra shims in fact. 1 wasn't enough. I should have stated this in my OP.
Top
 Profile  
 
 
 Post subject: Re: Lifter noise and possible misfiring after cam installed
Posted: Sat Jan 28, 2012 12:17 pm 
Technical Contributor
Offline

Age: 60

Posts: 6817

Joined: 22nd Jun 2005

Gallery: 8 images

Ride: EF Fairmont

Location: Campbelltown
NSW, Australia

How long ago did you fit the cam? It can take a few days in some cases for the lifters to pump up properly.

Tech90 wrote:
2 extra shims in fact. 1 wasn't enough. I should have stated this in my OP.


Are you saying that you are running 3 shims?
Top
 Profile  
 
 
 Post subject: Re: Lifter noise and possible misfiring after cam installed
Posted: Sat Jan 28, 2012 12:25 pm 
Stock as a Rock
Offline

Posts: 145

Joined: 4th Aug 2010

Ride: BA Ghia '03

That's right. There was a fair bit of a gap between the end of the lifter and the top of the valve springs, moved them with my hand and they were making that same ticking noise. So I added a third set of shims in each arm, it closed the gap and makes proper contact but the same noise is still there. I don't remember the lifters being bleeded out or anything. Just straight swapped from my EL hybrid rocker arms into the ED XR6 ones. I've heard of a few cases where 3 shims are needed for ED arms on a hybrid head...

Cam was fitted 3 days ago, but I don't think it's going to go away, hence why I think there's something wrong with the lifters, although they were nice and quiet before the cam install.
Top
 Profile  
 
 
 Post subject: Re: Lifter noise and possible misfiring after cam installed
Posted: Sat Jan 28, 2012 2:41 pm 
Getting Side Ways
Offline
User avatar

Age: 25

Posts: 4599

Joined: 30th Aug 2010

Ride: BF XR6,

Location: NEWCASTLE
NSW, Australia

i think instead of swapping the s**t over you shouldve left it as the au head gear if it was a hybrid el motor, or swapped a whole e series head onto the car

 

_________________

BF XR6
xr8 snorkel,typhoon lower snorkel,territory intake pipe,20% underdrive kit,pacemaker extractors,high flow cat,xforce exhaust,t56 conversion hd turbo clutch/ flywheel,m86 3.45 lsd,custom tune187.1rwkw as an auto

Top
 Profile  
 
Display posts from previous:
Sort by  
 Page 1 of 1  [ 6 posts ] 

Who is online

Users browsing this forum: tripleexpansion and 25 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

 

 

It is currently Mon Dec 18, 2017 10:57 am All times are UTC + 11 hours

 

 

(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names