Fordmods Logo

loss of power at high rev 

 

Page 1 of 1 [ 9 posts ] 

 
 Post subject: loss of power at high rev
Posted: Sun Sep 24, 2006 12:57 pm 
Parts Gopher
Offline
User avatar

Age: 37

Posts: 56

Joined: 17th Jul 2006

Location: melbourne
VIC, Australia

hi i have an au ute dedicated gas manual every time it revs rnd the 4grand mark it feels like its loosing power almost like it aint getting gas any suggestions what it could be
Top
 Profile  
 
 
Posted: Sun Sep 24, 2006 2:08 pm 
Getting Side Ways
Offline
User avatar

Age: 46

Posts: 8590

Joined: 5th Nov 2004

Gallery: 5 images

Ride: AU Fairlane 5.0, KE Laser, 01 Kw

Location: Melbourne
VIC, Australia

A lot of possiblities there mate, but those convertors are known for their problems, don't price a new one because you will s**t yourself literally lol.
It could be blocked filter, stepper motor, convertor, even the ecu or oxy sensor.
Top
 Profile  
 
 
Posted: Sun Sep 24, 2006 2:30 pm 
Fordmods Junkie
Offline
User avatar

Posts: 3083

Joined: 22nd Sep 2005

Gallery: 13 images

Ride: EF

Location: Melbourne
VIC, Australia

a simple thing to check is the bbm switch over, if its working, it'll move the arm up when you rev over 3800rpm

btw said valve is on the front of the intake manifold.

 

_________________

Image
latest mod: A Service
MY BUILD THREAD

Top
 Profile  
 
 
Posted: Sun Sep 24, 2006 4:45 pm 
Parts Gopher
Offline
User avatar

Age: 37

Posts: 56

Joined: 17th Jul 2006

Location: melbourne
VIC, Australia

i have had to get a new converter already i s**t myself when i heard the price hope its not stuffed again i look at the other options you have given cheers il keep u posted on what happends :idea:
Top
 Profile  
 
 
Posted: Sun Sep 24, 2006 5:01 pm 
Parts Gopher
Offline
User avatar

Age: 37

Posts: 56

Joined: 17th Jul 2006

Location: melbourne
VIC, Australia

would a cracked head or head gasket be causing this i am loosing coolant and my oil appears milky what do you think

 

 

Attachments:
Picture 004.jpg
Picture 004.jpg [ 71.93 KiB | Viewed 39 times ]
Picture 005.jpg
Picture 005.jpg [ 103.91 KiB | Viewed 34 times ]
Picture 003.jpg
Picture 003.jpg [ 114.52 KiB | Viewed 19 times ]
Top
 Profile  
 
 
Posted: Sun Sep 24, 2006 8:45 pm 
Stock as a Rock
Offline
User avatar

Posts: 100

Joined: 18th Nov 2004

Ride: turbo

Location: melb
VIC, Australia

a mechanic might be able to tell you
Top
 Profile  
 
 
Posted: Sun Sep 24, 2006 9:09 pm 
Getting Side Ways
Offline

Age: 36

Posts: 3794

Joined: 9th Aug 2005

Ride: Hilux

Location: Mornington
VIC, Australia

hard to tell from all those pics.
the one of the dip stick, wipe it off and dip it in again so you can get a more ccurate level and colour.

But, loosing cooland + milky oil doesnt sound good sorry. Real good signs of head / gasket

 

_________________

Now driving a Hilux

Top
 Profile  
 
 
Posted: Sun Sep 24, 2006 9:34 pm 
Parts Gopher
Offline
User avatar

Age: 37

Posts: 56

Joined: 17th Jul 2006

Location: melbourne
VIC, Australia

yeah thats what im thinking il take it to the mechanic tom
Top
 Profile  
 
 
Posted: Mon Sep 25, 2006 12:42 pm 
Getting Side Ways
Offline
User avatar

Age: 46

Posts: 8590

Joined: 5th Nov 2004

Gallery: 5 images

Ride: AU Fairlane 5.0, KE Laser, 01 Kw

Location: Melbourne
VIC, Australia

Ummm yeah i reckon that might be a part of your problem LOL.
Top
 Profile  
 
Display posts from previous:
Sort by  
 Page 1 of 1  [ 9 posts ] 

Who is online

Users browsing this forum: Locko90 and 30 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

 

 

It is currently Fri Dec 15, 2017 7:36 pm All times are UTC + 11 hours

 

 

(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names