Fordmods Logo

Loud 'POP', Car stalled, Electrical smell...? 

 

Page 1 of 1 [ 6 posts ] 

 
 Post subject: Loud 'POP', Car stalled, Electrical smell...?
Posted: Sun Oct 10, 2010 7:40 pm 
Fordmods Newbie
Offline

Age: 31

Posts: 12

Joined: 6th Oct 2010

Ride: AU II FAIRLANE

Location: Brisbane
QLD, Australia

I was just driving home and stopped at the lights about two streets away from our place.

All of a sudden, there was a huge POP from what seemed to be under the passenger side of the bonnet/dash, the car stalled and then there was an electrical burning smell!
It managed to start up again and I drove home.

Anyone know what this could be?

PS: Car runs LPG if that makes a difference.
Top
 Profile  
 
 
 Post subject: Re: Loud 'POP', Car stalled, Electrical smell...?
Posted: Sun Oct 10, 2010 7:49 pm 
Getting Side Ways
Offline
User avatar

Age: 31

Posts: 886

Joined: 17th Aug 2005

Gallery: 24 images

Ride: VZ SS 6Ltr ute, Honda VFR800

Location: Melbourne
VIC, Australia

sounds like it backfired..

 

_________________

My Cars
2006 VZ SS cammed 6Ltr ute 295rwkW
2004 BA XR6T - 290rwkW 12.5@113mph ( SOLD )
1996 EFII Fairmont - 130rwkW 15.5@91mph ( SOLD )

Top
 Profile  
 
 
 Post subject: Re: Loud 'POP', Car stalled, Electrical smell...?
Posted: Sun Oct 10, 2010 7:51 pm 
Fordmods Newbie
Offline

Age: 31

Posts: 12

Joined: 6th Oct 2010

Ride: AU II FAIRLANE

Location: Brisbane
QLD, Australia

Why would a backfire cause a burning electrical smell...?

Never had a backfire that's caused that.
Top
 Profile  
 
 
 Post subject: Re: Loud 'POP', Car stalled, Electrical smell...?
Posted: Sun Oct 10, 2010 7:57 pm 
Getting Side Ways
Offline
User avatar

Age: 31

Posts: 886

Joined: 17th Aug 2005

Gallery: 24 images

Ride: VZ SS 6Ltr ute, Honda VFR800

Location: Melbourne
VIC, Australia

possibly the inside of your air intake burning or your air filter.
have you checked your airfilter?? because if it was a backfire it may not be in place properly.. Happend on my old EF sometimes when the Gas system was out of tune (running a little lean).

 

_________________

My Cars
2006 VZ SS cammed 6Ltr ute 295rwkW
2004 BA XR6T - 290rwkW 12.5@113mph ( SOLD )
1996 EFII Fairmont - 130rwkW 15.5@91mph ( SOLD )

Top
 Profile  
 
 
 Post subject: Re: Loud 'POP', Car stalled, Electrical smell...?
Posted: Sun Oct 10, 2010 10:19 pm 
Stock as a Rock
Offline
User avatar

Posts: 108

Joined: 12th Jun 2010

Ride: El falcon

Location: melbourne
VIC, Australia

have a look at your airbox clips, probably stretched to buggery.

 

_________________

I enjoy the symphony of mechanical harmony, :lol:

EL build thread
Turbo DOHC - AU front suspension - AU IRS - T56 - xr kit
the-garage-f53/bbqburners-daily-turned-toy-d-t93182.html

Top
 Profile  
 
 
 Post subject: Re: Loud 'POP', Car stalled, Electrical smell...?
Posted: Mon Oct 11, 2010 3:47 pm 
QLD Cruise Moderator
Offline

Age: 52

Posts: 407

Joined: 20th Jul 2009

Gallery: 1 images

Ride: EF Ford Falcon Wagon

Location: Atkinsons Dam an hour out of Brisbane
QLD, Australia

it would be a LPG backfire could have been caused even by the sudden surge as you take off but mine sometimes backfires and either blows a hose off and then runs like crap or just the airfilter line. Hasnt for awhile now fingers crossed

May also be time for new spark plugs?
Top
 Profile  
 
Display posts from previous:
Sort by  
 Page 1 of 1  [ 6 posts ] 

Who is online

Users browsing this forum: Google [Bot], Google Adsense [Bot] and 13 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

 

 

It is currently Thu Dec 14, 2017 12:55 am All times are UTC + 11 hours

 

 

(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names