Fordmods Logo

Misfire at part throttle... fine at WOT.... fixed page 2 

 

Page 3 of 3 [ 34 posts ] Go to page Previous  1, 2, 3

 
Posted: Fri Mar 07, 2008 9:49 am 
Getting Side Ways
Offline

Posts: 6166

Joined: 8th May 2007

Just to follow up, i found that the plug connector going to the coolant temp sensor was rooted and when you pressed on the plug whilst the engine was running, the fans would come on and the car would run really rich.

So i replaced the plug connector, and cleaned the crank angle sensor the best i could and now the car doesnt hesitate at all, hot or cold. Sensor has since been replaced with a new one for good measure

As for the hissing noise when switching the car off, i found the hose going to a heater? vacuum solenoid had come off, fixed that and car doesnt hiss anymore.
Top
 Profile  
 
 
Posted: Fri Mar 07, 2008 12:17 pm 
Getting Side Ways
Offline
User avatar

Posts: 3363

Joined: 27th Dec 2004

Gallery: 4 images

Ride: MCMXCV Falcon

Location: G town
VIC, Australia

so wouldnt the faulty coolant sensor plug have given a bad reading to the dash as well???

did u replace the crank angle or the coolant sensor??

 

_________________

Image

Top
 Profile  
 
 
Posted: Fri Mar 07, 2008 12:57 pm 
Getting Side Ways
Offline

Posts: 6166

Joined: 8th May 2007

gogetta wrote:
so wouldnt the faulty coolant sensor plug have given a bad reading to the dash as well???

did u replace the crank angle or the coolant sensor??


yes replaced both in the end, but the coolant temp sensor's actual plug was playing up.

Funny thing it never played havoc with the gauge, but when you pressed on the plug lightly the engine went beserk and thermos came on, and ran really rich, so was replaced with another plug, and this one is fine
Top
 Profile  
 
 
Posted: Fri Mar 07, 2008 1:01 pm 
Getting Side Ways
Offline
User avatar

Posts: 3363

Joined: 27th Dec 2004

Gallery: 4 images

Ride: MCMXCV Falcon

Location: G town
VIC, Australia

how strange

 

_________________

Image

Top
 Profile  
 
Display posts from previous:
Sort by  
 Page 3 of 3  [ 34 posts ]  Go to page Previous  1, 2, 3

Who is online

Users browsing this forum: No registered users and 26 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

 

 

It is currently Wed Dec 13, 2017 2:57 pm All times are UTC + 11 hours

 

 

(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names