Fordmods Logo

Misfiring under load 

 

Page 1 of 1 [ 7 posts ] 

 
 Post subject: Misfiring under load
Posted: Sat May 15, 2010 9:18 pm 
Fordmods Newbie
Offline

Age: 42

Posts: 8

Joined: 5th May 2010

Ride: AU Futura II

Location: Adelaide
SA, Australia

G'day all

My AUII Futura seems to be misfiring when i put the foot down and only seems to happen when the engine is warm/hot.

It started a few weeks ago so I got it serviced so new plugs etc but not new leads. I also got new headers, high flow cat, and 2.5" system at the same time as the service but the problem remains.

I give it a boot and nothing much happens except it makes a noise like a lawnmower on steroids.

Any ideas??
Top
 Profile  
 
 
 Post subject: Re: Misfiring under load
Posted: Sat May 15, 2010 9:21 pm 
Getting Side Ways
Offline

Posts: 6449

Joined: 11th Nov 2004

did they charge you for plugs?

Spark plugs generally are not included as a regular service item.

Perhaps booking it in for a tune up would have been better

 

_________________

PERMANENTLY BANNED

Top
 Profile  
 
 
 Post subject: Re: Misfiring under load
Posted: Sat May 15, 2010 9:47 pm 
Getting Side Ways
Offline

Age: 26

Posts: 1109

Joined: 4th Sep 2009

Ride: 92 EB s

Location: DORRIGO
NSW, Australia

What plugs and leads did you get?.
Top
 Profile  
 
 
 Post subject: Re: Misfiring under load
Posted: Sat May 15, 2010 10:57 pm 
Fordmods Newbie
Offline

Age: 42

Posts: 8

Joined: 5th May 2010

Ride: AU Futura II

Location: Adelaide
SA, Australia

87SIlude wrote:
What plugs and leads did you get?.


I was charged for 6 platinum plugs and ignition timing reset. Didn't get new leads.....i'm guessing it might be worth replacing these and seeing if it makes a difference?
Top
 Profile  
 
 
 Post subject: Re: Misfiring under load
Posted: Sat May 15, 2010 11:03 pm 
Getting Side Ways
Offline

Age: 36

Posts: 508

Joined: 28th Feb 2009

Gallery: 9 images

Ride: Ed v8 fairmont wagon, wr450f

Power: 137 rwkw

Change the leads and it will fix it.Warm the car up and have a look at your leads at night and you should see a nice light show on the leads/arcing on tappet cover etc while its running...

phill
Top
 Profile  
 
 
 Post subject: Re: Misfiring under load
Posted: Sat May 15, 2010 11:29 pm 
Fordmods Newbie
Offline

Age: 42

Posts: 8

Joined: 5th May 2010

Ride: AU Futura II

Location: Adelaide
SA, Australia

taxi 5L wrote:
Change the leads and it will fix it.Warm the car up and have a look at your leads at night and you should see a nice light show on the leads/arcing on tappet cover etc while its running...

phill


Cheers for that guys - Phill, i'll try changing the leads. I just took it for a quick run and got it warm but no light show from the leads so maybe wasn't hot enough.

Will let you know if this fixes it.

Thanks again
Top
 Profile  
 
 
 Post subject: Re: Misfiring under load
Posted: Sat May 15, 2010 11:30 pm 
NSW Cruise Moderator
Offline
User avatar

Age: 39

Posts: 7331

Joined: 5th Nov 2004

Gallery: 12 images

Ride: TE50

Location: ɹǝpun uʍop
NSW, Australia

check your fuel filter as well, a blocked filter can also present as spark breakdown.

 

_________________

Image

I have a car.

Top
 Profile  
 
Display posts from previous:
Sort by  
 Page 1 of 1  [ 7 posts ] 

Who is online

Users browsing this forum: Google [Bot] and 14 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

 

 

It is currently Wed Dec 13, 2017 3:37 am All times are UTC + 11 hours

 

 

(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names