Fordmods Logo

modifying el alternator to use on ea. 

 

Page 2 of 2 [ 20 posts ] Go to page Previous  1, 2

 
 Post subject: EA Alt Problem
Posted: Sun Mar 25, 2007 7:23 pm 
Fordmods Newbie
Offline

Age: 63

Posts: 10

Joined: 25th Mar 2007

Location: Dalby
QLD, Australia

If you can get hold of an EL alt you use the body of your EA unit and change the gizzards over . I have done this for myself and other Ford users

jimbour
Top
 Profile  
 
 
 Post subject: Re: EA Alt Problem
Posted: Sun Mar 25, 2007 7:36 pm 
Moderator
Offline

Posts: 14513

Joined: 7th Nov 2004

Ride: ford falcon au3 xr8

Location: a shit suburb in sydney
NSW, Australia

jimbour wrote:
If you can get hold of an EL alt you use the body of your EA unit and change the gizzards over . I have done this for myself and other Ford users

jimbour


cool i might give that a go.
is there anything specific that needs to modified to swap the guts over??
Top
 Profile  
 
 
Posted: Sun Mar 25, 2007 7:49 pm 
Getting Side Ways
Offline
User avatar

Posts: 3363

Joined: 27th Dec 2004

Gallery: 4 images

Ride: MCMXCV Falcon

Location: G town
VIC, Australia

cjh wrote:
Does the alt in an EL need the ECU to tell it when to charge??? like in the EF.???


how do people come up with this crap?

 

_________________

Image

Top
 Profile  
 
 
Posted: Sun Mar 25, 2007 8:32 pm 
Getting Side Ways
Offline
User avatar

Age: 33

Posts: 5924

Joined: 5th Nov 2004

Gallery: 7 images

Ride: Ford FPV FG F6 310

Power: 149 rwkw

Location: Brisbane
QLD, Australia

gogetta wrote:
cjh wrote:
Does the alt in an EL need the ECU to tell it when to charge??? like in the EF.???


how do people come up with this crap?

hahah was gonna ask the same question.
some new jap and euro cars the ecu tells it when to charge, but not on 12year old aussie cars.

the bosch alternators on ea's were 85A so if you can source one, that will work better. try to source a smaller pulley for it too and it will spin faster, therefore charge better at low rpm with load.

 

_________________

NEW RIDE - FPV FG F6 6spd Auto. 12.26@114MPH, 1.88 60FT on Cheapy Tyres with 38PSI - Stock except K&N filter!

R.I.P. BF XR6 Turbo - You will not be forgotten :( 12.06@120MPH

Top
 Profile  
 
 
 Post subject: EA Alt Problem
Posted: Sun Mar 25, 2007 9:26 pm 
Fordmods Newbie
Offline

Age: 63

Posts: 10

Joined: 25th Mar 2007

Location: Dalby
QLD, Australia

There nothing dramatic in swappoing the gizzards over just make sure they are both the same make ie Bosch not Mitsabishi. I usually replace the bearings at this time just to make sure of a lasting c/o. Remove the regulator first and and add last , don't want to damage brushes

jimbour
Top
 Profile  
 
Display posts from previous:
Sort by  
 Page 2 of 2  [ 20 posts ]  Go to page Previous  1, 2

Who is online

Users browsing this forum: No registered users and 16 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

 

 

It is currently Sat Dec 16, 2017 3:12 am All times are UTC + 11 hours

 

 

(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names