Fordmods Logo

MPFI conversion problem - with pics 

 

Page 1 of 1 [ 9 posts ] 

 
 Post subject: MPFI conversion problem - with pics
Posted: Sat Apr 24, 2010 6:16 pm 
Parts Gopher
Offline

Posts: 89

Joined: 20th May 2009

Ride: EB 91 now with mpfi

Location: wodonga
VIC, Australia

Hi all
Am currently doing a MPFI conversion to 91 EB and have possible issue with plug colour coding / layout from existing loom to new MPFI loom. Have installed everything but car wont fire, definately have fuel. In the photos the new intake loom has a fat red wire in the plug which i assume is injector power. The existing plug on the ecu side has no corresponding wire and wondering if I have to add one to the ecu. On my 91 i believe black/yellow is injector power which is on the other side of the plug and connected to a smaller guage red wire. Maybe I need to pull out the black yellow and move it?? Any help appreciated.
cheers

 

 

Attachments:
plug ecu side.jpg
plug ecu side.jpg [ 45.33 KiB | Viewed 42 times ]
loom plug.jpg
loom plug.jpg [ 51.08 KiB | Viewed 49 times ]
Top
 Profile  
 
 
 Post subject: Re: MPFI conversion problem - with pics
Posted: Sun Apr 25, 2010 7:50 am 
Parts Gopher
Offline

Posts: 89

Joined: 20th May 2009

Ride: EB 91 now with mpfi

Location: wodonga
VIC, Australia

well I'm at a loss guys
Have spark
Have fuel
Pink wire is connected
Double checked all loom pinouts
Wont fire up

I currently have an auto mpfi ecu in it (car is 5 speed) I know I need to do the resistor trick but shouldnt it at least fire up? have also tried cfi manual ecu just to try to get it to fire but no good
any suggestions would be appreciated
Top
 Profile  
 
 
 Post subject: Re: MPFI conversion problem - with pics
Posted: Sun Apr 25, 2010 8:08 am 
Getting Side Ways
Offline
User avatar

Age: 45

Posts: 1953

Joined: 1st Feb 2006

Gallery: 25 images

Ride: BA on gas. EL on gas. XF on gas.

Location: Greenacres/Adelaide
SA, Australia

What model car did the ecu come from? did it have smartlock? eg. EB2 on.

 

_________________

Member Number 8804
Image

Top
 Profile  
 
 
 Post subject: Re: MPFI conversion problem - with pics
Posted: Sun Apr 25, 2010 8:12 am 
Parts Gopher
Offline

Posts: 89

Joined: 20th May 2009

Ride: EB 91 now with mpfi

Location: wodonga
VIC, Australia

ecu is off a 91 fairmont auto 3.9
my car is 91 falcon 5 speed
Top
 Profile  
 
 
 Post subject: Re: MPFI conversion problem - with pics
Posted: Sun Apr 25, 2010 8:14 am 
Getting Side Ways
Offline
User avatar

Age: 45

Posts: 1953

Joined: 1st Feb 2006

Gallery: 25 images

Ride: BA on gas. EL on gas. XF on gas.

Location: Greenacres/Adelaide
SA, Australia

I think you may find there is a difference between CFI and MPFI dizzies...

 

_________________

Member Number 8804
Image

Top
 Profile  
 
 
 Post subject: Re: MPFI conversion problem - with pics
Posted: Sun Apr 25, 2010 8:19 am 
Parts Gopher
Offline

Posts: 89

Joined: 20th May 2009

Ride: EB 91 now with mpfi

Location: wodonga
VIC, Australia

yeh i think so but I have read in several different places that it should run ok on CFI dizzy. Something is not getting a signal, back to the drawing board ( or back to CFI)
Top
 Profile  
 
 
 Post subject: Re: MPFI conversion problem - with pics
Posted: Sun Apr 25, 2010 8:28 am 
Getting Side Ways
Offline
User avatar

Age: 45

Posts: 1953

Joined: 1st Feb 2006

Gallery: 25 images

Ride: BA on gas. EL on gas. XF on gas.

Location: Greenacres/Adelaide
SA, Australia

Test with aerostart. If you are getting spark at the right time it will semi fire up.
My guess is you are not getting injector pulse.

Have a look here, I used the search function for you....
post1061065.html?hilit=mpfi#p1061065

 

_________________

Member Number 8804
Image

Top
 Profile  
 
 
 Post subject: Re: MPFI conversion problem - with pics
Posted: Sun Apr 25, 2010 11:01 am 
Parts Gopher
Offline

Posts: 89

Joined: 20th May 2009

Ride: EB 91 now with mpfi

Location: wodonga
VIC, Australia

its all sorted now thanks, some d***head who looks alot like me :oops: reversed the fuel lines (even after labelling them.) makes me wonder how i had any fuel in there at all.
Top
 Profile  
 
 
 Post subject: Re: MPFI conversion problem - with pics
Posted: Sun Apr 25, 2010 6:31 pm 
Getting Side Ways
Offline
User avatar

Age: 45

Posts: 1953

Joined: 1st Feb 2006

Gallery: 25 images

Ride: BA on gas. EL on gas. XF on gas.

Location: Greenacres/Adelaide
SA, Australia

LOL. Good work.

 

_________________

Member Number 8804
Image

Top
 Profile  
 
Display posts from previous:
Sort by  
 Page 1 of 1  [ 9 posts ] 

Who is online

Users browsing this forum: Google [Bot] and 12 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

 

 

It is currently Tue Dec 12, 2017 8:02 am All times are UTC + 11 hours

 

 

(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names