Fordmods Logo

my car is shagged and runs an sounds like a bettle 

 

Page 1 of 1 [ 7 posts ] 

 
 Post subject: my car is shagged and runs an sounds like a bettle
Posted: Tue Feb 01, 2005 9:48 pm 
Parts Gopher
Offline

Posts: 64

Joined: 5th Dec 2004

Ride: FALCON

Location: adelaide
SA, Australia

ok the story starts with fuel pump diein (dont blame it over 300k)
replaced the pump and now car runs like s**t
replaced plugs
checked leads
heaps of spark
cleaned out fuel filter didnt help(noticed a heap of black s**t ) will replace tomorrow
checkd injectors by pulling of wiring each one made car die abit and idle and at 3grand
put a k&n filter in it today
still f**k

ok at idle and timing is fine

like i said it sound like a vw or wrx at the moment and im gettin beatin by colts lol
is this a common problem???
what should i look at next. im considering taking to ford
but i dont want to pay $400 for them to plug in a computer and spend 5 min on the car
Top
 Profile  
 
 
Posted: Tue Feb 01, 2005 10:21 pm 
Stock as a Rock
Offline
User avatar

Age: 33

Posts: 113

Joined: 5th Nov 2004

Gallery: 8 images

Ride: Futura

Location: Perth
WA, Australia

blown heady gasket...

 

_________________

94 ED Futura, 5spd, RPM clutch,3.27 LSD, PH4480 pacemakers, 2.5'' Supercat, STG 2 Wade1004-112 advanced16degrees, XH intake K&N panel,pedders superlows, Expursuit puter. clearindicators, volvoTT thermofan
15.3@146kph
Alpine deck,splits,rears, clarion amp P1Crossfire subboofa, tint

Top
 Profile  
 
 
Posted: Wed Feb 02, 2005 9:52 am 
Getting Side Ways
Offline
User avatar

Age: 54

Posts: 4102

Joined: 18th Nov 2004

Gallery: 10 images

Ride: PX2 Ranger 4x4 XLT Dual CAB

Location: Carrum Downs
VIC, Australia

Black s**t out of Fuel filter eh! but you haven't changed it yet? that black s**t is likely to be in your injectors also. Unplugging the injectors is one thing, but if the injector is working with a poor spray pattern then the car will run poorly. Cleaning the injectors cost about $20ea if you take them out, a little more if the workshop does it.

 

_________________

Image
She's meanness put to music and the b**ch is born to run!
Like the sign says, "speed's just a question of money. How fast can you go?"

Top
 Profile  
 
 
Posted: Wed Feb 02, 2005 10:21 am 
Fordmods Junkie
Offline
User avatar

Age: 38

Posts: 1000491

Joined: 6th Nov 2004

Gallery: 2 images

Ride: AUXR6 HP With Ducati SupA Bike!

Location: Perth
WA, Australia

dude check all connections on the fuel pump, ther may be 1 that is loose and not allowing enough fuel pressure to the motor

 

_________________

RIP SCOTT

Top
 Profile  
 
 
Posted: Wed Feb 02, 2005 8:53 pm 
Parts Gopher
Offline

Posts: 64

Joined: 5th Dec 2004

Ride: FALCON

Location: adelaide
SA, Australia

thanks for the replys
fuel pressure seems fine
im thinking and hoping injectors are chockers

cheers josh
Top
 Profile  
 
 
Posted: Thu Feb 03, 2005 1:01 am 
Fordmods Junkie
Offline
User avatar

Age: 38

Posts: 1000491

Joined: 6th Nov 2004

Gallery: 2 images

Ride: AUXR6 HP With Ducati SupA Bike!

Location: Perth
WA, Australia

EBII_93 wrote:
thanks for the replys
fuel pressure seems fine
im thinking and hoping injectors are chockers

cheers josh
did u use a fuel pressure gauge?

 

_________________

RIP SCOTT

Top
 Profile  
 
 
Posted: Thu Feb 03, 2005 4:41 pm 
Getting Side Ways
Offline
User avatar

Age: 33

Posts: 1680

Joined: 5th Nov 2004

Gallery: 1 images

Ride: 220kw 1600 Datto

Location: Scaaabz
WA, Australia

LOL @ title :lol:

 

_________________

Image

Top
 Profile  
 
Display posts from previous:
Sort by  
 Page 1 of 1  [ 7 posts ] 

Who is online

Users browsing this forum: No registered users and 16 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

 

 

It is currently Tue Dec 19, 2017 4:12 am All times are UTC + 11 hours

 

 

(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names