Fordmods Logo

My DEV 5 EL XR6 a tad sluggish / unresponsive ...any ideas?? 

 

Page 3 of 3 [ 44 posts ] Go to page Previous  1, 2, 3

 
Posted: Sun May 04, 2008 6:40 pm 
Oompa Loompa
Offline

Posts: 29

Joined: 1st Nov 2007

Ride: EL XR6; BFII XR8 (KB S/C); ZX10R

Location: Perth
WA, Australia

No. The ISC has a 2 holes on the inside - one on each side of the throttle valve/window. This lets air through when the throttle is closed to retain idle. As I understand, it is adjusted by the ISC valve which opens and closes from the ECU.

The brass fitting blocked the hole but was drilled out approx. 5mm. Possibly to artificially override the tune or the ECU but who knows! I replaced the ISC when I removed the chip & went back to an EMS tune.

The chip and tune got the car over the pits but that is all.
Top
 Profile  
 
 
Posted: Thu May 08, 2008 1:28 am 
Getting Side Ways
Offline
User avatar

Age: 50

Posts: 1525

Joined: 13th Oct 2005

Gallery: 13 images

Ride: The DEVEL XR6

Location: Perth
WA, Australia

As Jamie predicted ...the little glitches have crept in again over the last 2 days.

So it could be sensor or tune related.

Thing is, I can't really pull the chip off at this stage ...because it will be retarded to what it was before the tune.

 

_________________

Hot Chilli Red EL XR6, 5-spd, JMM DEV 5 enhanced (161 rwkw custom tuned), Eliminator Switch Chip, 18" BA GTP rims, Pedders Superlows, BA XR6 badges, BA Sunroof, Pioneer Stereo, Splits, 6x9's, 10" sub, 700W 6-ch Viper amp.
QUARTER MILE PB: currently 14.590 @ 96.00 mph ...BOOST AHEAD!!

Top
 Profile  
 
 
Posted: Thu May 08, 2008 8:22 am 
Fordmods Addict
Offline
User avatar

Age: 31

Posts: 7958

Joined: 1st Jun 2005

Gallery: 13 images

Ride: Falcon

Power: 237 rwkw

Location: Melbourne
VIC, Australia

What will be retarded?
Ignition timing?
It'll go back to what it was stock, unless they've changed base timing for some reason, which is an easy fix.
Diagnostic mode and a timing light to see where it is.
If you mean cam timing, what worked with the chip will probably work for the stock ECU too.
Retarded cam timing generally helps with idle.

 

_________________

ED XR8 Sprint - S-Trim, V500, 249rwkw
BF MKII F6 Tornado - 237rwkw

Top
 Profile  
 
 
Posted: Thu May 08, 2008 9:24 am 
Getting Side Ways
Offline

Age: 32

Posts: 434

Joined: 19th May 2006

Ride: ba xr6 turbo

Location: melbourne
VIC, Australia

hey mark how it going

i see that my old baby is starting to loser her go, but still has not lost her show, man that is one awsome car, i really miss it!

now as for the car. it is for fure the clutch, i even noticed it when i was up there last time that it was losing power when i was giving it a mouth full of fuel, i think ull find if you change the clutch the dev kit will get right back up and going again,

only other thing it might be is the computer chip in it is still stock (unless you changed it) and jim once told me that after a little while it wil be worth buying the computer chip to suit the dev 5 kit, cause the car is getting older now it may need some TLC

either way mate still gotta love that car,

p.s when you selling it back to me??
Top
 Profile  
 
 
Posted: Thu May 08, 2008 9:26 am 
Getting Side Ways
Offline

Age: 32

Posts: 434

Joined: 19th May 2006

Ride: ba xr6 turbo

Location: melbourne
VIC, Australia

markr154 wrote:
Steady ED wrote:
Only one way to find out.
When did it run a 14.5?
Without the chip yeah?


Yep ...and easy 14.7's


what ya talking about mark, its an easy 14.3 second car, i you have my sheets to prove it.. lol
Top
 Profile  
 
 
Posted: Thu May 08, 2008 10:46 am 
Getting Side Ways
Offline
User avatar

Age: 50

Posts: 1525

Joined: 13th Oct 2005

Gallery: 13 images

Ride: The DEVEL XR6

Location: Perth
WA, Australia

Hey Brendan,

Was actually thinking of you last night mate ...bearing in mind you may not recognise this car in a couple of months, haha.

I'm now running the Eliminator Chip in the car, base timing was reset before the timing and AFR's were custom tuned on the dyno.

She runs a whole heap smoother, but seems to have lost a little of the sting she had when she was running purely off the factory ECU.

The timing was quite a few degrees advanced without the chip ...and I'm thinking the timing reset, coupled with a conservative tune and / or a faulty sensor could be the likely causes.

These pics are just for you mate ...notice a few changes? Haha

Image
Image
Image
Image
Image

 

_________________

Hot Chilli Red EL XR6, 5-spd, JMM DEV 5 enhanced (161 rwkw custom tuned), Eliminator Switch Chip, 18" BA GTP rims, Pedders Superlows, BA XR6 badges, BA Sunroof, Pioneer Stereo, Splits, 6x9's, 10" sub, 700W 6-ch Viper amp.
QUARTER MILE PB: currently 14.590 @ 96.00 mph ...BOOST AHEAD!!

Top
 Profile  
 
 
Posted: Thu May 08, 2008 11:01 am 
Getting Side Ways
Offline
User avatar

Age: 50

Posts: 1525

Joined: 13th Oct 2005

Gallery: 13 images

Ride: The DEVEL XR6

Location: Perth
WA, Australia

NO wing, and custom tail-lights FTW, with more to come..

Boosted to 250+ rwkw, aftermarket ECU, more cosmetic mods ...wait and see mate ;)

 

_________________

Hot Chilli Red EL XR6, 5-spd, JMM DEV 5 enhanced (161 rwkw custom tuned), Eliminator Switch Chip, 18" BA GTP rims, Pedders Superlows, BA XR6 badges, BA Sunroof, Pioneer Stereo, Splits, 6x9's, 10" sub, 700W 6-ch Viper amp.
QUARTER MILE PB: currently 14.590 @ 96.00 mph ...BOOST AHEAD!!

Top
 Profile  
 
 
Posted: Thu May 08, 2008 11:09 am 
Getting Side Ways
Offline
User avatar

Age: 34

Posts: 10826

Joined: 17th Apr 2005

Gallery: 34 images

Ride: BF MK11 XR 6 TURBO ZF 6spd

Power: 225 rwkw

Location: glenwood/sydney
NSW, Australia

must have a big money tree.. :lol: looking great.. and some tasty mods coming along.. 8-) :twisted:

 

_________________

Todd: Nurse, suction.
Nurse: The patient's not even here yet.
Todd: I know.

http://www.youtube.com/watch?v=_GQpRYRcAiA

Top
 Profile  
 
 
Posted: Thu May 08, 2008 11:34 am 
Fordmods Addict
Offline
User avatar

Age: 31

Posts: 7958

Joined: 1st Jun 2005

Gallery: 13 images

Ride: Falcon

Power: 237 rwkw

Location: Melbourne
VIC, Australia

markr154 wrote:
The timing was quite a few degrees advanced without the chip ...and I'm thinking the timing reset, coupled with a conservative tune and / or a faulty sensor could be the likely causes.

Advancing the base timing again is just a matter of twisting the dizzy.

Base timing is just that, the BASE timing figure.
The ECU will add or reduce ignition advance to that figure
So if you twist the dizzy to advance the timing, by say 5 degrees, you are adding +5 degrees of timing across the board.
This is basically a work around.
Because you are adding it across the board, you have to compromise.
Adding another 10 degrees might work at some points and make more power, but may cause it to detonate at other points.

With the chip, you can have the base timing set at the factory figure, because you know longer have to compromise with the factory ignition timing maps.
You can add more timing in some spots, and pull it out in others.

So having the timing reset as you say will not be a cause.
It's either a s**t tune, or a faulty sensor.
If it's not throwing up fault codes, it makes it hard to find the sensor.
Elimanating the chip as the factor is the easiest.
Remove it, twist the dizzy to advance the timing by a few degrees, and see how it goes :wink:

 

_________________

ED XR8 Sprint - S-Trim, V500, 249rwkw
BF MKII F6 Tornado - 237rwkw

Top
 Profile  
 
 
Posted: Thu May 08, 2008 12:44 pm 
Getting Side Ways
Offline
User avatar

Age: 50

Posts: 1525

Joined: 13th Oct 2005

Gallery: 13 images

Ride: The DEVEL XR6

Location: Perth
WA, Australia

Thanks for the pointers Steady ...I'll have a crack at that this weekend.

 

_________________

Hot Chilli Red EL XR6, 5-spd, JMM DEV 5 enhanced (161 rwkw custom tuned), Eliminator Switch Chip, 18" BA GTP rims, Pedders Superlows, BA XR6 badges, BA Sunroof, Pioneer Stereo, Splits, 6x9's, 10" sub, 700W 6-ch Viper amp.
QUARTER MILE PB: currently 14.590 @ 96.00 mph ...BOOST AHEAD!!

Top
 Profile  
 
 
Posted: Thu May 08, 2008 1:35 pm 
Getting Side Ways
Offline

Age: 32

Posts: 434

Joined: 19th May 2006

Ride: ba xr6 turbo

Location: melbourne
VIC, Australia

looks nice mark.. personaly rather the spoiler n s**t like that but still one sexy car right there! (thanks to me) haha

so how much ya want for it?

LOL
Top
 Profile  
 
 
Posted: Thu May 08, 2008 1:43 pm 
Getting Side Ways
Offline

Age: 32

Posts: 434

Joined: 19th May 2006

Ride: ba xr6 turbo

Location: melbourne
VIC, Australia

here just for you mark

 

 

Attachments:
btcar1.jpg
btcar1.jpg [ 541.53 KiB | Viewed 37 times ]
btcar.jpg
btcar.jpg [ 532.43 KiB | Viewed 28 times ]
Top
 Profile  
 
 
Posted: Thu May 08, 2008 2:12 pm 
Getting Side Ways
Offline
User avatar

Age: 50

Posts: 1525

Joined: 13th Oct 2005

Gallery: 13 images

Ride: The DEVEL XR6

Location: Perth
WA, Australia

Nice ride Brendan ...back in a Ford for the win.

I've had the DEV EL almost 2 years now ...so she's MINE, F**k ya.

She's come a fair way ...with plenty more to come.

 

_________________

Hot Chilli Red EL XR6, 5-spd, JMM DEV 5 enhanced (161 rwkw custom tuned), Eliminator Switch Chip, 18" BA GTP rims, Pedders Superlows, BA XR6 badges, BA Sunroof, Pioneer Stereo, Splits, 6x9's, 10" sub, 700W 6-ch Viper amp.
QUARTER MILE PB: currently 14.590 @ 96.00 mph ...BOOST AHEAD!!

Top
 Profile  
 
 
Posted: Thu May 08, 2008 3:15 pm 
Getting Side Ways
Offline

Age: 32

Posts: 434

Joined: 19th May 2006

Ride: ba xr6 turbo

Location: melbourne
VIC, Australia

markr154 wrote:
Nice ride Brendan ...back in a Ford for the win.

I've had the DEV EL almost 2 years now ...so she's MINE, F**k ya.

She's come a fair way ...with plenty more to come.



yeah my ba she good i like her.. she boogies along just nicely.. sounds better then the old 6's i have had thats for sure.. haha
Top
 Profile  
 
Display posts from previous:
Sort by  
 Page 3 of 3  [ 44 posts ]  Go to page Previous  1, 2, 3

Who is online

Users browsing this forum: No registered users and 17 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

 

 

It is currently Tue Dec 19, 2017 7:56 am All times are UTC + 11 hours

 

 

(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names