Fordmods Logo

my rebuild 

 

Page 2 of 2 [ 17 posts ] Go to page Previous  1, 2

 
Posted: Mon Oct 16, 2006 12:28 pm 
Tyre Shredder
Offline

Posts: 304

Joined: 5th Sep 2006

Location: christchurch
New Zealand

ok head is nearly ready to go back on.. it's been crack tested and it's all good. The dude said there's no way that my heads done 300,000kms especially on LPG.
It's already got hardened valve seats.. (is that normal?)

anyway it's been ported and in getting skimmed at the moment.

then I'll go get the cam re-ground and it's all ready.

I was wondering what the best way to clean everything afterwards.. the oil is all mucky from mixing with water.. and the cooling system is all brown and rusty.

run an engine cleaner and a radiator cleaner and flush??

 

_________________

http://www.retrotech.co.nz

Top
 Profile  
 
 
Posted: Mon Oct 16, 2006 5:26 pm 
Smokin em up
Offline

Age: 30

Posts: 235

Joined: 10th Nov 2005

Ride: S2 TI R31

Location: Melbourne
VIC, Australia

you dont need the EL ECU to use the bbm. Just get a RPM switch from jaycay and your gg.
Top
 Profile  
 
Display posts from previous:
Sort by  
 Page 2 of 2  [ 17 posts ]  Go to page Previous  1, 2

Who is online

Users browsing this forum: No registered users and 29 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

 

 

It is currently Mon Dec 18, 2017 7:53 pm All times are UTC + 11 hours

 

 

(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names