Fordmods Logo

Need help.. Leads 

 

Page 1 of 1 [ 8 posts ] 

 
 Post subject: Need help.. Leads
Posted: Sun Oct 01, 2006 7:45 pm 
Fordmods Newbie
Offline

Posts: 7

Joined: 1st Oct 2006

Ride: Falcon EF

Location: Perth
WA, Australia

Hi, We just changed the leads and spark plugs on my EF falcon, (had to do this as one of the leads snapped when checking spark plugs) anyways, everything seems to be all ok, checked for air in leads etc... but its still missing badly, was all ok before.. Tried everything we can think of, Can someone help me? Please!!!
Top
 Profile  
 
 
Posted: Sun Oct 01, 2006 7:48 pm 
Getting Side Ways
Offline
User avatar

Age: 54

Posts: 4102

Joined: 18th Nov 2004

Gallery: 10 images

Ride: PX2 Ranger 4x4 XLT Dual CAB

Location: Carrum Downs
VIC, Australia

Crook plug or lead or lead connections. Check them all again.

 

_________________

Image
She's meanness put to music and the b**ch is born to run!
Like the sign says, "speed's just a question of money. How fast can you go?"

Top
 Profile  
 
 
Posted: Sun Oct 01, 2006 8:06 pm 
Fordmods Newbie
Offline

Posts: 7

Joined: 1st Oct 2006

Ride: Falcon EF

Location: Perth
WA, Australia

ok, found a crook lead, put old one back on. Is still missing. Could a lead be plugged in the wrong place?
Top
 Profile  
 
 
Posted: Sun Oct 01, 2006 8:06 pm 
Getting Side Ways
Offline
User avatar

Age: 32

Posts: 3687

Joined: 4th Mar 2005

Gallery: 23 images

Ride: XR6 Turbo

Location: Taree
NSW, Australia

Change the plugs now.

 

_________________

SS Inductions CAI, K&N Filters, M-spec FMC, Turbosmart BOV, 8psi capa tune, X-force cat.

Mods going on: Nizpro springs, bosch 040 pump + Walbro gss341, 600cc injectors, PWR transcooler, 20% Underdrives, 15psi Actuator, Kingspring SSL's, 15psi tune.....More coming

Top
 Profile  
 
 
Posted: Sun Oct 01, 2006 8:10 pm 
Fordmods Newbie
Offline

Posts: 7

Joined: 1st Oct 2006

Ride: Falcon EF

Location: Perth
WA, Australia

new plugs. Although when we checked for bad leads, we noticed no'2 plug was dirty.. aarrgghhh I'm so frustrated! Never had problems with my XF that I couldn't fix! :o)
Top
 Profile  
 
 
Posted: Sun Oct 01, 2006 8:12 pm 
Fordmods Newbie
Offline

Posts: 7

Joined: 1st Oct 2006

Ride: Falcon EF

Location: Perth
WA, Australia

it also seems to have a slight knock...
Top
 Profile  
 
 
Posted: Sun Oct 01, 2006 8:24 pm 
Fordmods Newbie
Offline

Posts: 7

Joined: 1st Oct 2006

Ride: Falcon EF

Location: Perth
WA, Australia

ok ok.. thanx for your suggestions... No'2 lead was faulty, but I had no'1 and no'2 leads swapped at the dist cap. DOH! Thanx for your help though... :o)
Top
 Profile  
 
 
Posted: Sun Oct 01, 2006 8:34 pm 
Getting Side Ways
Offline

Posts: 6913

Joined: 6th Nov 2004

Gallery: 4 images

Ride: BF XR6, BF XT Wagon

Power: 197 rwkw

Location: Perth
WA, Australia

Yep that would do it. Always the simple things we miss.

 

_________________

EL XR8
Timmeh banned himself from being a moderator.

Top
 Profile  
 
Display posts from previous:
Sort by  
 Page 1 of 1  [ 8 posts ] 

Who is online

Users browsing this forum: Google [Bot] and 20 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

 

 

It is currently Wed Dec 13, 2017 9:09 am All times are UTC + 11 hours

 

 

(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names