Fordmods Logo

Need help 

 

Page 1 of 1 [ 15 posts ] 

 
 Post subject: Need help
Posted: Tue Sep 19, 2006 2:08 pm 
Getting Side Ways
Offline
User avatar

Age: 32

Posts: 3687

Joined: 4th Mar 2005

Gallery: 23 images

Ride: XR6 Turbo

Location: Taree
NSW, Australia

Hey lads, I just put on a replacment steering wheel on the EF, now when u press the horn, u can just here it make clicking noises under the bonnet, all the wires went back in correctly as I marked them with pen, next thing, My oddometer has gone dim as all f#$k, it worked fine this morning when I went into town? any qlues?

Thanks lads

 

_________________

SS Inductions CAI, K&N Filters, M-spec FMC, Turbosmart BOV, 8psi capa tune, X-force cat.

Mods going on: Nizpro springs, bosch 040 pump + Walbro gss341, 600cc injectors, PWR transcooler, 20% Underdrives, 15psi Actuator, Kingspring SSL's, 15psi tune.....More coming

Top
 Profile  
 
 
Posted: Tue Sep 19, 2006 2:45 pm 
Getting Side Ways
Offline
User avatar

Age: 31

Posts: 2550

Joined: 28th Jun 2005

Gallery: 13 images

Ride: EF 5 Speed, XH Uterus :P

Location: Hobart
TAS, Australia

when i put my new wheel on, i didn't need to disconnect any wires...

sounds like you've got a short somewhere, or a bad earth for interior/dash lights.

 

_________________

Maloo - Holden's word for ugly.

Top
 Profile  
 
 
Posted: Tue Sep 19, 2006 2:49 pm 
Getting Side Ways
Offline
User avatar

Age: 32

Posts: 3687

Joined: 4th Mar 2005

Gallery: 23 images

Ride: XR6 Turbo

Location: Taree
NSW, Australia

I had to change the backing on the streering wheel as it was from a fairmont, and mines a GLI so i took off the cruise control buttons horn etc and replaced it with the gear out of the GLI wheel so it still has all the same wires/ airbag as before.

 

_________________

SS Inductions CAI, K&N Filters, M-spec FMC, Turbosmart BOV, 8psi capa tune, X-force cat.

Mods going on: Nizpro springs, bosch 040 pump + Walbro gss341, 600cc injectors, PWR transcooler, 20% Underdrives, 15psi Actuator, Kingspring SSL's, 15psi tune.....More coming

Top
 Profile  
 
 
Posted: Tue Sep 19, 2006 5:57 pm 
Fordmods Addict
Offline

Age: 32

Posts: 2245

Joined: 5th Nov 2004

Ride: BA XR6T

Location: Bayswater
VIC, Australia

your odometer is most likely just the globe, very easy to fix this, do a search and you should find several threads on it.

your horn is a more interesting one. i had the same problem in my laser, push the horn button and nothing but a clicking sound from under the bonnet. i replaced the actual horn. Though unlikely, its maybe just coincidence that your horn carked it when you started playing with the steering wheel.
go to a wreckers a pull a horn off there and try that, should be relatively cheap.
the fact that when you push the horn button in, its doing something, makes me think its all wired up ok, and the problem is at the horn end.

 

_________________

Image

Top
 Profile  
 
 
Posted: Tue Sep 19, 2006 8:26 pm 
Getting Side Ways
Offline
User avatar

Age: 32

Posts: 3687

Joined: 4th Mar 2005

Gallery: 23 images

Ride: XR6 Turbo

Location: Taree
NSW, Australia

Yeah bit the bullet shes booked in at ford next monday, got my sisters BF working on it. I got no time to do anything for the next few weeks, just sucks, all i wanted was a new un-sun damaged steering wheel, now ive got 2 new probs!

 

_________________

SS Inductions CAI, K&N Filters, M-spec FMC, Turbosmart BOV, 8psi capa tune, X-force cat.

Mods going on: Nizpro springs, bosch 040 pump + Walbro gss341, 600cc injectors, PWR transcooler, 20% Underdrives, 15psi Actuator, Kingspring SSL's, 15psi tune.....More coming

Top
 Profile  
 
 
Posted: Tue Sep 19, 2006 8:35 pm 
Fordmods Addict
Offline

Age: 32

Posts: 2245

Joined: 5th Nov 2004

Ride: BA XR6T

Location: Bayswater
VIC, Australia

tell me hes doing it for free?

 

_________________

Image

Top
 Profile  
 
 
Posted: Tue Sep 19, 2006 8:43 pm 
Getting Side Ways
Offline
User avatar

Age: 32

Posts: 3687

Joined: 4th Mar 2005

Gallery: 23 images

Ride: XR6 Turbo

Location: Taree
NSW, Australia

Ill get a horn 2moz on the way 2 work, other from that I hope so,

 

_________________

SS Inductions CAI, K&N Filters, M-spec FMC, Turbosmart BOV, 8psi capa tune, X-force cat.

Mods going on: Nizpro springs, bosch 040 pump + Walbro gss341, 600cc injectors, PWR transcooler, 20% Underdrives, 15psi Actuator, Kingspring SSL's, 15psi tune.....More coming

Top
 Profile  
 
 
Posted: Tue Sep 19, 2006 10:07 pm 
Getting Side Ways
Offline

Posts: 404

Joined: 8th Jun 2006

Location: melbourne
VIC, Australia

The clicking is from the horn relay not the horn. Check your earth, then try replacing the relay.
Top
 Profile  
 
 
Posted: Wed Sep 20, 2006 7:08 am 
Getting Side Ways
Offline
User avatar

Age: 32

Posts: 3687

Joined: 4th Mar 2005

Gallery: 23 images

Ride: XR6 Turbo

Location: Taree
NSW, Australia

Where is the earth for the horn? also where is the horn relay?

 

_________________

SS Inductions CAI, K&N Filters, M-spec FMC, Turbosmart BOV, 8psi capa tune, X-force cat.

Mods going on: Nizpro springs, bosch 040 pump + Walbro gss341, 600cc injectors, PWR transcooler, 20% Underdrives, 15psi Actuator, Kingspring SSL's, 15psi tune.....More coming

Top
 Profile  
 
 
Posted: Wed Sep 20, 2006 12:17 pm 
Getting Side Ways
Offline
User avatar

Age: 32

Posts: 3687

Joined: 4th Mar 2005

Gallery: 23 images

Ride: XR6 Turbo

Location: Taree
NSW, Australia

LOL ok the horn, well there is no horn, the pannel beaters didnt take it off the old front bar, thats why it wouldnt work lol so thats fixed now, second, just picked up a led bulb for the oddometer ill read the dash doco and do it when i get some time, Once again fordmods saves me $300!!! thanks lads!

 

_________________

SS Inductions CAI, K&N Filters, M-spec FMC, Turbosmart BOV, 8psi capa tune, X-force cat.

Mods going on: Nizpro springs, bosch 040 pump + Walbro gss341, 600cc injectors, PWR transcooler, 20% Underdrives, 15psi Actuator, Kingspring SSL's, 15psi tune.....More coming

Top
 Profile  
 
 
Posted: Wed Sep 20, 2006 12:26 pm 
Getting Side Ways
Offline
User avatar

Posts: 2644

Joined: 6th Nov 2004

Gallery: 8 images

Ride: 2007

Location: Mount Annan
NSW, Australia

Molloy wrote:
well there is no horn, the pannel beaters didnt take it off the old front bar,
That would do it every time. The lamp probably blew when removing the wheel, they are more likely to go if bumped while the filliments are cold.

 

_________________

BF Fairmont Ghia Series II update.
GQ XR6T ghia patrol.

,======o00o
//__|__|_,\_____\,___
|_/--\'_|'__|_/--\_[]IIII[]
_( o ) )_____( o ) )=o=) )__

Top
 Profile  
 
 
Posted: Wed Sep 20, 2006 1:00 pm 
Getting Side Ways
Offline
User avatar

Age: 32

Posts: 3687

Joined: 4th Mar 2005

Gallery: 23 images

Ride: XR6 Turbo

Location: Taree
NSW, Australia

Yeah I fair had to give the old wheel a flogging to get it off the rack, went to the auto elecs got a bulb cant be that had too do just take off the suround take out the cluster, unscrew old bulb and pop in the new one, and bam it costs $1.50 and not $200 if ford did it! looking forward to pulling the dash apart give me a chance to have a look around etc. learn some s**t.

 

_________________

SS Inductions CAI, K&N Filters, M-spec FMC, Turbosmart BOV, 8psi capa tune, X-force cat.

Mods going on: Nizpro springs, bosch 040 pump + Walbro gss341, 600cc injectors, PWR transcooler, 20% Underdrives, 15psi Actuator, Kingspring SSL's, 15psi tune.....More coming

Top
 Profile  
 
 
Posted: Wed Sep 20, 2006 1:03 pm 
Getting Side Ways
Offline
User avatar

Posts: 2644

Joined: 6th Nov 2004

Gallery: 8 images

Ride: 2007

Location: Mount Annan
NSW, Australia

Its not hard at all, 15-20 minutes blindfolded after you have done it a few tmes.

 

_________________

BF Fairmont Ghia Series II update.
GQ XR6T ghia patrol.

,======o00o
//__|__|_,\_____\,___
|_/--\'_|'__|_/--\_[]IIII[]
_( o ) )_____( o ) )=o=) )__

Top
 Profile  
 
 
Posted: Wed Sep 20, 2006 1:05 pm 
Getting Side Ways
Offline
User avatar

Age: 32

Posts: 3687

Joined: 4th Mar 2005

Gallery: 23 images

Ride: XR6 Turbo

Location: Taree
NSW, Australia

Cool, yeah the old globe in now u can still see it but only just its real real dim, so that makes me think the bulb is rat s**t and its not any of the wires or anything.

 

_________________

SS Inductions CAI, K&N Filters, M-spec FMC, Turbosmart BOV, 8psi capa tune, X-force cat.

Mods going on: Nizpro springs, bosch 040 pump + Walbro gss341, 600cc injectors, PWR transcooler, 20% Underdrives, 15psi Actuator, Kingspring SSL's, 15psi tune.....More coming

Top
 Profile  
 
 
Posted: Wed Sep 20, 2006 4:26 pm 
Getting Side Ways
Offline
User avatar

Age: 32

Posts: 3687

Joined: 4th Mar 2005

Gallery: 23 images

Ride: XR6 Turbo

Location: Taree
NSW, Australia

Ok i put the globe in, when the cars headlights are turned off the oddometer lights up not as bright as it was before it s**t itself but enough to see it now, but when u turn the headlights on it goes all dim and s**t like the last one??? any qlues, its a GLI so there is no cluster dimmer switch or anything, did they give me the wrong bulb??

 

_________________

SS Inductions CAI, K&N Filters, M-spec FMC, Turbosmart BOV, 8psi capa tune, X-force cat.

Mods going on: Nizpro springs, bosch 040 pump + Walbro gss341, 600cc injectors, PWR transcooler, 20% Underdrives, 15psi Actuator, Kingspring SSL's, 15psi tune.....More coming

Top
 Profile  
 
Display posts from previous:
Sort by  
 Page 1 of 1  [ 15 posts ] 

Who is online

Users browsing this forum: Google [Bot] and 31 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

 

 

It is currently Mon Dec 11, 2017 10:56 pm All times are UTC + 11 hours

 

 

(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names