Fordmods Logo

new car different problems 

 

Page 1 of 1 [ 12 posts ] 

 
 Post subject: new car different problems
Posted: Thu Feb 23, 2006 12:49 pm 
Fordmods Junkie
Offline
User avatar

Posts: 11739

Joined: 17th May 2005

Gallery: 11 images

Ride: EL Fairmont, VFR400 racer

Power: 144 rwkw

Location: Melbourne
VIC, Australia

heys everyone

bought myself an EL Fairmont 1996......has done 179000kms. 4 speed auto.

anyways when i picked her up from the auction place in altona, vic. she drove alrite for a while.....and then i tried the aircon and i heard a cling noise........the engine revs went down a bit and then went back to normal. drove it with air con on and the engine seems to jerk.....and idle is really bad. when i accelerate from the lights the car revs up slowly with a rough feel to it and it seems like its going to stall........when im cruising on the freeway it seems fine but when i accelerate to go faster she hesitates. whats the problem?

lets hope the problem is simple so i can fix it myself.

cheers

phong =P~

 

_________________

phongus = Post whore 2006
EL XR6 motor, EL ECU + J3 chip, WADE 1673 Camshaft, 3" S/S intake, Pacy 4480, 2.5" Hi flow cat, 2.5" Lukey exhaust.
Max Power = 144.6 rwkw (03/05/2008)

Top
 Profile  
 
 
Posted: Thu Feb 23, 2006 6:19 pm 
Getting Side Ways
Offline
User avatar

Age: 32

Posts: 2833

Joined: 7th Nov 2004

Gallery: 4 images

Ride: Lincoln LS, MKII Escort, ED

Location: geelong
VIC, Australia

sounds like the aircon compressor is well and truly rooted, mine does a similar thing, but nowhere near as bad, i just dont use it anymore!

 

_________________

Because i can.

Top
 Profile  
 
 
Posted: Thu Feb 23, 2006 6:54 pm 
Fordmods Junkie
Offline
User avatar

Posts: 11739

Joined: 17th May 2005

Gallery: 11 images

Ride: EL Fairmont, VFR400 racer

Power: 144 rwkw

Location: Melbourne
VIC, Australia

oh okai....well im getting a rwc tomorrow so hopefully my friend's cousin can find out whats happenin but thanks.....

by the way u wouldnt happen to know if the rack and pinion of a ford EA would fir on an EL?

cheers

phong =P~

 

_________________

phongus = Post whore 2006
EL XR6 motor, EL ECU + J3 chip, WADE 1673 Camshaft, 3" S/S intake, Pacy 4480, 2.5" Hi flow cat, 2.5" Lukey exhaust.
Max Power = 144.6 rwkw (03/05/2008)

Top
 Profile  
 
 
 Post subject: Re: new car different problems
Posted: Thu Feb 23, 2006 7:30 pm 
Getting Side Ways
Offline
User avatar

Posts: 2644

Joined: 6th Nov 2004

Gallery: 8 images

Ride: 2007

Location: Mount Annan
NSW, Australia

phongus wrote:
heys everyone

bought myself an EL Fairmont 1996......has done 179000kms. 4 speed auto.

anyways when i picked her up from the auction place in altona, vic. she drove alrite for a while.....and then i tried the aircon and i heard a cling noise........the engine revs went down a bit and then went back to normal. drove it with air con on and the engine seems to jerk.....and idle is really bad. when i accelerate from the lights the car revs up slowly with a rough feel to it and it seems like its going to stall........when im cruising on the freeway it seems fine but when i accelerate to go faster she hesitates. whats the problem?

lets hope the problem is simple so i can fix it myself.

cheers

phong =P~

Assuming the air conditoner is cooling OK then the idle issues may only be the ISC or idle speed controller is dirty or faulty. Poor performance may be plug leads , plugs and Air filter type problems, all easy to deal with.
Cheers
TW

 

_________________

BF Fairmont Ghia Series II update.
GQ XR6T ghia patrol.

,======o00o
//__|__|_,\_____\,___
|_/--\'_|'__|_/--\_[]IIII[]
_( o ) )_____( o ) )=o=) )__

Top
 Profile  
 
 
Posted: Fri Feb 24, 2006 12:35 am 
Fordmods Junkie
Offline
User avatar

Posts: 11739

Joined: 17th May 2005

Gallery: 11 images

Ride: EL Fairmont, VFR400 racer

Power: 144 rwkw

Location: Melbourne
VIC, Australia

yeah i thought it might be the ISC. i would take it out and clean it myself.......if i knew where exactly to pull it apart. might go out and get an EL Manual. im suspecting ISC mainly becos this car has been sitting at the auction yard for a while i think. so it might be really dirty. cheers

phong =P~

 

_________________

phongus = Post whore 2006
EL XR6 motor, EL ECU + J3 chip, WADE 1673 Camshaft, 3" S/S intake, Pacy 4480, 2.5" Hi flow cat, 2.5" Lukey exhaust.
Max Power = 144.6 rwkw (03/05/2008)

Top
 Profile  
 
 
 Post subject: Fuel Filter
Posted: Fri Feb 24, 2006 12:43 pm 
Stock as a Rock
Offline

Age: 34

Posts: 105

Joined: 11th Sep 2005

Ride: Falcon GLI

Location: Perth
WA, Australia

I reckon it's the fuel filter. Just be careful when you undo it; fuel pisses otut already after the FIRST TURN!!! I got fuel in my eyes doing it, and it was no pleasant experience. It was BP Ultimate fuel with a NULON fuel system cleaner mixed through it; it was PAINFUL!

I reckon it's the fuel filter because it hesitates when you accelerate. Either that or your injectors need cleaning, which is more likely to happen with dual fuel.
Top
 Profile  
 
 
Posted: Fri Feb 24, 2006 12:58 pm 
Fordmods Junkie
Offline
User avatar

Posts: 11739

Joined: 17th May 2005

Gallery: 11 images

Ride: EL Fairmont, VFR400 racer

Power: 144 rwkw

Location: Melbourne
VIC, Australia

ah yeah forgot about the fuel line......might need to check that up too. =D and i know what u mean with petrol in ur eye.......i did the same thing on my EA.....stung like hell tried to get out from under my car and hit a metal part of the car where u jack up ur car and made a scar on my face. i think this time ill start the car with the fuel pump off =D should work better. cheers

phong =P~

 

_________________

phongus = Post whore 2006
EL XR6 motor, EL ECU + J3 chip, WADE 1673 Camshaft, 3" S/S intake, Pacy 4480, 2.5" Hi flow cat, 2.5" Lukey exhaust.
Max Power = 144.6 rwkw (03/05/2008)

Top
 Profile  
 
 
 Post subject: ...
Posted: Fri Feb 24, 2006 9:09 pm 
Stock as a Rock
Offline

Age: 34

Posts: 105

Joined: 11th Sep 2005

Ride: Falcon GLI

Location: Perth
WA, Australia

LOL :lol:
Top
 Profile  
 
 
Posted: Sat Feb 25, 2006 12:55 am 
Fordmods Junkie
Offline
User avatar

Posts: 11739

Joined: 17th May 2005

Gallery: 11 images

Ride: EL Fairmont, VFR400 racer

Power: 144 rwkw

Location: Melbourne
VIC, Australia

the idle kinda ceased a bit...not as bad as before. i think its becos the car hasnt been driven for a while. after that drive it was fine. getting rwc....hopefully it goes well

cheers

phong =P~

 

_________________

phongus = Post whore 2006
EL XR6 motor, EL ECU + J3 chip, WADE 1673 Camshaft, 3" S/S intake, Pacy 4480, 2.5" Hi flow cat, 2.5" Lukey exhaust.
Max Power = 144.6 rwkw (03/05/2008)

Top
 Profile  
 
 
Posted: Sat Feb 25, 2006 1:00 am 
Getting Side Ways
Offline
User avatar

Age: 52

Posts: 4370

Joined: 5th Nov 2004

Ride: BA Fairlane Ghia

Location: Karratha
WA, Australia

When i get any new car, i change the leads, plugs, oil, filters, dizzy parts etc, then you know whats been done and what hasnt.
Top
 Profile  
 
 
Posted: Sat Feb 25, 2006 2:42 pm 
Fordmods Junkie
Offline
User avatar

Age: 38

Posts: 5051

Joined: 5th Nov 2004

Ride: Kia Rio - 1.4L Auto

Power: 238 rwkw

Location: Westside
VIC, Australia

EF/EL Sanden compressors have a fair habit of destroying themselves internally and eventually seizing. Little bits of metal start breaking off the pump and jam it.

Sounds like what my one did, but luckily happened at 45,000km and the pump was changed and lines flushed under warranty.

If its causing the car to run like s**t when your accelerating, it would have nothing to do with the ISC.
Top
 Profile  
 
 
Posted: Sun Feb 26, 2006 1:06 am 
Fordmods Junkie
Offline
User avatar

Posts: 11739

Joined: 17th May 2005

Gallery: 11 images

Ride: EL Fairmont, VFR400 racer

Power: 144 rwkw

Location: Melbourne
VIC, Australia

car started running fine again. but i did ask the mechanic to check my air con while he was at it and the fuel line, sparkies and leads. so yeah hopefully nothing too much.

phong =P~

 

_________________

phongus = Post whore 2006
EL XR6 motor, EL ECU + J3 chip, WADE 1673 Camshaft, 3" S/S intake, Pacy 4480, 2.5" Hi flow cat, 2.5" Lukey exhaust.
Max Power = 144.6 rwkw (03/05/2008)

Top
 Profile  
 
Display posts from previous:
Sort by  
 Page 1 of 1  [ 12 posts ] 

Who is online

Users browsing this forum: Google Adsense [Bot] and 14 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

 

 

It is currently Tue Dec 19, 2017 5:44 am All times are UTC + 11 hours

 

 

(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names