Fordmods Logo

No Coolant/Inhibitor 

 

Page 1 of 1 [ 2 posts ] 

 
 Post subject: No Coolant/Inhibitor
Posted: Fri Feb 01, 2008 7:08 pm 
Getting Side Ways
Offline
User avatar

Age: 49

Posts: 6467

Joined: 18th Dec 2006

Ride: 93 ED sedan

Power: 161 rwkw

Location: Rockhampton
QLD, Australia

I know its a Mitsubishi, but the point is the same, no Inhibitor = expensive repairs. In this case, the cam belt broke, and has bent valves on 2 cylinders on the rear bank.
Have to now wait for the customer to get back us to see whether they want to fix it.

 

 

Attachments:
6G72 12V V6 Mits. 001.jpg
6G72 12V V6 Mits. 001.jpg [ 586.5 KiB | Viewed 25 times ]
6G72 12V V6 Mits. 003.jpg
6G72 12V V6 Mits. 003.jpg [ 499.35 KiB | Viewed 25 times ]

 

_________________

http://youtu.be/jJTh9F3Vgg0

Top
 Profile  
 
 
Posted: Fri Feb 01, 2008 8:10 pm 
Getting Side Ways
Offline

Posts: 1302

Joined: 10th Nov 2006

Location: Allmods suck so do viruses
WA, Australia

F**k mate that a real shocker

 

_________________

Your all a bunch of f**k Heads delete this f**k account stupid useless C*** who run this site cant even sell something useless wankers

Top
 Profile  
 
Display posts from previous:
Sort by  
 Page 1 of 1  [ 2 posts ] 

Who is online

Users browsing this forum: No registered users and 27 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

 

 

It is currently Sun Dec 17, 2017 7:24 pm All times are UTC + 11 hours

 

 

(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names