Fordmods Logo

no power under full throttle 

 

Page 1 of 2 [ 17 posts ] Go to page 1, 2  Next

 
 Post subject: no power under full throttle
Posted: Tue Apr 12, 2011 11:01 pm 
Smokin em up
Offline

Age: 24

Posts: 294

Joined: 27th Sep 2009

Ride: 1995 EF Ford Fairmont

Location: Bundaberg, QLD
QLD, Australia

Okay so i own an EF ford fairmont, and im having problems with my acceleration.
when i plant the foot on take off, the car seems like it loses all power and then after a bit it just screams and takes off like a rocket.
car is practically standard other then exhaust.
how can i fix this?
Top
 Profile  
 
 
 Post subject: Re: no power under full throttle
Posted: Wed Apr 13, 2011 9:20 am 
Getting Side Ways
Offline
User avatar

Age: 54

Posts: 844

Joined: 12th Aug 2007

Gallery: 22 images

Ride: AU2 XR8 ute & 91 EA bitsa

Location: Melbourne
VIC, Australia

Check you accelerator cable for frayed strands and make sure it moves freely. It might be sticking or stretched. After that, maybe look at the condition of the TPS (on the side of the throttle body).

How long has it been since the engine had a tune-up?

 

_________________

AU2 XR8 with Raptor VL, ported Yella Terra GT40P heads, Scorpion 1.6 RRs, XE264HR-14 Comp Cam, ceramic coated Hurricane Headers, 60lb injectors, Walbro 255, 200cfi cats, 3" exhaust & Snow Performance water methanol injection

Top
 Profile  
 
 
 Post subject: Re: no power under full throttle
Posted: Wed Apr 13, 2011 4:22 pm 
Parts Gopher
Offline

Posts: 74

Joined: 11th Nov 2004

Ride: EF 5 speed

Location: Canberra
ACT, Australia

Shortshift is right, a good way to check the accelerator cable is to take the intake tubing off the throttle body, stand in the door of the car and watch the throttle body butterfly opening/closing as you plant the accelerator pedal (with the car off :) ). Make sure it moves smoothly and that it's all the way open when the accelerator pedal is planted to the floor. If not, replace the cable.

If the cable is all good it could be a fuel issue, check/replace fuel filter first then move onto other things if necessary.
Top
 Profile  
 
 
 Post subject: Re: no power under full throttle
Posted: Wed Apr 13, 2011 4:33 pm 
Getting Side Ways
Offline

Age: 25

Posts: 510

Joined: 8th Aug 2010

Gallery: 9 images

Ride: NF Fairlane Ghia

my NF use to do a very similar thing
turned out to be the ignition leads
and the fuel filter

 

_________________

NF Fairlane Ghia, Brand New Leather Interior, Wallnut All Through, 800W RMS JL Audio Sound System, Lowered King Springs And Monroe GT Shocks, Custom BA/GT Air Intake, Holley Highflow, Simmons B45's, Going To Be Supercharged At 9-12psi With Stage 4 Head And Cam With Pacemakers And 3" Exhaust

Top
 Profile  
 
 
 Post subject: Re: no power under full throttle
Posted: Wed Apr 13, 2011 7:35 pm 
Smokin em up
Offline

Age: 24

Posts: 294

Joined: 27th Sep 2009

Ride: 1995 EF Ford Fairmont

Location: Bundaberg, QLD
QLD, Australia

okay will definatly check the throttle cable then, its very likely that it could be damaged.
the leads a brand new so it definatly isnt that as i did have issues with them and replaced them and sorted that all out. i also plan to change the fuel filter on it anyway so will do that tommorow and see what i come up with.
cheers guys will let you know how it goes.
Top
 Profile  
 
 
 Post subject: Re: no power under full throttle
Posted: Thu Apr 14, 2011 8:14 pm 
Getting Side Ways
Offline

Age: 50

Posts: 912

Joined: 22nd Mar 2005

Gallery: 1 images

Location: FNQ
QLD, Australia

"will let you know how it goes"

Good luck with it - and please do post what ends up happening with it - there are lots of threads that end up hanging with no posted result - which is frustrating when you're doing a later search for exactly that problem.

 

_________________

96 EF Auto GLi - Bilstein Shocks - Adjustable Front sway bar - JMM Cam - TI Perf J3 - TCI 2500/3000 stall converter. 2015 Jeep Cherokee Trailhawk.

Last edited by Greenmachine on Fri Apr 15, 2011 9:19 am, edited 1 time in total.

Top
 Profile  
 
 
 Post subject: Re: no power under full throttle
Posted: Thu Apr 14, 2011 11:10 pm 
Smokin em up
Offline

Age: 24

Posts: 294

Joined: 27th Sep 2009

Ride: 1995 EF Ford Fairmont

Location: Bundaberg, QLD
QLD, Australia

ohh sorry haha umm basicly got a fuel filter out of the shed then cross threaded the f**k out of it so now i need to get another one....
also the throttle body opens and closes fine and the throttle cable seems to be in good nick.
Top
 Profile  
 
 
 Post subject: Re: no power under full throttle
Posted: Fri Apr 15, 2011 9:22 am 
Getting Side Ways
Offline

Age: 50

Posts: 912

Joined: 22nd Mar 2005

Gallery: 1 images

Location: FNQ
QLD, Australia

Sorry, my earlier post was a bit heavy on - I've edited it down - I wasn't having a go at you and don't feel it necessary to give minute by minute updates - just posting what eventually fixes it would be nice is all :-)

 

_________________

96 EF Auto GLi - Bilstein Shocks - Adjustable Front sway bar - JMM Cam - TI Perf J3 - TCI 2500/3000 stall converter. 2015 Jeep Cherokee Trailhawk.

Top
 Profile  
 
 
 Post subject: Re: no power under full throttle
Posted: Fri Apr 15, 2011 9:46 am 
Getting Side Ways
Offline
User avatar

Age: 28

Posts: 404

Joined: 4th May 2007

Gallery: 8 images

Location: Noosa
QLD, Australia

Does it feel like it misses??? I had the same thing in my EF and it ended up being a dead coil pack. It would miss under load (taking off from lights and r-a-b) but once over about 2500rpm it was good again.

I suggest that as it is something fairly simple and fairly cheap to replace.

 

_________________

99 AU Fairlane Ghia V8 Black Leather, 19" ANZ 5+5's with 245/35 rubber
Full sound system. Extractors, Dual 2.25" exhaust.
Lowered on Tickford XR8 springs and shocks!!

Top
 Profile  
 
 
 Post subject: Re: no power under full throttle
Posted: Fri Apr 15, 2011 12:45 pm 
Smokin em up
Offline

Age: 24

Posts: 294

Joined: 27th Sep 2009

Ride: 1995 EF Ford Fairmont

Location: Bundaberg, QLD
QLD, Australia

the coil pack has been replaced with a brand new bosch one, it also has brand new leads and spark plugs. so spark shouldnt be the issue as its already been checked out fully.
once the fuel filter is replaced ill have to give it another run and see how it goesi think it will make a huge improvement cause the old one was really dirty
Top
 Profile  
 
 
 Post subject: Re: no power under full throttle
Posted: Fri Apr 15, 2011 7:01 pm 
Fordmods Newbie
Offline

Age: 29

Posts: 1

Joined: 3rd Apr 2011

Gallery: 1 images

Ride: EF Ford 95

Location: Shepparton
VIC, Australia

how many km's has your car done. i had the same problem. put new leads and spark plugs in. new coil pack, new fuel filter. ended up running worse. a mate and i were having a few beers and we both come up with it could be the fuel pump. put a new fuel pump in and went like brand new. a year ago and havent had a problem yet.
Top
 Profile  
 
 
 Post subject: Re: no power under full throttle
Posted: Fri Apr 15, 2011 7:08 pm 
Smokin em up
Offline

Age: 24

Posts: 294

Joined: 27th Sep 2009

Ride: 1995 EF Ford Fairmont

Location: Bundaberg, QLD
QLD, Australia

the fuel pump has been replaced since ive had the car but I might replace it anyway as it was replaced with a second hand one. the cars done like 350 thousand k's. ill replace the fuel filter forst then once ive done that and if I doesntt work ill replace thepump
Top
 Profile  
 
 
 Post subject: Re: no power under full throttle
Posted: Tue Apr 19, 2011 12:24 am 
Smokin em up
Offline

Age: 24

Posts: 294

Joined: 27th Sep 2009

Ride: 1995 EF Ford Fairmont

Location: Bundaberg, QLD
QLD, Australia

have replaced the fuel filter and it has made a significant difference, but it still bogs down a bit when i take off hard. not too sure what else there is i can do? any suggestions?
Top
 Profile  
 
 
 Post subject: Re: no power under full throttle
Posted: Tue Apr 19, 2011 1:08 am 
Getting Side Ways
Offline
User avatar

Age: 33

Posts: 1322

Joined: 21st Dec 2004

Gallery: 40 images

Ride: EF GLi/Ghia bitsa

Location: Melbourne
VIC, Australia

couple of things:

has it got a blocked cat or exhaust?
do a compression check, is it down on compression?
blocked injectors maybe?
stuffed oxygen sensor?
blocked air filter?
fuel pressure regulator?
could the ignition TIMING be out?
wonder if it might have a blown headgasket?

there's a few ideas to work with

Cheers, Gab
Top
 Profile  
 
 
 Post subject: Re: no power under full throttle
Posted: Tue Apr 19, 2011 11:16 am 
Smokin em up
Offline

Age: 24

Posts: 294

Joined: 27th Sep 2009

Ride: 1995 EF Ford Fairmont

Location: Bundaberg, QLD
QLD, Australia

umm exhaust should be fine but i have a hi flow cat on the way anyway, and ill be putting extractors on at the same time.
umm compression im not to sure on should be fine but as i just did the headgasket, which wasnt actually gone, but was on its way out.
air filter is brand new but only a cheap one, im gonna put a pod on it soon so well see what that changes.
oxygen sensor im not sure but will put one i know is working in when i put the extractors in.
blocked injectors could be likely as they did run a bit of crappy fuel through them for a while and they also sat around for a while. but it runs exactly the same on gas.
umm ignition timing, how can i check that?
and also the fuel pressure regulator?
Top
 Profile  
 
Display posts from previous:
Sort by  
 Page 1 of 2  [ 17 posts ]  Go to page 1, 2  Next

Who is online

Users browsing this forum: No registered users and 26 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

 

 

It is currently Wed Dec 13, 2017 10:29 am All times are UTC + 11 hours

 

 

(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names