Fordmods Logo

noisey valve springs?? 

 

Page 1 of 1 [ 3 posts ] 

 
 Post subject: noisey valve springs??
Posted: Thu Jan 11, 2007 4:58 pm 
Parts Gopher
Offline
User avatar

Age: 32

Posts: 96

Joined: 7th Nov 2004

Gallery: 2 images

Ride: XT Turbo

Location: Perth
WA, Australia

very since i got new surecam valve springs and my head ported n polished ive had a loud ticking noise (no its not the lifters) ive replace the rocker gear, changed the exhaust gasket, new injectors and reg, and have had the front of the motor rebuild. is it possible that the valve springs could be making the noise?

Cheers
Top
 Profile  
 
 
Posted: Thu Jan 11, 2007 7:43 pm 
Getting Side Ways
Offline
User avatar

Age: 49

Posts: 6467

Joined: 18th Dec 2006

Ride: 93 ED sedan

Power: 161 rwkw

Location: Rockhampton
QLD, Australia

Did you check for " coil bind " on the valve springs at full open/lift?
You need minimum 0.040" space between the coils of the springs at full lift, if not then they will hit making a noise, eventually breaking, not good.
It may even break a rocker, since they are alloy, and alloy doesn't like that sort of treatment.

 

_________________

http://youtu.be/jJTh9F3Vgg0

Top
 Profile  
 
 
Posted: Thu Jan 11, 2007 8:28 pm 
Parts Gopher
Offline
User avatar

Age: 32

Posts: 96

Joined: 7th Nov 2004

Gallery: 2 images

Ride: XT Turbo

Location: Perth
WA, Australia

cheers mate ill have to check with the engine builder and see if he did that.
Top
 Profile  
 
Display posts from previous:
Sort by  
 Page 1 of 1  [ 3 posts ] 

Who is online

Users browsing this forum: No registered users and 17 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

 

 

It is currently Fri Dec 15, 2017 10:29 am All times are UTC + 11 hours

 

 

(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names