Fordmods Logo

Oil pressure drop when driven on a hot day. 

 

Page 1 of 1 [ 1 post ] 

 
 Post subject: Oil pressure drop when driven on a hot day.
Posted: Fri Jan 14, 2005 1:06 am 
Parts Gopher
Offline

Age: 47

Posts: 72

Joined: 8th Nov 2004

Gallery: 3 images

Ride: Fairmont

Location: Sydney
NSW, Australia

G'day guys! I was wondering if anyone have an idea what's wrong with my I6. Today was a very hot day here in Western Sydney. As I was driving my 95 EF (mid-day), I noticed my oil pressure gauge was giving a very low reading...and when idling, it would go to the orange region and at one point gave off a beeping sound indicating very low oil pressure. This has been the second time it has occured, I ignored the previous one because it never happened again (on that day). I remember it was a very hot day (40degs) as well when it first happened. At these instances, my water temp reading is fairly normal...pointing at the letter 'M'. I am using 10-40W viscosity engine oil. This only happens when ambient temp approaches 40 degs.

Any ideas? Is it the engine oil? The heat? My oil pressure sender failing (in the heat)? Please help! Thanks in advance.


:D
Top
 Profile  
 
Display posts from previous:
Sort by  
 Page 1 of 1  [ 1 post ] 

Who is online

Users browsing this forum: No registered users and 31 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

 

 

It is currently Sat Dec 16, 2017 12:57 pm All times are UTC + 11 hours

 

 

(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names