Fordmods Logo

Oil pressure problem??? 

 

Page 1 of 1 [ 10 posts ] 

 
 Post subject: Oil pressure problem???
Posted: Mon Jan 16, 2006 9:38 pm 
Fordmods Newbie
Offline

Posts: 7

Joined: 28th Sep 2005

Gallery: 2 images

Location: adalaide
SA, Australia

This happend to me the other day, i was driving into adelaide, from the freeway, all was fine on freeway, once in adelaide, i come to stop lights, sitting there waiting, and suddenly my oil pressure starts beeping at me, i pulled off, keeping eye on it, and it raised back up to were it normally sits, next stop light, same thing. pulled over, checked oil levels which was fine.wat ive determined, is taht wen under revs, the pressure is normal, however wen idling, it drops markedy. i dont know much bout mechanics of cars, any pointers/suggestions about y this suddenly started happening. cheers
Top
 Profile  
 
 
Posted: Mon Jan 16, 2006 10:29 pm 
Getting Side Ways
Offline

Age: 31

Posts: 3772

Joined: 5th Nov 2004

Gallery: 33 images

Ride: EL Fairmont Ghia

Location: Hobart
TAS, Australia

my car does the same thing, now i have head that its often an electical problem and the oil pressure is in fact fine, but i am yet to prove this is the case. be good if someone can shed some better light on it, i searched this forum a couple of weeks ago for answers and no one really came up with a solution
Top
 Profile  
 
 
Posted: Mon Jan 16, 2006 10:30 pm 
Getting Side Ways
Offline
User avatar

Age: 43

Posts: 906

Joined: 9th Aug 2005

Gallery: 4 images

Ride: EB2

Location: s.e suburbs
VIC, Australia

the sender is faulty (you hope) or the pumps on its way out (you hope not)
Top
 Profile  
 
 
Posted: Mon Jan 16, 2006 10:40 pm 
Getting Side Ways
Offline

Age: 32

Posts: 972

Joined: 6th Feb 2005

Gallery: 6 images

Ride: XHII pano, Landau

Location: S.E Subs
VIC, Australia

what car??

 

_________________

Automatics only come in assult riffles
---------------------------------------
www.aussiecoupes.net

Top
 Profile  
 
 
Posted: Tue Jan 17, 2006 2:19 am 
Stock as a Rock
Offline
User avatar

Age: 34

Posts: 155

Joined: 5th Nov 2004

Gallery: 2 images

Ride: EL XR6

Location: melb
VIC, Australia

i got same problem. EL XR6.
ive changed the sender and all that little things people mention. plus earthed the sender running a wire cable from the battery - negative to the sender, ect. still wont fix sh*t.

and my car burns alot of oil.
so my cousin who is a mechanic said my bottom end of the engine needs a reco,
Top
 Profile  
 
 
Posted: Tue Jan 17, 2006 10:01 am 
Getting Side Ways
Offline
User avatar

Posts: 681

Joined: 3rd Apr 2005

Gallery: 24 images

Ride: BF MKII Ghia

i got the oppisite problem when im travelling my oil temp goes right up near the red even with gtx3 15w-40 oil. it get one notch of the red sometimes but when im idling its sits about half???
Top
 Profile  
 
 
Posted: Wed Jan 18, 2006 4:11 pm 
Getting Side Ways
Offline

Posts: 578

Joined: 22nd Mar 2005

Location: Melbourne
VIC, Australia

i've got the same problem as you tempest351, it was funny reading coz it's an exact copy of what I have giving me the irrates!

Can anyone shed light on how to check the sender for faults?

Cheers
Top
 Profile  
 
 
 Post subject: ??
Posted: Wed Jan 18, 2006 5:16 pm 
Getting Side Ways
Offline

Posts: 476

Joined: 28th Jan 2005

Ride: 1990 EA Spac

Location: grenfell
NSW, Australia

Fords only run about 40PSI oil pressure and it can be quite normal at idle for the pressure to be as low as 4PSI, as long as it rises as soon as you increase the revs all should be ok. This usually happens in hot weather when the engine also has done a lot of miles.
If you are worried get a proper oil pressure gauge and check it.

 

_________________

Drive safe, arrive alive

EA Spak EL dash and interior, thermo's,BBM, EF head and cam, superlows,

Top
 Profile  
 
 
Posted: Wed Jan 18, 2006 5:18 pm 
Getting Side Ways
Offline

Age: 36

Posts: 3794

Joined: 9th Aug 2005

Ride: Hilux

Location: Mornington
VIC, Australia

my pressure is low at idle(according to my guage) but as soon as engine speed picks up pressure builds. doesnt really bother me too much

 

_________________

Now driving a Hilux

Top
 Profile  
 
 
Posted: Wed Jan 18, 2006 7:57 pm 
Oompa Loompa
Offline

Age: 30

Posts: 42

Joined: 23rd Jun 2005

Gallery: 1 images

Ride: Eb II 5 speed Wagon

Location: the bush
NSW, Australia

does it blow oil out the dipstick or where ever? does it rattle due to oil starvation? if not dont worry that guage is so far inacurate its not funny , not one i get in works properly. dont stress yourself

 

_________________

EB II 5 Speed wagon
4L MPEFI with EEC IV & Smartlock
Air Con
Windscreen mounted sun visor
Tow Bar
15Inch Pensioner special Alloys with cheap tires
Radio/Cassete
Self Retracting Safety Belts
Fold Down Rear Seats
Clear Side Indicators

Such Exciting stuff is a GLI

Top
 Profile  
 
Display posts from previous:
Sort by  
 Page 1 of 1  [ 10 posts ] 

Who is online

Users browsing this forum: Google Adsense [Bot] and 22 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

 

 

It is currently Thu Dec 14, 2017 10:18 am All times are UTC + 11 hours

 

 

(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names