Fordmods Logo

Oil pressure problems (mabe) 

 

Page 1 of 2 [ 27 posts ] Go to page 1, 2  Next

 
 Post subject: Oil pressure problems (mabe)
Posted: Sat Feb 20, 2010 10:25 pm 
Getting Side Ways
Offline
User avatar

Age: 33

Posts: 3885

Joined: 6th Nov 2004

Gallery: 24 images

Ride: BF MKII XR6 Turbo

Location: Victor Harbor
SA, Australia

Hi all, i just put some Lifter treatment thru the engine today, to try and suppress the lifter noise problem.

But now i seem to have another problem, for the 1st time ive had the car my oil pressure was sitting on the 2nd to last stroke on the oil pressure gauge then went to under the last stroke while the car was at the lights etc..

I have never seen it go that low before.. But i did notice something weird, my Battery volts gauge was also reading high 11v to low 12v and the oil pressure gauge seemed to go high and low in unicen with the volt meter....

Also a first since ive had the XR.. Aaand on top of that wheneva i used my electric window switches the interior and headlights dimmed a bit....

Could this be an alternator on its way out?? And could these problems all be connected somehow or do i have 4 problems at once in one night! :cry:

Any help would be appreciated

Thanks

Andrew

 

_________________

Image -BF MKII XR6 Turbo in EGO-

Top
 Profile  
 
 
 Post subject: Re: Oil pressure problems (mabe)
Posted: Sat Feb 20, 2010 10:46 pm 
Getting Side Ways
Offline
User avatar

Posts: 807

Joined: 28th Oct 2008

Location: melburn
VIC, Australia

the best way to stop the ticking is get some of the plastic o-rings.
i fitted some to my EL engine last weekend and it is 100% silent.

but every falcon engine ive owned (3 now) has always been on the last stroke or under oil pressure wise :/

not sure what the deal is!

i'd say try replacing the oil filter, as after i did mine my oil pressure at least rose with the revs

 

_________________

XG Panelvan
mild engine, EL ECU & J3, HI6 & MSD coil

in the shed - .595" lift cam, GT4202, forged AU engine, ems 4424 ecu, glide & 5500 stall - next-bellhousing

XH ute daily - DOHC BA XR6 engine, T5, AU3 ECU, J3 chip, wideband & logger, ported BBM, 3" intake

Top
 Profile  
 
 
 Post subject: Re: Oil pressure problems (mabe)
Posted: Sat Feb 20, 2010 11:18 pm 
Getting Side Ways
Offline
User avatar

Age: 33

Posts: 3885

Joined: 6th Nov 2004

Gallery: 24 images

Ride: BF MKII XR6 Turbo

Location: Victor Harbor
SA, Australia

Yeah mine will too but doesnt go past the 2nd to last bar.. Just stays at that..The car will be gettin serviced next week so after some fresh oil and a new filter hopefully that sorts it out.. Thanks for the reply.

 

_________________

Image -BF MKII XR6 Turbo in EGO-

Top
 Profile  
 
 
 Post subject: Re: Oil pressure problems (mabe)
Posted: Sun Feb 21, 2010 3:46 pm 
Getting Side Ways
Offline
User avatar

Age: 33

Posts: 3885

Joined: 6th Nov 2004

Gallery: 24 images

Ride: BF MKII XR6 Turbo

Location: Victor Harbor
SA, Australia

Well started it up thismorning, and i had near full oil pressure reading on the gauge... Started driving around and it goes down to 1/2 way on the gauge, drove to Adelaide (50+ kms away) and she drops to 2nd bar till the bottom.. stays thier the whole time...

I get back home lift up the bonnet and noticed that my car had been leaking out coolant an alarming rate from a brass fitting sitting below my thermostat.... so i wonder if the OIl pressure had anything to do with my car possibly over heating/loosing too much coolant???

 

_________________

Image -BF MKII XR6 Turbo in EGO-

Top
 Profile  
 
 
 Post subject: Re: Oil pressure problems (mabe)
Posted: Sun Feb 21, 2010 4:51 pm 
Parts Gopher
Offline
User avatar

Age: 8

Posts: 59

Joined: 9th Aug 2009

Gallery: 22 images

Ride: A massive sideways utensill...

Location: Wagga Wagga
NSW, Australia

Thats the coolent tempreture sensor under your thermostat, and if you have coolent
running out of there at a constant rate that will most likley raise the engines tempreture because the
system isent under full pressure.
This also lowers the boiling tempreture of your cooling system, making it easy to overheat.

 

_________________

XR6, 3''CAI, sick'o BBM, no AC, 2.5''exhaust, special cat, PWR radiator&expansion-tank, BTR, kevlar bands, JMM converter, shiftkit, 4 pin 3.91:1, 31spline billets, minispool, Nolathane, RDA golds, My interior, genuine GT's.. (gallery) SpeedFlow

Last edited by wholagan on Mon May 02, 2011 10:14 pm, edited 1 time in total.

Top
 Profile  
 
 
 Post subject: Re: Oil pressure problems (mabe)
Posted: Sun Feb 21, 2010 5:12 pm 
Getting Side Ways
Offline
User avatar

Age: 33

Posts: 3885

Joined: 6th Nov 2004

Gallery: 24 images

Ride: BF MKII XR6 Turbo

Location: Victor Harbor
SA, Australia

Yeah coz my car was on LPG previously i had the unit upgraded to a Brass fitting. But now i dont have the LPG installed/hooked up any more the guy closed up one side of the fitting so that i didnt have to have the hose going to the mixer any more.. but the fitting they put on hasnt fully sealed properly, so im going to take it back and get them to refit/fix it so i dont have F*** coolant going everywhere over my nice clean engine bay!

It was sparying onto the belt and that was making it spill everywhere. Im surprised my car didnt overheat and die on the way home TBH!

If the engine does over heat thou, could that effect the oil pressure?? i tried doing a home DIY diagnostic on the rocker cover and i had a listen to the engine internals.. and nothing seemed out of the ordinary. Since puting in that lifter treatment the lifters seem a bit quieter but my injectors are fkn noisy as too! haha :cry:

 

_________________

Image -BF MKII XR6 Turbo in EGO-

Top
 Profile  
 
 
 Post subject: Re: Oil pressure problems (mabe)
Posted: Sun Feb 21, 2010 9:43 pm 
Getting Side Ways
Offline

Posts: 1221

Joined: 11th Nov 2007

Ride: f6 rspec

Location: Sydney
NSW, Australia

misk_one wrote:
the best way to stop the ticking is get some of the plastic o-rings.
i fitted some to my EL engine last weekend and it is 100% silent.

but every falcon engine ive owned (3 now) has always been on the last stroke or under oil pressure wise :/

not sure what the deal is!

i'd say try replacing the oil filter, as after i did mine my oil pressure at least rose with the revs



plastic o-rings? do u mean the lifter repair kits that u can get from spare parts shops?
Top
 Profile  
 
 
 Post subject: Re: Oil pressure problems (mabe)
Posted: Sun Feb 21, 2010 9:47 pm 
Getting Side Ways
Offline
User avatar

Posts: 807

Joined: 28th Oct 2008

Location: melburn
VIC, Australia

thats them...
they are little plastic clips that go over the top of the bottom part of the lash adjuster.
makes them silent

 

_________________

XG Panelvan
mild engine, EL ECU & J3, HI6 & MSD coil

in the shed - .595" lift cam, GT4202, forged AU engine, ems 4424 ecu, glide & 5500 stall - next-bellhousing

XH ute daily - DOHC BA XR6 engine, T5, AU3 ECU, J3 chip, wideband & logger, ported BBM, 3" intake

Top
 Profile  
 
 
 Post subject: Re: Oil pressure problems (mabe)
Posted: Sun Mar 07, 2010 7:48 pm 
Getting Side Ways
Offline
User avatar

Posts: 627

Joined: 5th Dec 2009

Gallery: 2 images

Ride: GREEN ED XR6

Power: 249 rwkw

Location: CENTRAL WEST QLD
QLD, Australia

Yup mine is doing that now ? its due for a service but now when its idling its just on the last bar (not the red one) and when im driving it barely gets to the secont notch and moves when revs increase the Lifters are a little ticky but nothing a seal kit wont fix but have a spare set here new anyway any thoughts? its the first time its done it too me since i put the VCT head on and dosent make a difference if i connect or dissconnect the VCT plug at all? im Puzzled !!!

 

_________________

AU2 engine with Hoppers head/cam performance package & spool rods / CP pistons ,Snort 1200 plenum, T56 Manual & Billet short shifter, Front & Rear Slotted rotors, Pedders lowered suspension, LSD and tuned with EMS stinger 4424 347rwkw THE ED XR6 IS BOOSTED

Top
 Profile  
 
 
 Post subject: Re: Oil pressure problems (mabe)
Posted: Tue Mar 09, 2010 11:43 am 
Getting Side Ways
Offline
User avatar

Age: 33

Posts: 3885

Joined: 6th Nov 2004

Gallery: 24 images

Ride: BF MKII XR6 Turbo

Location: Victor Harbor
SA, Australia

Ive put a lifter treament through mine and has made a small difference to the level of noise the lifters make now. But my Oil pressure seems to act differently depending on the volt gauge ive noticed, higher voltage i have 3/4 to a near full oil pressure but when the voltage sits on 12-11 the oil pressure stays under 1/2 all the time... Pretty strange. But mine is getting a serviced tommorrow so ill see how that goes.

 

_________________

Image -BF MKII XR6 Turbo in EGO-

Top
 Profile  
 
 
 Post subject: Re: Oil pressure problems (mabe)
Posted: Tue Mar 09, 2010 11:56 am 
Getting Side Ways
Offline
User avatar

Posts: 807

Joined: 28th Oct 2008

Location: melburn
VIC, Australia

the revs wouldnt happen to be different at those times would it?
ie when volts are at 11 your car is idling at 500rpm?

you should have 14 volts at all times...

 

_________________

XG Panelvan
mild engine, EL ECU & J3, HI6 & MSD coil

in the shed - .595" lift cam, GT4202, forged AU engine, ems 4424 ecu, glide & 5500 stall - next-bellhousing

XH ute daily - DOHC BA XR6 engine, T5, AU3 ECU, J3 chip, wideband & logger, ported BBM, 3" intake

Top
 Profile  
 
 
 Post subject: Re: Oil pressure problems (mabe)
Posted: Tue Mar 09, 2010 12:01 pm 
Getting Side Ways
Offline
User avatar

Age: 33

Posts: 3885

Joined: 6th Nov 2004

Gallery: 24 images

Ride: BF MKII XR6 Turbo

Location: Victor Harbor
SA, Australia

misk_one wrote:
the revs wouldnt happen to be different at those times would it?
ie when volts are at 11 your car is idling at 500rpm?

you should have 14 volts at all times...


Nah my car idles at about 600-800rpm most of the time (hav never seen it go below 600rpm).. and yes i know the volts should be 14 :-) I have a brand new battery in thier too (well like 3 months old ne way). Thats why i reckon it could be my Alternator...

 

_________________

Image -BF MKII XR6 Turbo in EGO-

Top
 Profile  
 
 
 Post subject: Re: Oil pressure problems (mabe)
Posted: Tue Mar 09, 2010 12:04 pm 
Getting Side Ways
Offline
User avatar

Posts: 807

Joined: 28th Oct 2008

Location: melburn
VIC, Australia

yeah either your alternator or the regulator are poo
just easier to get another.

the oil pressure issue is strange though.
my car sits on the very lowest bar.
i recently put an ef engine in with 170,000ks and i pulled th eoil pump apart and inspect4ed it before putting it back in and it looked fine.
so i have oil going somewhere it shouldnt at a quick rate :(

 

_________________

XG Panelvan
mild engine, EL ECU & J3, HI6 & MSD coil

in the shed - .595" lift cam, GT4202, forged AU engine, ems 4424 ecu, glide & 5500 stall - next-bellhousing

XH ute daily - DOHC BA XR6 engine, T5, AU3 ECU, J3 chip, wideband & logger, ported BBM, 3" intake

Top
 Profile  
 
 
 Post subject: Re: Oil pressure problems (mabe)
Posted: Tue Mar 09, 2010 2:08 pm 
Parts Gopher
Offline

Age: 35

Posts: 62

Joined: 11th Jan 2010

Ride: Eb2 ghia

Location: Manor Lakes
VIC, Australia

my oil pressure sits on about the 3rd bar from the left above the red, so just under halfway,
always does..
Top
 Profile  
 
 
 Post subject: Re: Oil pressure problems (mabe)
Posted: Wed Mar 10, 2010 6:04 pm 
Getting Side Ways
Offline
User avatar

Age: 33

Posts: 3885

Joined: 6th Nov 2004

Gallery: 24 images

Ride: BF MKII XR6 Turbo

Location: Victor Harbor
SA, Australia

Well i replaced the oil and filter today, and put some engine flush treatment through the old oil to get rid of the gunk. On inital startup with the new oil it seemed to have made the oil pressure better, engine was quieter on start up too (barely heard the lifters) but as soon as i took the cra for a drive i could hear the lifters ticking away.... ughhh fail! Its definately quieter on idle but not any diferent while driving.

Im also gettin some nice new performance plugs tommorrow too, so ill see how good the car goes after that.

 

_________________

Image -BF MKII XR6 Turbo in EGO-

Top
 Profile  
 
Display posts from previous:
Sort by  
 Page 1 of 2  [ 27 posts ]  Go to page 1, 2  Next

Who is online

Users browsing this forum: No registered users and 20 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

 

 

It is currently Tue Dec 19, 2017 12:24 am All times are UTC + 11 hours

 

 

(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names