Fordmods Logo

Oil pressure sensor 

 

Page 1 of 1 [ 14 posts ] 

 
 Post subject: Oil pressure sensor
Posted: Thu Nov 03, 2011 8:01 pm 
Fordmods Newbie
Offline

Age: 48

Posts: 18

Joined: 3rd Nov 2011

Ride: EB wagon

Location: Benalla
VIC, Australia

Just updated my instrument cluster to an ED sports panel.
Changed the oil pressure switch to a sender .
but the gauge shows just above the red.
the sender i put in was an EF sender.
Is this correct ?
If it is any other ideas
Top
 Profile  
 
 
 Post subject: Re: Oil pressure sensor
Posted: Thu Nov 03, 2011 8:05 pm 
Getting Side Ways
Offline

Age: 27

Posts: 424

Joined: 18th Feb 2010

Ride: Ford EF - Garret TO4Z

Location: Hobart
TAS, Australia

review your wireing , if its not connected gauge will read max, i belive from memory

 

_________________

Crank Assembly balanced, HV oil pump, ACL Trimetal bearings, "1 extra oil clearance taking to around 0.0650-0.0700 on mains and big ends, Moly rings,, Xr6 Cam, POD ( Possibly oversize injectors), Block, Head, Timing cover, belt idler, Alternator,painted in ford light blue

Top
 Profile  
 
 
 Post subject: Re: Oil pressure sensor
Posted: Thu Nov 03, 2011 8:10 pm 
Fordmods Newbie
Offline

Age: 48

Posts: 18

Joined: 3rd Nov 2011

Ride: EB wagon

Location: Benalla
VIC, Australia

Had the original switch in it changed it for a sensor
the switch gave max pressure
the sensor should be gradual
Top
 Profile  
 
 
 Post subject: Re: Oil pressure sensor
Posted: Thu Nov 03, 2011 8:20 pm 
Getting Side Ways
Offline

Age: 27

Posts: 424

Joined: 18th Feb 2010

Ride: Ford EF - Garret TO4Z

Location: Hobart
TAS, Australia

switch is a stubby thing , sender is like a larger one lol, ive got a ef futura and i put a sender and a xr cluster in with the gauge and it works sireing seems to be the same

 

_________________

Crank Assembly balanced, HV oil pump, ACL Trimetal bearings, "1 extra oil clearance taking to around 0.0650-0.0700 on mains and big ends, Moly rings,, Xr6 Cam, POD ( Possibly oversize injectors), Block, Head, Timing cover, belt idler, Alternator,painted in ford light blue

Top
 Profile  
 
 
 Post subject: Re: Oil pressure sensor
Posted: Thu Nov 03, 2011 8:23 pm 
Getting Side Ways
Offline
User avatar

Age: 32

Posts: 591

Joined: 28th May 2011

Gallery: 4 images

Ride: EF Futura DUH

Location: central coast
NSW, Australia

It would show a higher reading while driving or revving than at idle if functioning correctly.
Maybe it just has bugger all oil pressure?

My EF sits between the second and third highest points on the guage most of the time, though it has just had a rebuild and runs a high volume oil pump.

I hope this sheds some light

 

_________________

1996 EF Futura factory manual
Fully rebuilt engine,Decked, Honed, Bored, Tolerences spot on, Wade 1673, Extractors, 2.5" zorst, 3" CAI, High flow filter, Exedy sports tuff clutch, Chiptorque tune.
Future Mods: A mortgage...

Top
 Profile  
 
 
 Post subject: Re: Oil pressure sensor
Posted: Thu Nov 03, 2011 8:25 pm 
Getting Side Ways
Offline
User avatar

Age: 30

Posts: 849

Joined: 3rd Jan 2011

Gallery: 1 images

Ride: Subaru Liberty RX Wagon MY03

Location: North Richmond
NSW, Australia

Also, ef/el oil pressure senders are different to ea/b/d units. They have different resistance. You need VDO 360.013, available at Repco etc. for about $50 - $60.

 

_________________

Current ride: MY03 Liberty RX Wagon
EBII S-XR6, Now 5 speed. Moved on to greener pastures...

Top
 Profile  
 
 
 Post subject: Re: Oil pressure sensor
Posted: Thu Nov 03, 2011 8:28 pm 
Fordmods Newbie
Offline

Age: 48

Posts: 18

Joined: 3rd Nov 2011

Ride: EB wagon

Location: Benalla
VIC, Australia

I d read something about different sensor having different Ohm ratings
can anyone shed some light
the part i put in was a 290a

if the sensor isnt the problem then what might be ?
Top
 Profile  
 
 
 Post subject: Re: Oil pressure sensor
Posted: Thu Nov 03, 2011 8:46 pm 
Getting Side Ways
Offline
User avatar

Age: 30

Posts: 849

Joined: 3rd Jan 2011

Gallery: 1 images

Ride: Subaru Liberty RX Wagon MY03

Location: North Richmond
NSW, Australia

Was the sender new or used? Before I changed my sender, my gauge would read 200 kPa at the most.

Some info from the VDO Site
eb=360.013 10-180ohm
ef=360.045 couldn't find any info

Source: http://aftermarket.continental-corporation.com.au/files/CA2GZ79DXL/VDO_CATALOGUE_2011.pdf page 56

 

_________________

Current ride: MY03 Liberty RX Wagon
EBII S-XR6, Now 5 speed. Moved on to greener pastures...

Top
 Profile  
 
 
 Post subject: Re: Oil pressure sensor
Posted: Thu Nov 03, 2011 8:58 pm 
Fordmods Newbie
Offline

Age: 48

Posts: 18

Joined: 3rd Nov 2011

Ride: EB wagon

Location: Benalla
VIC, Australia

new from ford
mabe has the wrong Ohms???
Top
 Profile  
 
 
 Post subject: Re: Oil pressure sensor
Posted: Thu Nov 03, 2011 9:00 pm 
Technical Contributor
Offline
User avatar

Age: 28

Posts: 3705

Joined: 27th Sep 2006

Gallery: 20 images

Ride: ED Falcon

Power: 133 rwkw

Location: Leeton
NSW, Australia

You've already said you put an EF sender in it... It is the wrong sender... Has to be an EA to ED one...

I still have an ED sender in mine it max's out on the NL instrument cluster I'm running... Will change it when I get around to it one day...

Cheers,
Tim

 

_________________

93 Red ED 5spd Manual Build Thread

Performance: Complete AUII VCT Wiring & Power Train, Pacey Headers, 2.5" Exhaust, Exedy Clutch, DBA Rotors
Visuals: FG XR Wheel, XR Front, 17's, BA 5 Spd Shifter, BA Ghia Window Switches, NL Cluster
Tunes: 8" Pioneer Sub, JBL Speakers, Clarion Double DIN Headunit

Top
 Profile  
 
 
 Post subject: Re: Oil pressure sensor
Posted: Thu Nov 03, 2011 9:01 pm 
Fordmods Newbie
Offline

Age: 48

Posts: 18

Joined: 3rd Nov 2011

Ride: EB wagon

Location: Benalla
VIC, Australia

any idea on a part number ?
Top
 Profile  
 
 
 Post subject: Re: Oil pressure sensor
Posted: Thu Nov 03, 2011 9:10 pm 
Technical Contributor
Offline
User avatar

Age: 28

Posts: 3705

Joined: 27th Sep 2006

Gallery: 20 images

Ride: ED Falcon

Power: 133 rwkw

Location: Leeton
NSW, Australia

nope... go to ford and ask for an oil sender to suit a 93-94 ED Falcon... Or ask Papa Smurf on here... He works for ford... Go to repco or super cheap and ask for an oil sender to suit a 93-94 ED falcon... Any sales place should have documentation for this... Why is a part number so vital? As long as it is an oil pressure sender to suit an ED falcon you'll be set...

Alternatively go to wrecker and and take an oil pressure sender off an ED falcon... Looks heaps different to an EF one... All steel... and rather huge...

 

_________________

93 Red ED 5spd Manual Build Thread

Performance: Complete AUII VCT Wiring & Power Train, Pacey Headers, 2.5" Exhaust, Exedy Clutch, DBA Rotors
Visuals: FG XR Wheel, XR Front, 17's, BA 5 Spd Shifter, BA Ghia Window Switches, NL Cluster
Tunes: 8" Pioneer Sub, JBL Speakers, Clarion Double DIN Headunit

Top
 Profile  
 
 
 Post subject: Re: Oil pressure sensor
Posted: Thu Nov 03, 2011 9:12 pm 
Getting Side Ways
Offline
User avatar

Age: 30

Posts: 849

Joined: 3rd Jan 2011

Gallery: 1 images

Ride: Subaru Liberty RX Wagon MY03

Location: North Richmond
NSW, Australia

TimmyA wrote:
You've already said you put an EF sender in it... It is the wrong sender... Has to be an EA to ED one...

I still have an ED sender in mine it max's out on the NL instrument cluster I'm running... Will change it when I get around to it one day...

Cheers,
Tim



Pretty much what I have been saying.

 

_________________

Current ride: MY03 Liberty RX Wagon
EBII S-XR6, Now 5 speed. Moved on to greener pastures...

Top
 Profile  
 
 
 Post subject: Re: Oil pressure sensor
Posted: Thu Nov 03, 2011 9:16 pm 
Getting Side Ways
Offline
User avatar

Age: 30

Posts: 849

Joined: 3rd Jan 2011

Gallery: 1 images

Ride: Subaru Liberty RX Wagon MY03

Location: North Richmond
NSW, Australia

TimmyA wrote:
nope... go to ford and ask for an oil sender to suit a 93-94 ED Falcon... Or ask Papa Smurf on here... He works for ford... Go to repco or super cheap and ask for an oil sender to suit a 93-94 ED falcon... Any sales place should have documentation for this... Why is a part number so vital? As long as it is an oil pressure sender to suit an ED falcon you'll be set...

Alternatively go to wrecker and and take an oil pressure sender off an ED falcon... Looks heaps different to an EF one... All steel... and rather huge...



Don't bother from Ford. Part is obselete.

evxr6 wrote:
You need VDO 360.013, available at Repco etc. for about $50 - $60.

 

_________________

Current ride: MY03 Liberty RX Wagon
EBII S-XR6, Now 5 speed. Moved on to greener pastures...

Top
 Profile  
 
Display posts from previous:
Sort by  
 Page 1 of 1  [ 14 posts ] 

Who is online

Users browsing this forum: No registered users and 24 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

 

 

It is currently Thu Dec 14, 2017 9:54 pm All times are UTC + 11 hours

 

 

(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names