Fordmods Logo

oil pump dead 


Page 1 of 1 [ 2 posts ] 

 Post subject: oil pump dead
Posted: Fri Dec 14, 2007 4:43 pm 
Stock as a Rock
User avatar

Age: 37

Posts: 135

Joined: 3rd May 2006

Gallery: 3 images

Power: 149 rwkw

Location: Bendigo
VIC, Australia

hey guys,

was driving home from work, smashed it back to third at 100km/h slowing down for a corner, the motor staring rattling really loudly, pulled neutral and rolled the last 100m to my house, oil light was on and beeping its head off, i put 3.5 litres of oil in the motor coz it was very low, not leaking anywhere :evil: started motor and it stil rattles could the oil pump be dead????

need help before i start pulling the motor out etc



Skidz are cooooool!

15.49 @ 91MPH
2.327 60ft
Willowbank Raceway 14th October 2006
220k motor 320k auto

Posted: Sat Dec 15, 2007 9:27 am 
Getting Side Ways
User avatar

Age: 42

Posts: 906

Joined: 9th Aug 2005

Gallery: 4 images

Ride: EB2

Location: s.e suburbs
VIC, Australia

might be timing chain guides wheres the noise coming from
Display posts from previous:
Sort by  
 Page 1 of 1  [ 2 posts ] 

Who is online

Users browsing this forum: No registered users and 26 guests

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum



It is currently Sun Oct 23, 2016 1:12 pm All times are UTC + 11 hours



(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names