Fordmods Logo

Oils again, what should I use on this rebuilt stuff up 

 

Page 1 of 1 [ 13 posts ] 

 
 Post subject: Oils again, what should I use on this rebuilt stuff up
Posted: Thu May 18, 2006 10:40 pm 
Oompa Loompa
Offline

Posts: 38

Joined: 7th Apr 2006

Location: BlackStump
QLD, Australia

Hi guys, Any ideas on what would be the bets oil to use on this rebuilt motor?

It uses about 1Lt every 600Ks It doesnt seem to be leaking anywhere or blowing it out the back. It gets very cold here in the mournings so any suggestions would be a great help. Thanks

NA Fairlane
Top
 Profile  
 
 
Posted: Thu May 18, 2006 11:00 pm 
Smokin em up
Offline
User avatar

Age: 31

Posts: 247

Joined: 24th Nov 2005

Location: Brissy
QLD, Australia

I use Castrol GTX3 15W/40 with a white valvoline oil filter-V01. Change every 5000km.

The main reason why i choose this oil is cause supercheap sell it in a 5.5l bottle which is the oil capacity of the 4l donk.

Cheers.
Top
 Profile  
 
 
Posted: Thu May 18, 2006 11:18 pm 
Oompa Loompa
Offline

Posts: 38

Joined: 7th Apr 2006

Location: BlackStump
QLD, Australia

Hi Thanks, yes I had been useing that but it still burns through, I was wondering if there would be an oil that might help it's poorly built problems. I am hoping to get better the 600Ks out of 1 litre of oil.
Top
 Profile  
 
 
Posted: Thu May 18, 2006 11:29 pm 
Getting Side Ways
Offline
User avatar

Age: 31

Posts: 11103

Joined: 15th Nov 2004

Ride: AU III XR8 Pursuit 250 ute

Location: Hobart
TAS, Australia

there ain't no oil that's going to fix a f**k motor.

 

_________________

Heaps of performance EF/L parts for sale, including supercharged VCT motor!

2002 Ford AU Series III Falcon XR8 Pursuit 250 ute - 5.6L of V8 Windsor!

Top
 Profile  
 
 
Posted: Thu May 18, 2006 11:35 pm 
Oompa Loompa
Offline

Posts: 38

Joined: 7th Apr 2006

Location: BlackStump
QLD, Australia

Ya but I was wondering if a thicker oil or somthing like that would help. I am led to belive it didn't wear in properly.
Top
 Profile  
 
 
Posted: Thu May 18, 2006 11:46 pm 
NSW Cruise Moderator
Offline
User avatar

Age: 39

Posts: 7331

Joined: 5th Nov 2004

Gallery: 12 images

Ride: TE50

Location: ɹǝpun uʍop
NSW, Australia

thiscker would help but not solve the issue, and thicker is not good on cold starts, takes longer to lift to the top of the head,

 

_________________

Image

I have a car.

Top
 Profile  
 
 
Posted: Fri May 19, 2006 11:57 pm 
Getting Side Ways
Offline

Age: 51

Posts: 720

Joined: 18th Sep 2005

Ride: ef fairmont

Location: orange
NSW, Australia

it sounds like a turned oil ring to me. hoo did the motor?
Top
 Profile  
 
 
Posted: Sat May 20, 2006 12:09 am 
Oompa Loompa
Offline

Posts: 38

Joined: 7th Apr 2006

Location: BlackStump
QLD, Australia

Hi Mark, Here is the story about it all.


http://www.fordmods.com/forums/viewtopi ... highlight=

Still waiting for a court date.
Top
 Profile  
 
 
Posted: Sat May 20, 2006 12:23 am 
Getting Side Ways
Offline

Age: 51

Posts: 720

Joined: 18th Sep 2005

Ride: ef fairmont

Location: orange
NSW, Australia

4 grang it a lot for a rebuild take the f***ker to court it sounds like a turned oil ring or he has broken a oil ring or he hasnt seperated the ring gaps .the bloke i take all my work to his price would of been 2 grand at the most .and that is afull rebuild.
Top
 Profile  
 
 
Posted: Sat May 20, 2006 10:02 pm 
Getting Side Ways
Offline
User avatar

Age: 28

Posts: 2983

Joined: 15th Apr 2006

Gallery: 5 images

Ride: Falcon

Location: Aberfoyle Park
SA, Australia

Ok one thing u need to do NOW. Get rid of that Castrol Oil. FYI Castron GTX is the WORST oil you can ever use. I used to take the heads off the falcons and commies and you can tell when castrol oil has been used. What happens is the oil sticks to the motor. Like you know when oil just builds up around the mainfolds and the rocker cover and just in general. Well thats that castrol is doing to your motor. Its building up on everything and it starts to block off holes that are used to circulate oil around the motor. I use Shell Heluix Ultra or Mobil One. Its synthetic and cost about $50 for 5L. Some times you can get the oil filter and the Oil for about 45-50$ on special. But remember once you go synthetic you CANT go back. Your motor will also last alot longer. Mine has been using Shell Helix Ultra for 100'000 Km's and (on 276'xxx now) and its still going fine. Better than some 150's i know of.
But its your car you do what you want. Its just personal experience that 1/2 motors at the wrecker that we did change overs were castrol. Its bad news

 

_________________

HOLDENS go like rockets. They fall apart in stages!!!

Top
 Profile  
 
 
Posted: Sat May 20, 2006 10:34 pm 
Moderator
Offline

Posts: 14513

Joined: 7th Nov 2004

Ride: ford falcon au3 xr8

Location: a shit suburb in sydney
NSW, Australia

I would try penrite hpr30 (20w/60)or you could go even thicker hpr40 (25w/60)or hpr 50(40w/70) i think hpr50 is a bit to thick..
but depends how cold it is in your area..
hpr40 will help if your burning oil ...
Top
 Profile  
 
 
Posted: Sun May 21, 2006 12:19 am 
Getting Side Ways
Offline
User avatar

Age: 64

Posts: 3552

Joined: 7th Nov 2004

Gallery: 4 images

Power: 482 rwkw

Location: Penrith
NSW, Australia

Just use cheap oil and check oil every second tankfull... Its stuffed no point in throwing good $$$ into a stuffed engine...!!! $12 oil from Woolworths is good enough....
Retarding timing a few degree should help oil consumption...

 

_________________

As in ZOOM 126 edition
331 Dart block,3.25/ 4340 steel crank, Oliver rods,TFS ported track heat heads, TFS track heat inlet Twin SC61 turbo's
Project 1UZ-EF has started.. S475 Turbo 4.0 V8 Mustang Celica.....

Top
 Profile  
 
 
Posted: Sun May 21, 2006 2:09 am 
Getting Side Ways
Offline

Age: 66

Posts: 2548

Joined: 18th Mar 2006

Ride: EF-XR8chaser

Location: wollongong
NSW, Australia

Fubar wrote:
Hi Thanks, yes I had been useing that but it still burns through, I was wondering if there would be an oil that might help it's poorly built problems. I am hoping to get better the 600Ks out of 1 litre of oil.
i would say its worn out,is it re built,the rings-if fitted to deglazed bores,shoud run running in oil for about 1000 ks-straight 30 grade,no additives.repco sells it.to stop oil use you may have to rebuild,deglaze bores and change rings. at the moment your oil control rings are shot and both compression rings havnt seated to bores,no fix-it will keep on using oil and get worse.i usually rebuild before it gets this bad

 

_________________

R.I.P HANS HARTMAN

Top
 Profile  
 
Display posts from previous:
Sort by  
 Page 1 of 1  [ 13 posts ] 

Who is online

Users browsing this forum: No registered users and 14 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

 

 

It is currently Mon Dec 18, 2017 3:40 am All times are UTC + 11 hours

 

 

(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names