Fordmods Logo

Petrol Issues 

 

Page 1 of 1 [ 5 posts ] 

 
 Post subject: Petrol Issues
Posted: Tue Sep 01, 2009 1:59 pm 
Parts Gopher
Offline

Age: 26

Posts: 71

Joined: 17th Apr 2008

Ride: 06/10 FG XR6 Sedan

Location: Adelaide
SA, Australia

Hey guys,

Wow its been ages since I have been here, I couldn't log in for some reason but it worked today! (Maybe I remembered the correct stuff this time!)

I recently got my 03 BA Wagon serviced (its done 98000kms) and since its been serviced it is chonking through the petrol. For example, I drove 5.5kms and used 10kms worth of Petrol. I filled my car up (I always use BP Unleaded) and it said I had 448kms worth of petrol at full. I have driven 100kms since and now have 315Kms worth of petrol.

The guy who I had it serviced with gave me an itemised receipt on which he said he had cleaned my air filter. He has not cleaned that (it is a K&N Pod Filter). I have taken it to another mechanic and it is booked in to get fixed on Thursday.

Just wondering what you guys think the problem could be?

Thanks,

Tom

 

_________________

My band: www.myspace.com/hybridillusion

Top
 Profile  
 
 
 Post subject: Re: Petrol Issues
Posted: Tue Sep 01, 2009 2:18 pm 
Moderator
Offline
User avatar

Age: 40

Posts: 2327

Joined: 6th Oct 2005

Ride: 93EB Fairmont / BA Falcon XR6T

Location: Western Sydney
NSW, Australia

Well a dirty air filter is a start for it to be chewing petrol.
Check tyre pressures.
Try using premium unleaded in it.

And why are you paying to go to another mechanic? You should be asking the guy who touched it what he did and then check the itemised receipt of what was done and see if it was done. If he has said he done things without doing then i would abuse the s**t out of him.
I wonder if he changed your oil filter???

 

_________________

93 EB II Fairmon8 with 17' EL GT's / Clear indicators / H.I.Ds / Sports exhaust / Lowered 2' / K&N / XR6 ECU.
2004 BA MKI XR6T in Lightning Strike paint / K&N / XR8 bonnet / BF lights and a few tweaks.

Top
 Profile  
 
 
 Post subject: Re: Petrol Issues
Posted: Wed Sep 02, 2009 3:55 pm 
Parts Gopher
Offline

Age: 26

Posts: 71

Joined: 17th Apr 2008

Ride: 06/10 FG XR6 Sedan

Location: Adelaide
SA, Australia

Because I dont trust he will rectify the problems if the hasn't done it right in the first place. The mechanic I am going to is the one I should have gone to in the first place.

I am wondering if the problem has gone away, how inaccurate is the Range to Empty feature on trip computers?

The exact stats are as follows:

448km at Full - 144.0km travelled = 304km left

My trip says I have 307km left, so now its saying I have more petrol than I should. Perhaps my computer is having some problems?

 

_________________

My band: www.myspace.com/hybridillusion

Top
 Profile  
 
 
 Post subject: Re: Petrol Issues
Posted: Wed Sep 02, 2009 4:06 pm 
Moderator
Offline
User avatar

Age: 40

Posts: 2327

Joined: 6th Oct 2005

Ride: 93EB Fairmont / BA Falcon XR6T

Location: Western Sydney
NSW, Australia

The trip computer is pretty acurate but i would not trust it a 100%.
You may find the L/100kms is high and the computer is giving an average on those readings. Try resetting the Liters per 100 km and drive it easy and see if the Range increases. It should increase as the Litres per 100km lowers. You do this by holding down the trip button until it beeps. My XR hovers around the 13.5 L/100 mark and gets as low as 10 on long highway driving on cruise control and can go 15 or higher if i drive it hard. I expect yours should be lower again.

 

_________________

93 EB II Fairmon8 with 17' EL GT's / Clear indicators / H.I.Ds / Sports exhaust / Lowered 2' / K&N / XR6 ECU.
2004 BA MKI XR6T in Lightning Strike paint / K&N / XR8 bonnet / BF lights and a few tweaks.

Top
 Profile  
 
 
 Post subject: Re: Petrol Issues
Posted: Thu Sep 03, 2009 1:29 am 
Parts Gopher
Offline

Age: 26

Posts: 71

Joined: 17th Apr 2008

Ride: 06/10 FG XR6 Sedan

Location: Adelaide
SA, Australia

Today I was driving a lot and I have noticed that, when the engine was churning through the petrol, it was at an AVG of ~16.6L/100 its now at 14.1L/100. I have also cleaned my air filter.

Hopefully its all fixed!

 

_________________

My band: www.myspace.com/hybridillusion

Top
 Profile  
 
Display posts from previous:
Sort by  
 Page 1 of 1  [ 5 posts ] 

Who is online

Users browsing this forum: No registered users and 20 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

 

 

It is currently Tue Dec 19, 2017 8:03 am All times are UTC + 11 hours

 

 

(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names