Fordmods Logo

Please help !!!!!!!!!! 

 

Page 1 of 1 [ 8 posts ] 

 
 Post subject: Please help !!!!!!!!!!
Posted: Fri Oct 21, 2011 8:02 pm 
Smokin em up
Offline

Age: 26

Posts: 284

Joined: 7th Sep 2011

Gallery: 4 images

Ride: Ef wagon

Location: Upper ferntree gully
VIC, Australia

My car had been sitting for a week . Just did new raditor and toped up the oil and now my gearbox is sliping ??? Is it just my gearbox is stuffed or is it somthing alse?? Please help me
Top
 Profile  
 
 
 Post subject: Re: Please help !!!!!!!!!!
Posted: Fri Oct 21, 2011 8:32 pm 
Smokin em up
Offline

Age: 26

Posts: 284

Joined: 7th Sep 2011

Gallery: 4 images

Ride: Ef wagon

Location: Upper ferntree gully
VIC, Australia

Just cos i got a alaminum one and nar no red stuff .. Could it be cos i have 2 much oil in the motor??
Top
 Profile  
 
 
 Post subject: Re: Please help !!!!!!!!!!
Posted: Fri Oct 21, 2011 10:56 pm 
Getting Side Ways
Offline
User avatar

Age: 39

Posts: 843

Joined: 20th Feb 2010

Gallery: 2 images

Ride: AU Fairmont Ghia

Location: Elizibif Norf (Local Spelling!!)
SA, Australia

Was the trans topped up with fluid after the radiator swap? And are the trans cooler fittings to the new radiator tightened up enough? Low auto trans fluid level will cause it to slip.

 

_________________

dc_todd wrote:
Cheap pads squeal like cheap hookers, and you can take that to the bank.


Au Fairmont Ghia
My (Old) 95 EF Wagon

Top
 Profile  
 
 
 Post subject: Re: Please help !!!!!!!!!!
Posted: Fri Oct 21, 2011 11:37 pm 
Smokin em up
Offline

Age: 26

Posts: 284

Joined: 7th Sep 2011

Gallery: 4 images

Ride: Ef wagon

Location: Upper ferntree gully
VIC, Australia

Well oil p****d out of the radtior ahah so il try top it up and that makes me feel soooooo much better i hope its just the oil i really cant aford 2 get it fixed thanks
Top
 Profile  
 
 
 Post subject: Re: Please help !!!!!!!!!!
Posted: Fri Oct 21, 2011 11:55 pm 
Smokin em up
Offline

Age: 26

Posts: 284

Joined: 7th Sep 2011

Gallery: 4 images

Ride: Ef wagon

Location: Upper ferntree gully
VIC, Australia

I dont think so i have never looked i have a 97 el farmont wagon so i realy dont no if i do ahah but i have a pump and the oil to do it so il just put some in and c if it will fix it :)
Top
 Profile  
 
 
 Post subject: Re: Please help !!!!!!!!!!
Posted: Sat Oct 22, 2011 12:03 am 
Smokin em up
Offline

Age: 26

Posts: 284

Joined: 7th Sep 2011

Gallery: 4 images

Ride: Ef wagon

Location: Upper ferntree gully
VIC, Australia

Ahahaah i no how u feel
I think il just top it up tomorro and c how it runs thanks 4 the help
Top
 Profile  
 
 
 Post subject: Re: Please help !!!!!!!!!!
Posted: Sat Oct 22, 2011 5:13 am 
Tyre Shredder
Offline
User avatar

Posts: 326

Joined: 12th Jun 2010

Ride: EL Fairmont

Location: Central Highlands
QLD, Australia

Your auto fluid level must have already been low too cause your current auto problems. You may aswell get a new filter kit $30 and 4l of auto oil and given it a good service.............

 

_________________

Current ride 2007
ML GLX Dualcab Triton 4x4

Top
 Profile  
 
 
 Post subject: Re: Please help !!!!!!!!!!
Posted: Sun Oct 23, 2011 11:23 pm 
Smokin em up
Offline

Age: 26

Posts: 284

Joined: 7th Sep 2011

Gallery: 4 images

Ride: Ef wagon

Location: Upper ferntree gully
VIC, Australia

yer i topped it up and now its all better :) thanks
Top
 Profile  
 
Display posts from previous:
Sort by  
 Page 1 of 1  [ 8 posts ] 

Who is online

Users browsing this forum: No registered users and 37 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

 

 

It is currently Sat Dec 16, 2017 10:50 pm All times are UTC + 11 hours

 

 

(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names