Fordmods Logo

POS BA Falcon problems 

 

Page 1 of 1 [ 11 posts ] 

 
 Post subject: POS BA Falcon problems
Posted: Mon Feb 23, 2009 6:45 pm 
Stock as a Rock
Offline

Posts: 189

Joined: 5th May 2008

Location: Kununurra
WA, Australia

Hey guys my POS BA XR6 is driving me insane right now. It used to be a mad machine speed/accelerationwise now its the most gutless peice of crap pretty much happened overnight. It sits in the middle of the temp guage and it never does and once it gets to 4000rpms it loses all power and starts spluttering. it almost feels like clutch is slipping but its an auto. Any help would be appreciated

Cheers
J

 

_________________

-- Built Not Bought --

Top
 Profile  
 
 
 Post subject: Re: POS BA Falcon problems
Posted: Mon Feb 23, 2009 6:53 pm 
Getting Side Ways
Offline

Posts: 1221

Joined: 11th Nov 2007

Ride: f6 rspec

Location: Sydney
NSW, Australia

what have u checked?

sputtering? sounds like fuel problems..checked ur filter, pump, regulator, injectors?

I'd start with a simple service changing plugs, filters and run some injector cleaner through it with some premium fuel..
Top
 Profile  
 
 
 Post subject: Re: POS BA Falcon problems
Posted: Mon Feb 23, 2009 7:00 pm 
Oompa Loompa
Offline

Age: 32

Posts: 37

Joined: 3rd Nov 2008

Ride: BF xr8 Ute

Location: Tamworth
NSW, Australia

check your mufflers and cats to mate could be all blocked up how old are the cats

 

_________________

CANT HATE A V8 LOUD N PROUD

Top
 Profile  
 
 
 Post subject: Re: POS BA Falcon problems
Posted: Mon Feb 23, 2009 7:30 pm 
Stock as a Rock
Offline

Posts: 189

Joined: 5th May 2008

Location: Kununurra
WA, Australia

Hey thanks for your help. I meant the temp guage now sits on half which it hasnt before. thought id clear that up. It also sounds a bit weezy. and it is definately not as loud as it used to be. I havent done anything yet. i thought i had dirty fuel so i drained it all and run premium through it but still the same. i'll change the plugs and the filters when i get back from work next week. as for the cat it has never been changed but the exhaust back from there is all brand new, 2 1/2 inch with one sport hiflow muffler. cheers for your help again
J

 

_________________

-- Built Not Bought --

Top
 Profile  
 
 
 Post subject: Re: POS BA Falcon problems
Posted: Mon Feb 23, 2009 7:49 pm 
Stock as a Rock
Offline
User avatar

Posts: 103

Joined: 7th Jul 2008

Location: perth
WA, Australia

+1 for check cat. bro's car had same problem couple of years back. he ended up modifying it *wink wink*

 

_________________

1995 EF Futura
Port and Polished 94DT Tickford Head - Crow valve springs - 68mm Throttle Body - Wade 1673
4499 Pacemakers - 2.5" exhaust - Ti J3 Chip - 2J1 Techedge Logger -EL Tickford 3.45LSD -
XR low springs - Boge Turbo Shocks - Front DBA slotted Rotors - BA ESS shifter - Shift Kit

Top
 Profile  
 
 
 Post subject: Re: POS BA Falcon problems
Posted: Mon Feb 23, 2009 9:09 pm 
Getting Side Ways
Offline
User avatar

Age: 64

Posts: 3448

Joined: 11th Jan 2009

Ride: BA Falcon XT

Location: Smithfield
NSW, Australia

Could be your Cat. Check the H.E.G.O. sensor as well.
How long has it been since you had your Auto flushed? and a new filter?
Do you regularly use some for of injector cleaner in your beast? change the Fuel filter? fuel can have dirt and rubbish in it and varnish buildup on your injector tips makes for rough running.
Top
 Profile  
 
 
 Post subject: Re: POS BA Falcon problems
Posted: Tue Feb 24, 2009 12:08 am 
Technical Contributor
Offline
User avatar

Age: 32

Posts: 2517

Joined: 7th Nov 2004

Gallery: 4 images

Ride: LS3 VF

Location: Bunbury
WA, Australia

+3 for blocked cat / exhaust
Top
 Profile  
 
 
 Post subject: Re: POS BA Falcon problems
Posted: Tue Feb 24, 2009 12:11 am 
Getting Side Ways
Offline
User avatar

Age: 38

Posts: 1228

Joined: 5th Mar 2006

Gallery: 25 images

Ride: FALCON EB TURBO, EL XR6

Location: Sydney
NSW, Australia

Hows your air filter? new? clean?

 

_________________

FALCAHOLIC

IF AT FIRST YOU DON'T SUCCEED
DESTROY ALL EVIDENCE THAT YOU EVEN TRIED


Image

Top
 Profile  
 
 
 Post subject: Re: POS BA Falcon problems
Posted: Tue Feb 24, 2009 11:33 am 
Getting Side Ways
Offline

Age: 30

Posts: 1798

Joined: 14th Jun 2006

Gallery: 7 images

Ride: FG 50th Anni G6E Turbo

Location: Melbourne
VIC, Australia

xpression wrote:
+3 for blocked cat / exhaust


Agreed. If its lost power, and is no longer as loud as it used to be... spluttering at high revs. Stuffed Cat for sure.
Top
 Profile  
 
 
 Post subject: Re: POS BA Falcon problems
Posted: Tue Feb 24, 2009 1:53 pm 
Stock as a Rock
Offline

Posts: 189

Joined: 5th May 2008

Location: Kununurra
WA, Australia

cheers guys much appreciated, yeah i cleaned my air filter already... Im out at work for a week so i left it at my bro's place, hes an apprentice mechanic which worries me lol. But i told him how to change the cat over so he going to do that as well as a full service for me while im away. Hopefully that will fix my problem, thanks heaps guys i'll let you know on friday how it goes.

Oh by the way what made the cat s**t itself? is it all the ceramic stuff just in the way of the exhaust gasses getting out? So in theory hollowing it out would fix the problem? im not going to do that of course but just if im stuck in another situation like i was last week it would be helpful. i was stuck in perth and needed to be in gero where my shed is (and second cat) and it was painful driving the 5 hours back.

Cheers again guys

J

 

_________________

-- Built Not Bought --

Top
 Profile  
 
 
 Post subject: Re: POS BA Falcon problems
Posted: Wed Feb 25, 2009 10:25 am 
Stock as a Rock
Offline

Posts: 189

Joined: 5th May 2008

Location: Kununurra
WA, Australia

Was a blocked fuel filter guys. dont ask me why that made the car quieter? fukn confusing. Car is now for sale, im just going to use my bike now since im off to uni in NSW in June. Road trip across the world on my zzr600... should be fun ;)

Thanks anyway

 

_________________

-- Built Not Bought --

Top
 Profile  
 
Display posts from previous:
Sort by  
 Page 1 of 1  [ 11 posts ] 

Who is online

Users browsing this forum: No registered users and 15 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

 

 

It is currently Wed Dec 13, 2017 5:43 am All times are UTC + 11 hours

 

 

(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names