Fordmods Logo

Pre-ignition 

 

Page 1 of 1 [ 10 posts ] 

 
 Post subject: Pre-ignition
Posted: Wed Dec 15, 2004 4:45 pm 
Smokin em up
Offline
User avatar

Posts: 225

Joined: 5th Nov 2004

Gallery: 1 images

Ride: Falcon

Location: Mount Gambier
SA, Australia

Hi, just wondering what causes my Ea to pre-ignite after the ignition is turned off, help would be much appreciated
Top
 Profile  
 
 
Posted: Wed Dec 15, 2004 4:54 pm 
Getting Side Ways
Offline
User avatar

Age: 54

Posts: 4102

Joined: 18th Nov 2004

Gallery: 10 images

Ride: PX2 Ranger 4x4 XLT Dual CAB

Location: Carrum Downs
VIC, Australia

Pre-ignition can be caused by, idle set to high, incorrect ignition timing, or high engine temperature.

 

_________________

Image
She's meanness put to music and the b**ch is born to run!
Like the sign says, "speed's just a question of money. How fast can you go?"

Top
 Profile  
 
 
Posted: Wed Dec 15, 2004 8:44 pm 
Getting Side Ways
Offline

Posts: 6449

Joined: 11th Nov 2004

you shouldn't have these problems with fuel injected cars. as when the car is turned off ther is no fuel going into the engine. and so the car should never run on after the key is off
i'd say you have problems other then ignition

 

_________________

PERMANENTLY BANNED

Top
 Profile  
 
 
Posted: Wed Dec 15, 2004 8:48 pm 
Getting Side Ways
Offline
User avatar

Age: 35

Posts: 1037

Joined: 5th Nov 2004

Gallery: 1 images

Ride: V8 T5 Fairmont & BA XR6T

Location: Sydney
NSW, Australia

Is your EA EFI or carbie? Carbon deposits in the combustion chamber are also known to cause pre ignition/ pinging. Is the car actually running on or pinging its a*** off?

 

_________________

Dima, Mitch & Jay's RPD

Top
 Profile  
 
 
Posted: Wed Dec 15, 2004 9:34 pm 
Getting Side Ways
Offline
User avatar

Age: 52

Posts: 4370

Joined: 5th Nov 2004

Ride: BA Fairlane Ghia

Location: Karratha
WA, Australia

Jaysen wrote:
Is your EA EFI or carbie? Carbon deposits in the combustion chamber are also known to cause pre ignition/ pinging. Is the car actually running on or pinging its a*** off?
EAs were either MPFI, or TBI, as in a single injector, no carbies, though they look like it, as was said, EFI shouldnt deisel/pre ign, more probs there than that.
Top
 Profile  
 
 
Posted: Wed Dec 15, 2004 11:36 pm 
Getting Side Ways
Offline

Age: 36

Posts: 7287

Joined: 5th Nov 2004

Gallery: 12 images

Ride: 1994 ED XR8 Sprint

Location: Somewhere in
QLD, Australia

tho there could be enough oil getting forced past the rings and coming in as vapour thru the PCV system to cause it for a short while

 

_________________

Banned

Top
 Profile  
 
 
Posted: Wed Dec 15, 2004 11:49 pm 
Getting Side Ways
Offline
User avatar

Age: 35

Posts: 850

Joined: 10th Nov 2004

Gallery: 20 images

Ride: 03 BA Fairmont

Location: Forest Lake
QLD, Australia

i know with my eb if i give it boot while turning the key of, it runs on. Perhaps rich mixture or something??

 

_________________

Regards,
Punnisher_42
_____________
2003 BA Fairmont - Stock standard
1994 U13 cough Nissan Cough Bluebird

Favorite Quotes:
"Sportwagon = homo-erotic wank-fest." - downingj

Top
 Profile  
 
 
Posted: Thu Dec 16, 2004 12:48 am 
Smokin em up
Offline
User avatar

Posts: 225

Joined: 5th Nov 2004

Gallery: 1 images

Ride: Falcon

Location: Mount Gambier
SA, Australia

yeh pinging its a**s off, so how do i do the mixture
Top
 Profile  
 
 
Posted: Thu Dec 16, 2004 9:52 am 
Getting Side Ways
Offline
User avatar

Age: 33

Posts: 3277

Joined: 5th Nov 2004

Gallery: 36 images

Ride: Ronald Mcdonald Mobile

Location: Sydney
NSW, Australia

it could be the fuel you are using. or it is most probably incorrect timing

 

_________________

Gooooone - Eb2 Coon - 143RWKW
Now - Mazda MX5 with HKS Supercharger 190RWKW
Crescent Motorsport Liverpool - 9600 6229

Top
 Profile  
 
 
Posted: Thu Dec 16, 2004 8:22 pm 
Smokin em up
Offline

Age: 45

Posts: 206

Joined: 5th Nov 2004

Gallery: 3 images

Ride: 2004 BA Falcon MkII

Location: Manjimup
WA, Australia

shai12 wrote:
yeh pinging its a**s off, so how do i do the mixture


Sounds like the timing needs checking.

It probably needs to be retarded slightly. By say 3-4 degrees.

 

_________________

Kel.
BHR
A/MD 1272
240 inch Dragster
466 Big Block Ford
650hp
8.40 @ 156mph (251kph)

Top
 Profile  
 
Display posts from previous:
Sort by  
 Page 1 of 1  [ 10 posts ] 

Who is online

Users browsing this forum: No registered users and 28 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

 

 

It is currently Sat Dec 16, 2017 2:23 pm All times are UTC + 11 hours

 

 

(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names