Fordmods Logo

PROBLEM with stalling EL Falcon 

 

Page 1 of 2 [ 21 posts ] Go to page 1, 2  Next

 
 Post subject: PROBLEM with stalling EL Falcon
Posted: Tue Jul 04, 2006 4:01 pm 
Parts Gopher
Offline
User avatar

Age: 35

Posts: 63

Joined: 1st Dec 2004

Ride: EL

Location: Perth
WA, Australia

G'day guys.

Got a query bout the falc. Its prob been happening for the last 6 months or so on and off, but its getting bad now and it did it to me last night in peak hour traffic! Anyways when its cold and I put it in D and go to take off/accelerate it stalls, if I’m quick I can slip it back in to neutral and rev it a bit or it stalls. This only happens when its cold, when engine temp is normal its fine, or if i give it a bit of s**t it seems not to do it. it only happened when I was stationary and talking off at the lights or an intersection, its doing it every time i start it up now.

But last night it happened while I was going along, as I slowed down for a round-about and it was going back down gears it stalled, and it took a few secs to fire it up again (lost power steering so nearly went up curb), falc doesn’t like being started after stalling. Then it did it to me at a giveaway sign.

So now I either have to put it in neutral when I’m slowing down of use both feet, one on brake and one on throttle to keep the revs up a bit.

(My car is not standard, crow stage 2 cam, head work, XR6 ECU, paccies, exhuast)

So that’s the problem. Any ideas on a cure?

Fuel pump, injectors?

Ignition, leads/plugs?

stall converter/transmission?

I’ve got no idea and when i take it to a mechanic to look at it, the car will be warm so its most likely not going to do it.

Hopefully not an expensive fix.

it need to address the problem soon as I’m heading down south to Margaret river and don’t want something to pack it in completely (I don’t have any RAC/RAA cover).

any help regarding this matter would be greatly appreciated, now gota find a mechanic in perth to take it to. (Im new to the state, recently moved from SA)
Top
 Profile  
 
 
Posted: Tue Jul 04, 2006 4:40 pm 
Getting Side Ways
Offline

Age: 29

Posts: 1538

Joined: 4th May 2006

Gallery: 4 images

Ride: ef fairmont turbo

Power: 213 rwkw

Location: melbourne
VIC, Australia

check the leads

 

_________________

96 EF FAIRMONT
Garrett gt40turbo, iceman plenum, ported head, turbo cam, double valvesprings, 023 fuel pump, 36lb injectors 4' cat, 4' dump, 2.5 exhaust, build bottom end, hypertonic pistons rods & rods, king bearings, j3. c10 3500 stall
232rwkw@4psi

Top
 Profile  
 
 
Posted: Tue Jul 04, 2006 5:21 pm 
Getting Side Ways
Offline

Age: 32

Posts: 1679

Joined: 9th Jul 2005

Gallery: 8 images

Ride: BA XR6 TURBO

Location: Newcastle
NSW, Australia

got fuel? lol
nah id check the plugs and mainly leads and get some injector cleaner from supercheap and run it aswell, wouldnt hurt anyway
Top
 Profile  
 
 
Posted: Tue Jul 04, 2006 5:54 pm 
Getting Side Ways
Offline

Age: 28

Posts: 1135

Joined: 27th Oct 2005

Gallery: 3 images

Location: SA
SA, Australia

hmm sounds exactly the same as my grandparents problem. took it to a ford mechanic and turned out to be timing chain loose as all f**k. put new one in an shes good as gold again
Top
 Profile  
 
 
Posted: Tue Jul 04, 2006 6:34 pm 
Parts Gopher
Offline
User avatar

Age: 35

Posts: 63

Joined: 1st Dec 2004

Ride: EL

Location: Perth
WA, Australia

cheers guys, yep bout to buy some injector cleaner. I put 67 litres in the other day so i ran her dry a bit, she could have picked some crap up from the bottom of the tank then.

Leads were changed 30,000km ago. i will check them.

How easy/hard is it to change fuel filters?
Top
 Profile  
 
 
Posted: Tue Jul 04, 2006 6:39 pm 
Technical Contributor
Offline
User avatar

Age: 38

Posts: 4093

Joined: 20th Mar 2005

Gallery: 2 images

Ride: 2.0 Turbo VW

Power: 142 rwkw

Location: Seaford State:
VIC, Australia

change the the coil,
They're reasonably cheap and most likely its done 200,000k's!

 

_________________

Carefree, we may not be number one, but we're up there.

Top
 Profile  
 
 
Posted: Tue Jul 04, 2006 8:29 pm 
Parts Gopher
Offline
User avatar

Age: 35

Posts: 63

Joined: 1st Dec 2004

Ride: EL

Location: Perth
WA, Australia

Valid point, car has done 242,000km
Top
 Profile  
 
 
Posted: Tue Jul 04, 2006 9:15 pm 
Getting Side Ways
Offline

Age: 34

Posts: 756

Joined: 21st Nov 2005

Gallery: 25 images

Ride: 1999 AU futura

Location: griffith
NSW, Australia

Have you checked your MAP sensor.Have had a EA mpfi which had similar symptoms.See if you can take it to the wreckers and try one and if it works there you go.But if it doesnt well have to keep searchin for the problem.When your car stalls does any lights appear on your dash,like engine light or something like that?

 

_________________

COMING SOON,XD WITH A TURBO...CLEVO STYLE

Top
 Profile  
 
 
Posted: Tue Jul 04, 2006 9:19 pm 
Getting Side Ways
Offline

Age: 30

Posts: 4609

Joined: 29th Jul 2005

Gallery: 10 images

Ride: BOXCAR

Location: Launceston
TAS, Australia

i'd say coil. I had a VERY similar issues on mine. and it only had 154,000 kms :o

 

_________________

^^^ What He Said

<a href="http://www.fordmods.com/forums/viewtopic.php?t=44952" target="_blank" class="postlink"> TAS Cruises</a>

Top
 Profile  
 
 
Posted: Tue Jul 04, 2006 9:31 pm 
Getting Side Ways
Offline

Age: 34

Posts: 756

Joined: 21st Nov 2005

Gallery: 25 images

Ride: 1999 AU futura

Location: griffith
NSW, Australia

You could also check your fuel pump.How old is it?Is it noisey.I would go get a fuel gauge and check its flow and if it holds pressure in the fuel line.

 

_________________

COMING SOON,XD WITH A TURBO...CLEVO STYLE

Top
 Profile  
 
 
Posted: Wed Jul 05, 2006 2:19 am 
Getting Side Ways
Offline

Posts: 1310

Joined: 12th Dec 2005

Location: Perth
WA, Australia

did you have the crow cam before the problem started happening... every person I've ever heard of with a crow cam in their falcon has had major idle problems.
Top
 Profile  
 
 
Posted: Wed Jul 05, 2006 12:34 pm 
Getting Side Ways
Offline

Age: 32

Posts: 1679

Joined: 9th Jul 2005

Gallery: 8 images

Ride: BA XR6 TURBO

Location: Newcastle
NSW, Australia

I got a crow cam in mine and have had no idle problems at all.. apart from chunky :P
Top
 Profile  
 
 
Posted: Wed Jul 05, 2006 1:53 pm 
Parts Gopher
Offline
User avatar

Age: 35

Posts: 63

Joined: 1st Dec 2004

Ride: EL

Location: Perth
WA, Australia

have had the crow cam for 4 years now, so it shouldnt be related to that. Idle quality was s**t, but since putting the XR6 ECU in sep 05 it has improved it heaps, different car, idle characteristics way better.

My old man recons its a fuel pump problem, its the same pump from when it rolled off the factory floor.
Top
 Profile  
 
 
Posted: Wed Jul 05, 2006 2:01 pm 
Getting Side Ways
Offline

Posts: 1310

Joined: 12th Dec 2005

Location: Perth
WA, Australia

well you got a list of what it could be.. check the isc first as it's the easiest.. then fuel filter.. then all the other stuff I reckon :)
Top
 Profile  
 
 
Posted: Wed Jul 05, 2006 2:07 pm 
Parts Gopher
Offline
User avatar

Age: 35

Posts: 63

Joined: 1st Dec 2004

Ride: EL

Location: Perth
WA, Australia

Havnt noticed any lights KRPUTD, although i am only looking at the tachomoeter to see what the revs are doing thats where im looking all the time. i cant say ive noticed any lights, will check the next time it does it.

Funny thing though, driving around last night, it didnt do it at all. but i was driving so it wouldnt do it (keeping revs up, using brake a bit). gona see if its gona do it tonight, if so gona have to get a mech to look at it.
Top
 Profile  
 
Display posts from previous:
Sort by  
 Page 1 of 2  [ 21 posts ]  Go to page 1, 2  Next

Who is online

Users browsing this forum: No registered users and 16 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

 

 

It is currently Tue Dec 19, 2017 4:06 am All times are UTC + 11 hours

 

 

(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names