Fordmods Logo

problems never sieze please help ! 

 

Page 1 of 1 [ 14 posts ] 

 
 Post subject: problems never sieze please help !
Posted: Sat Oct 17, 2009 8:10 pm 
Technical Contributor
Offline
User avatar

Age: 26

Posts: 676

Joined: 7th Jun 2009

Ride: Ford EB II Falcon

Location: Morphett Vale
SA, Australia

Hey guys quick background history is this i drive a 93 EB II Dual Fuel

The other week i had problems so replaced the coil and replaced the dizzy with a $35 one, fitted a new battery then got it on the road but since then i have had issue. The petrol was driving fine but the gas would go into low revs and stall and the battery icon would come up, then i went to the place where i got the gas fitted and they tuned it today briefly and then the gas went fine for a while.

Then i was at Subway and it stalled, the car started fine again but gas keeps stalling again when in drive due to low revs, then i switched it to petrol to get home and it stalled again but once again started fine, i got it home then did a few switches of fuel and each time it stalls i get a battery icon and the voltage fluctuates rapidly. its a new battery and its matinence free and says its fine with the green charge light.

Could it be the cheap dizzy? I guess ill have to get a multimeter but how to i check what it is? Could i get Battery World to do a system charging test?

Edit: it was running even worse and my vents wouldnt work, but that as just a loose vaccum hose which i plugged back in !

 

_________________

OLD CAR: EB II Falcon, Everglade Green, 250thous (Rough Guess), Wildcat Extractors, 2.5 Exhaust with Muffler + Hot Dog, 18 Inch Rodney Jane Mags, XH Snorkel, EA MPEFI Tubing !

NEW CAR: 1996 TE Magna...Mods Soon To Come

Top
 Profile  
 
 
 Post subject: Re: problems never sieze please help !
Posted: Sat Oct 17, 2009 8:48 pm 
Getting Side Ways
Offline
User avatar

Age: 49

Posts: 1634

Joined: 8th Jul 2007

Gallery: 21 images

Ride: EL F100 CAPRI XR EF

Power: 234 rwkw

Location: brighton
SA, Australia

far out i would be checking for another vac hose off, map sensor maybe.
check coil leads on firmly and the plug from the loom to coil and maybe plug for the tfi on the dizzy.
i doubt it would be the dizzy, what cap did u end up using?
Top
 Profile  
 
 
 Post subject: Re: problems never sieze please help !
Posted: Sat Oct 17, 2009 9:13 pm 
Getting Side Ways
Offline
User avatar

Age: 49

Posts: 6467

Joined: 18th Dec 2006

Ride: 93 ED sedan

Power: 161 rwkw

Location: Rockhampton
QLD, Australia

Are you running the right spark plugs???....How good are the HT leads???? Is the alternator any good???

 

_________________

http://youtu.be/jJTh9F3Vgg0

Top
 Profile  
 
 
 Post subject: Re: problems never sieze please help !
Posted: Sun Oct 18, 2009 10:04 am 
Technical Contributor
Offline
User avatar

Age: 26

Posts: 676

Joined: 7th Jun 2009

Ride: Ford EB II Falcon

Location: Morphett Vale
SA, Australia

I will check other hoses and map sensor and what not soonish, but as for the cap i used my old one because it was still pretty much intact, the lead are newish and plugs are brand new. When i drive the charge on the instrument cluster is at about 15 when accelerating and when my foot is off the pedal and the car is rolling the arrow is just on the charged side, just over the half way mark. I have a pretty heavy sound system which bumps the voltage around a bit but its a new battery and the system has never caused me an issue before.

Edit: Also my mechanic replaced the spark plugs himself so he should have put the right ones in !

 

_________________

OLD CAR: EB II Falcon, Everglade Green, 250thous (Rough Guess), Wildcat Extractors, 2.5 Exhaust with Muffler + Hot Dog, 18 Inch Rodney Jane Mags, XH Snorkel, EA MPEFI Tubing !

NEW CAR: 1996 TE Magna...Mods Soon To Come

Top
 Profile  
 
 
 Post subject: Re: problems never sieze please help !
Posted: Sun Oct 18, 2009 11:11 am 
SA Cruise Moderator
Offline
User avatar

Age: 28

Posts: 916

Joined: 7th Oct 2007

Ride: Ford Ed

Location: Edwardstown, Adelaide
SA, Australia

You can rule the sound system out.. So its when your rev's are low it cuts out??
same thing happens to my mum's EF...

 

_________________

Adelaide E Series

Top
 Profile  
 
 
 Post subject: Re: problems never sieze please help !
Posted: Sun Oct 18, 2009 12:44 pm 
Technical Contributor
Offline
User avatar

Age: 26

Posts: 676

Joined: 7th Jun 2009

Ride: Ford EB II Falcon

Location: Morphett Vale
SA, Australia

Yea when the car idles it is about 12-13 Volts when moving the car is at about 15 volts, and then the volts die down and the revs go low and it stalls !

 

_________________

OLD CAR: EB II Falcon, Everglade Green, 250thous (Rough Guess), Wildcat Extractors, 2.5 Exhaust with Muffler + Hot Dog, 18 Inch Rodney Jane Mags, XH Snorkel, EA MPEFI Tubing !

NEW CAR: 1996 TE Magna...Mods Soon To Come

Top
 Profile  
 
 
 Post subject: Re: problems never sieze please help !
Posted: Sun Oct 18, 2009 1:21 pm 
Getting Side Ways
Offline
User avatar

Age: 49

Posts: 1634

Joined: 8th Jul 2007

Gallery: 21 images

Ride: EL F100 CAPRI XR EF

Power: 234 rwkw

Location: brighton
SA, Australia

needs a multimeter on it, can u get it down to me around 6.30 today. sounds like the alternator is dying
Top
 Profile  
 
 
 Post subject: Re: problems never sieze please help !
Posted: Sun Oct 18, 2009 1:32 pm 
Technical Contributor
Offline
User avatar

Age: 26

Posts: 676

Joined: 7th Jun 2009

Ride: Ford EB II Falcon

Location: Morphett Vale
SA, Australia

I need to do some year12 work but i will see how i go ! Thanks for the offer either way !

 

_________________

OLD CAR: EB II Falcon, Everglade Green, 250thous (Rough Guess), Wildcat Extractors, 2.5 Exhaust with Muffler + Hot Dog, 18 Inch Rodney Jane Mags, XH Snorkel, EA MPEFI Tubing !

NEW CAR: 1996 TE Magna...Mods Soon To Come

Top
 Profile  
 
 
 Post subject: Re: problems never sieze please help !
Posted: Sun Oct 18, 2009 9:43 pm 
Technical Contributor
Offline
User avatar

Age: 26

Posts: 676

Joined: 7th Jun 2009

Ride: Ford EB II Falcon

Location: Morphett Vale
SA, Australia

If it needs a new alternator how much so i be looking at pay for one? i can also try UPI

 

_________________

OLD CAR: EB II Falcon, Everglade Green, 250thous (Rough Guess), Wildcat Extractors, 2.5 Exhaust with Muffler + Hot Dog, 18 Inch Rodney Jane Mags, XH Snorkel, EA MPEFI Tubing !

NEW CAR: 1996 TE Magna...Mods Soon To Come

Top
 Profile  
 
 
 Post subject: Re: problems never sieze please help !
Posted: Sun Oct 18, 2009 11:46 pm 
SA Cruise Moderator
Offline
User avatar

Age: 28

Posts: 916

Joined: 7th Oct 2007

Ride: Ford Ed

Location: Edwardstown, Adelaide
SA, Australia

Depends what the plug is... i might have one! It came off a ea i think..

 

_________________

Adelaide E Series

Top
 Profile  
 
 
 Post subject: Re: problems never sieze please help !
Posted: Mon Oct 19, 2009 12:33 am 
Getting Side Ways
Offline
User avatar

Age: 49

Posts: 1634

Joined: 8th Jul 2007

Gallery: 21 images

Ride: EL F100 CAPRI XR EF

Power: 234 rwkw

Location: brighton
SA, Australia

im pretty sure the ea ones are different plug than eb ed ones, upi sell em for around $33, look for something clean, like its just been recoed.

jaycar sell a cheap basic multimeter about $10 or maybe d**k smiths have a cheap one too

to test the alternator with a multimeter, u need to switch the multimeter to 20v dc and put the red lead to positive and black to negative on battery.
a fully charged battery will read over 12.6 volts
start up the car with all accessories on eg headlights on high beam, hazard lights, airconditioner with fan on high and have someone put their foot on the brake pedal too.
now the multimeter should be reading around 13 volts or as high as 14 volts give or take a couple of points (eg 14.2) with everything on and engine running.
hold the meter on the battery for a while and see if the reading drops
any readings lower than 12.8v and i would replace the alternator
Top
 Profile  
 
 
 Post subject: Re: problems never sieze please help !
Posted: Mon Oct 19, 2009 9:33 am 
Technical Contributor
Offline
User avatar

Age: 26

Posts: 676

Joined: 7th Jun 2009

Ride: Ford EB II Falcon

Location: Morphett Vale
SA, Australia

Ok cool i might try that today, on my way to Aldinga i drove the car on gas all the way and turned the bass from my sound system all off, and i didnt have any issue except that it lags a bit so i think it could be the Alternator. Also is it uncommon for a Throttle Body to give me these sorts of issues?

 

_________________

OLD CAR: EB II Falcon, Everglade Green, 250thous (Rough Guess), Wildcat Extractors, 2.5 Exhaust with Muffler + Hot Dog, 18 Inch Rodney Jane Mags, XH Snorkel, EA MPEFI Tubing !

NEW CAR: 1996 TE Magna...Mods Soon To Come

Top
 Profile  
 
 
 Post subject: Re: problems never sieze please help !
Posted: Mon Oct 19, 2009 11:03 am 
Getting Side Ways
Offline
User avatar

Age: 49

Posts: 1634

Joined: 8th Jul 2007

Gallery: 21 images

Ride: EL F100 CAPRI XR EF

Power: 234 rwkw

Location: brighton
SA, Australia

if u havent cleaned it out with carby cleaner ever it could be part of the problem, more likely the idle speed control (isc) on top of the throttle body needs a good clean out. do them both if u get the chance.
Top
 Profile  
 
 
 Post subject: Re: problems never sieze please help !
Posted: Mon Oct 19, 2009 4:04 pm 
Technical Contributor
Offline
User avatar

Age: 26

Posts: 676

Joined: 7th Jun 2009

Ride: Ford EB II Falcon

Location: Morphett Vale
SA, Australia

Ok well how do i go about cleaning both? Also i dont really wanna take the TB off because then i have to disconnect the gas connections is there an easy way?

Also i measured the cars volts when it was off i got 12.5, then i put the car in the on position and turned everything on and was only getting about 11volts but the instrument cluster says different !

I am getting the car looked over on wednesday arvo

edit: and with the engine running but no feet on the brake, but with air con, lights on i got a reading of 12.77-12.97 either one !

 

_________________

OLD CAR: EB II Falcon, Everglade Green, 250thous (Rough Guess), Wildcat Extractors, 2.5 Exhaust with Muffler + Hot Dog, 18 Inch Rodney Jane Mags, XH Snorkel, EA MPEFI Tubing !

NEW CAR: 1996 TE Magna...Mods Soon To Come

Top
 Profile  
 
Display posts from previous:
Sort by  
 Page 1 of 1  [ 14 posts ] 

Who is online

Users browsing this forum: No registered users and 21 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

 

 

It is currently Wed Dec 13, 2017 11:14 am All times are UTC + 11 hours

 

 

(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names