Fordmods Logo

Put my battery in backwards 

 

Page 1 of 1 [ 9 posts ] 

 
 Post subject: Put my battery in backwards
Posted: Sat May 05, 2007 4:13 pm 
Fordmods Newbie
Offline

Posts: 3

Joined: 5th May 2007

Location: Christchurch
New Zealand

Yes I did - I know!!!
My 95ef Fairmont is F**Ked I connected the wrong terminals.
(Long story dont ask!; I will admit that when I did this the heater turned on and the window wipers started going - eek!)
replaced some blown fuses, now only turns over & doesnt start
Tried bashing the dash and felt better (after reading similar post)
However Car still wont GO!

Oh yeah the smartlock light dosnt flash anymore, maybe i fried something

HELP!!! I have to drive my old toyota now!
Top
 Profile  
 
 
Posted: Sat May 05, 2007 5:21 pm 
Getting Side Ways
Offline
User avatar

Posts: 2644

Joined: 6th Nov 2004

Gallery: 8 images

Ride: 2007

Location: Mount Annan
NSW, Australia

BEM, is a good place to start if it is not cranking, it is fused by the interior lamp fuse, Check that first then remove it and check some tracks may be burnt off.

 

_________________

BF Fairmont Ghia Series II update.
GQ XR6T ghia patrol.

,======o00o
//__|__|_,\_____\,___
|_/--\'_|'__|_/--\_[]IIII[]
_( o ) )_____( o ) )=o=) )__

Top
 Profile  
 
 
Posted: Sat May 05, 2007 5:56 pm 
Technical Contributor
Offline
User avatar

Age: 38

Posts: 4093

Joined: 20th Mar 2005

Gallery: 2 images

Ride: 2.0 Turbo VW

Power: 142 rwkw

Location: Seaford State:
VIC, Australia

checked the main fuses in the engine bay?

 

_________________

Carefree, we may not be number one, but we're up there.

Top
 Profile  
 
 
Posted: Sat May 05, 2007 6:04 pm 
Fordmods Newbie
Offline

Posts: 3

Joined: 5th May 2007

Location: Christchurch
New Zealand

I changed the main fuse in the engine bay as it had blown, it was the blue one in the middle of a line on the drivers side, are there any more under the bonnet
Top
 Profile  
 
 
Posted: Sat May 05, 2007 6:14 pm 
Fordmods Newbie
Offline

Posts: 3

Joined: 5th May 2007

Location: Christchurch
New Zealand

twason THANK YOU! It goes! I thought I checked all the fuses but obviously i didn't, You guys rock ;)
Top
 Profile  
 
 
Posted: Sat May 05, 2007 11:28 pm 
Getting Side Ways
Offline
User avatar

Age: 36

Posts: 831

Joined: 9th Nov 2004

Gallery: 4 images

Ride: BA XR8 & 06 4x4 Bravo

Location: Pakenham
VIC, Australia

Yeah it normally just blows fuses..

Last week at work I had a brand new Battery which had been charged wrong, + was - & - was + anyone else ever seen that before!

 

_________________

Image
'04 BA XR8
Winter White, 5 Speed Manual, Sports Leather, Premium Sound, 2 1/2" Cat Back Exh - no rear Mufflers, Lowered SL/SSL, 20's, Underdrives, BF Typhoon Rear Spoiler, GT Steering Wheel, etc.

Top
 Profile  
 
 
Posted: Sun May 06, 2007 8:49 am 
Fordmods Junkie
Offline
User avatar

Posts: 11738

Joined: 17th May 2005

Gallery: 11 images

Ride: EL Fairmont, VFR400 racer

Power: 144 rwkw

Location: Melbourne
VIC, Australia

cheersdude wrote:
Yeah it normally just blows fuses..

Last week at work I had a brand new Battery which had been charged wrong, + was - & - was + anyone else ever seen that before!


bahahaha. forced reverse chemical reaction = lose.

good you got your car up and running again weldpool.

phong =P~

 

_________________

phongus = Post whore 2006
EL XR6 motor, EL ECU + J3 chip, WADE 1673 Camshaft, 3" S/S intake, Pacy 4480, 2.5" Hi flow cat, 2.5" Lukey exhaust.
Max Power = 144.6 rwkw (03/05/2008)

Top
 Profile  
 
 
Posted: Mon May 07, 2007 1:12 am 
Technical Contributor
Offline
User avatar

Age: 32

Posts: 2517

Joined: 7th Nov 2004

Gallery: 4 images

Ride: LS3 VF

Location: Bunbury
WA, Australia

cheersdude wrote:
Yeah it normally just blows fuses..

Last week at work I had a brand new Battery which had been charged wrong, + was - & - was + anyone else ever seen that before!


yeh i have, it was a genuine mitsubishi battery too.
Top
 Profile  
 
 
Posted: Mon May 07, 2007 6:51 pm 
Getting Side Ways
Offline
User avatar

Age: 33

Posts: 5924

Joined: 5th Nov 2004

Gallery: 7 images

Ride: Ford FPV FG F6 310

Power: 149 rwkw

Location: Brisbane
QLD, Australia

cheersdude wrote:
Yeah it normally just blows fuses..

Last week at work I had a brand new Battery which had been charged wrong, + was - & - was + anyone else ever seen that before!


yeh i seen it before too.
leave it go ultra flat and reverse charge it and you've got yourself a good prank!

 

_________________

NEW RIDE - FPV FG F6 6spd Auto. 12.26@114MPH, 1.88 60FT on Cheapy Tyres with 38PSI - Stock except K&N filter!

R.I.P. BF XR6 Turbo - You will not be forgotten :( 12.06@120MPH

Top
 Profile  
 
Display posts from previous:
Sort by  
 Page 1 of 1  [ 9 posts ] 

Who is online

Users browsing this forum: No registered users and 26 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

 

 

It is currently Tue Dec 12, 2017 10:44 am All times are UTC + 11 hours

 

 

(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names