Fordmods Logo

rough idle after a RWC check 

 

Page 1 of 1 [ 3 posts ] 

 
 Post subject: rough idle after a RWC check
Posted: Thu Jul 21, 2005 5:48 pm 
Fordmods Junkie
Offline
User avatar

Posts: 11739

Joined: 17th May 2005

Gallery: 11 images

Ride: EL Fairmont, VFR400 racer

Power: 144 rwkw

Location: Melbourne
VIC, Australia

hey everyone. took my car to a mechanic to get a RWC. got it back today and the idle seems very rough now. my side mirrors are shaking and it never used to do that. i can feel the vibration everytime i put my feet on the pedal.

this is what the mechanic did to the engine as quoted on the RWC.

Transmission mounts to be replaced
Diff vent pipe to be replaced
transmission oil leak to be fixed
timing case oil seal to be replaced.

now i dunno what he did but the car seems to idle rough and start off rough. i went for a drive home which is 10 mins, from the mechanic and to the shops today which all together was about a 25 min drive, and about 5 min idle time being stuck in traffic and my i lost a whole notch on my fuel. never used to use that much to get to the local shop

could anyone help me?

thanks

phong

 

_________________

phongus = Post whore 2006
EL XR6 motor, EL ECU + J3 chip, WADE 1673 Camshaft, 3" S/S intake, Pacy 4480, 2.5" Hi flow cat, 2.5" Lukey exhaust.
Max Power = 144.6 rwkw (03/05/2008)

Top
 Profile  
 
 
Posted: Thu Jul 21, 2005 6:16 pm 
Getting Side Ways
Offline
User avatar

Age: 33

Posts: 496

Joined: 10th Nov 2004

Gallery: 5 images

Ride: EBII Fairmont Ghia

Location: Warragul
VIC, Australia

Take it back to him, make sure all vac hoses are attached, like the one on the map sensor (on firewall).

Ben
Top
 Profile  
 
 
Posted: Thu Jul 21, 2005 7:05 pm 
Fordmods Junkie
Offline
User avatar

Posts: 11739

Joined: 17th May 2005

Gallery: 11 images

Ride: EL Fairmont, VFR400 racer

Power: 144 rwkw

Location: Melbourne
VIC, Australia

yeah i took it back just then and he said becos he washed my engine, some water might have leaked into the dizzy. which i thought was bad in the first place but the car after a bit of driving has started to idle better. but i dunno about fuel eco, since it had a bad fuel eco anyway. hope it didn't make it worse.

thanks benji

phong

 

_________________

phongus = Post whore 2006
EL XR6 motor, EL ECU + J3 chip, WADE 1673 Camshaft, 3" S/S intake, Pacy 4480, 2.5" Hi flow cat, 2.5" Lukey exhaust.
Max Power = 144.6 rwkw (03/05/2008)

Top
 Profile  
 
Display posts from previous:
Sort by  
 Page 1 of 1  [ 3 posts ] 

Who is online

Users browsing this forum: DStirrup and 16 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum
cron

 

 

It is currently Fri Dec 15, 2017 10:21 am All times are UTC + 11 hours

 

 

(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names