Fordmods Logo

Servicing my ED. 

 

Page 1 of 1 [ 4 posts ] 

 
 Post subject: Servicing my ED.
Posted: Thu Apr 21, 2005 2:38 am 
Getting Side Ways
Offline

Age: 31

Posts: 659

Joined: 18th Mar 2005

Gallery: 2 images

Ride: WRX

Power: 132 rwkw

Location: Frankston
VIC, Australia

Now this might be a fairly noobish question. But what do i need to service my ED.

Ive got a new filter, getting new leads, sparks, oil and fuel filter, new engine oil, coolant is brand new, ps fluid is new.

Anything else?

My car used to do almost 500kms from a full tank of ulp (that includes slight thrashings and drags)

Now im lucky to do 400 from driving conservatively. Anyone know of any other reasons my fuel efficientcy has s**t itself? (i do have a pod filter but it shouldnt suck that much fuel should it?)

Thanks.

 

_________________

Car Killer.

Top
 Profile  
 
 
Posted: Thu Apr 21, 2005 9:12 pm 
Fordmods Junkie
Offline
User avatar

Age: 38

Posts: 1000491

Joined: 6th Nov 2004

Gallery: 2 images

Ride: AUXR6 HP With Ducati SupA Bike!

Location: Perth
WA, Australia

pretty good list dude
also check your timing and the condition of the dizzy cap and rotor, injecotres could be clogged up

 

_________________

RIP SCOTT

Top
 Profile  
 
 
 Post subject: Re: Servicing my ED.
Posted: Fri Apr 22, 2005 12:15 am 
Getting Side Ways
Offline
User avatar

Age: 33

Posts: 2282

Joined: 14th Jan 2005

Gallery: 8 images

Ride: ED Fairmont Ghia & EF XR8

Location: Melbourne
VIC, Australia

byrneing wrote:
Now this might be a fairly noobish question. But what do i need to service my ED.

Ive got a new filter, getting new leads, sparks, oil and fuel filter, new engine oil, coolant is brand new, ps fluid is new.

Anything else?

My car used to do almost 500kms from a full tank of ulp (that includes slight thrashings and drags)

Now im lucky to do 400 from driving conservatively. Anyone know of any other reasons my fuel efficientcy has s**t itself? (i do have a pod filter but it shouldnt suck that much fuel should it?)

Thanks.


yeh if had the same thing happen god knows what the fix is.

 

_________________

Image

Top
 Profile  
 
 
Posted: Fri Apr 22, 2005 1:27 am 
Tyre Shredder
Offline
User avatar

Posts: 387

Joined: 12th Dec 2004

Gallery: 4 images

Ride: 2005 Hi-Ace

Location: melbourne
VIC, Australia

im used to being lucky to get 400 Km a tank out of my ED, id love to know what it is too!

 

_________________

2005 Toyota Hi-Ace aka ICE CUBE

Top
 Profile  
 
Display posts from previous:
Sort by  
 Page 1 of 1  [ 4 posts ] 

Who is online

Users browsing this forum: Google [Bot], Google Adsense [Bot] and 16 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

 

 

It is currently Tue Dec 19, 2017 1:54 am All times are UTC + 11 hours

 

 

(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names