Fordmods Logo

slight electrical problem with my eb fairmont 

 

Page 1 of 1 [ 3 posts ] 

 
 Post subject: slight electrical problem with my eb fairmont
Posted: Sun Oct 10, 2010 11:57 pm 
Parts Gopher
Offline

Age: 26

Posts: 71

Joined: 27th Aug 2010

Gallery: 1 images

Ride: 1992 eb fairmont classic

Location: newcastle
NSW, Australia

turning my lights on will most of the time cut out my stereo and reset my digital display for the range in the tank and average litres per 100/k and so forth and when i flick the high beams on it sometimes cuts the whole car out completely and i mean the engine stops lights go out and so on and so forth lol any info on that or maybe jst a auto elecies job
Top
 Profile  
 
 
 Post subject: Re: slight electrical problem with my eb fairmont
Posted: Mon Oct 11, 2010 12:02 am 
Getting Side Ways
Offline
User avatar

Age: 34

Posts: 4274

Joined: 8th Dec 2004

Gallery: 25 images

Ride: EB2 Ghia,Mighty Boy,Eb1 Xr8 5spd

Location: ** In the Shed! **
VIC, Australia

Sounds like a dodgy earth. Check the earth cable that runs from the battery down to the chassis rail & the engine mount. Clean the mounting points up, then test for the issue.

If it's still happening, clean up the earth point at the top of the dash, found by removing the plastic cover closest to the windscreen. Earth point is up in the middle of the car...

Cheers

ToranaGuy

 

_________________

I am the ToranaGuy!|74 Lh Torana Turbo|78 Hz PanelVan|86 Mighty Boy Ute|93 EB2 Ghia,GT Mockup,5spd,LPGI,Full Leather|2 x EB Xr8 5spd's|FS [VIC]: Wrecking - Eb XR8 - Parts available |Build Thread|Ebay Items - Ford Parts|

Top
 Profile  
 
 
 Post subject: Re: slight electrical problem with my eb fairmont
Posted: Mon Oct 11, 2010 12:16 am 
Parts Gopher
Offline

Age: 26

Posts: 71

Joined: 27th Aug 2010

Gallery: 1 images

Ride: 1992 eb fairmont classic

Location: newcastle
NSW, Australia

ToranaGuy wrote:
Sounds like a dodgy earth. Check the earth cable that runs from the battery down to the chassis rail & the engine mount. Clean the mounting points up, then test for the issue.

If it's still happening, clean up the earth point at the top of the dash, found by removing the plastic cover closest to the windscreen. Earth point is up in the middle of the car...

Cheers

ToranaGuy

oh i will have to give that a look then ay maybe in the next few days got a welche plug gettin dun 2moro and rego check the nxt LOL

thanks 4 that mate

silly question again but y is ur username (torana guy) on a for website??? LOL :D
Top
 Profile  
 
Display posts from previous:
Sort by  
 Page 1 of 1  [ 3 posts ] 

Who is online

Users browsing this forum: No registered users and 15 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

 

 

It is currently Thu Dec 08, 2016 7:13 am All times are UTC + 11 hours

 

 

(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names