Fordmods Logo

STG 3PS ITS MOTOR 

 

Page 1 of 1 [ 6 posts ] 

 
 Post subject: STG 3PS ITS MOTOR
Posted: Thu Mar 22, 2007 8:21 pm 
Fordmods Newbie
Offline

Posts: 12

Joined: 1st May 2005

Location: sydney
NSW, Australia

GOT MY ITS STG 3PS MOTOR , RAN IN AS SPECIFIED , IT SEEMS TO BE USING OIL (ROYAL PURPLE 10 40) IS THIS NORMAL?
ANY ONE ELSE RUNNING ONE THESE MOTORS ? DOES IT USE OIL?
WHICH OIL YOU USING IN IT?

THANKS :?:
Top
 Profile  
 
 
Posted: Fri Mar 23, 2007 8:23 am 
Oompa Loompa
Offline

Age: 34

Posts: 32

Joined: 4th Apr 2005

Ride: AU

Location: Melbourne
VIC, Australia

I would contact the engine builder.

My understanding is that you need to use a little thicker mineral based oil to run it in, but Im not 100% on that.
Top
 Profile  
 
 
Posted: Sat Mar 24, 2007 10:48 am 
Getting Side Ways
Offline

Age: 28

Posts: 1135

Joined: 27th Oct 2005

Gallery: 3 images

Location: SA
SA, Australia

someone else had this problem .. i think... im not sure that IT's is around any more
Top
 Profile  
 
 
Posted: Sat Mar 24, 2007 10:52 am 
Getting Side Ways
Offline
User avatar

Age: 34

Posts: 10826

Joined: 17th Apr 2005

Gallery: 34 images

Ride: BF MK11 XR 6 TURBO ZF 6spd

Power: 225 rwkw

Location: glenwood/sydney
NSW, Australia

hey br..... when did you get it installed? i had my stage 4 it's' engine installed about a year ago now.. just before mark moved from cambelltown.. seems he's disapeared.. but good luck to him any hows.. :wink: my engine has never had a problem with oil consumption.. and its the stage 4 it's engine with the stage 5 mega monster billet cam.. no probs here... :wink:

 

_________________

Todd: Nurse, suction.
Nurse: The patient's not even here yet.
Todd: I know.

http://www.youtube.com/watch?v=_GQpRYRcAiA

Top
 Profile  
 
 
Posted: Sat Mar 24, 2007 12:22 pm 
Fordmods Newbie
Offline

Posts: 12

Joined: 1st May 2005

Location: sydney
NSW, Australia

fordfreak
installed 6 months
wot oil u running in ur stg 4?
Top
 Profile  
 
 
Posted: Sat Mar 24, 2007 1:09 pm 
Getting Side Ways
Offline
User avatar

Age: 34

Posts: 10826

Joined: 17th Apr 2005

Gallery: 34 images

Ride: BF MK11 XR 6 TURBO ZF 6spd

Power: 225 rwkw

Location: glenwood/sydney
NSW, Australia

br wrote:
fordfreak
installed 6 months
wot oil u running in ur stg 4?
id have to check but uaualy i use a medium viscosity oil.. either shell or valvoline.. -the ones with the "for performance engines" sticker on the front... -not that im sure it aint a gimmick.. :roll:

 

_________________

Todd: Nurse, suction.
Nurse: The patient's not even here yet.
Todd: I know.

http://www.youtube.com/watch?v=_GQpRYRcAiA

Top
 Profile  
 
Display posts from previous:
Sort by  
 Page 1 of 1  [ 6 posts ] 

Who is online

Users browsing this forum: Google [Bot] and 17 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

 

 

It is currently Wed Dec 13, 2017 7:06 am All times are UTC + 11 hours

 

 

(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names