Fordmods Logo

Still need help engine running now Barley 

 

Page 1 of 1 [ 7 posts ] 

 
 Post subject: Still need help engine running now Barley
Posted: Fri Apr 30, 2010 9:01 am 
Parts Gopher
Offline

Age: 26

Posts: 57

Joined: 14th Apr 2010

Ride: ED GLi

Location: Ipswich, Brisbane
QLD, Australia

Gday i got inpatiant lastnight anddecided to cross the terminals on the starter solinoid and that got the old girl kicking but now i have a the red radiator light on in the cluster <picture of a radiator with a fan on it> and it wont go out even after half an hour of driving any help is appreciated
Top
 Profile  
 
 
 Post subject: Re: Still need help engine running now Barley
Posted: Fri Apr 30, 2010 10:16 am 
QLD Cruise Moderator
Offline

Age: 52

Posts: 407

Joined: 20th Jul 2009

Gallery: 1 images

Ride: EF Ford Falcon Wagon

Location: Atkinsons Dam an hour out of Brisbane
QLD, Australia

mysh*tbox wrote:
Gday i got inpatiant lastnight anddecided to cross the terminals on the starter solinoid and that got the old girl kicking but now i have a the red radiator light on in the cluster <picture of a radiator with a fan on it> and it wont go out even after half an hour of driving any help is appreciated



Take the dash out and pull the bulb mine use to do that for no reason so I pulled the bulb problem solved
Top
 Profile  
 
 
 Post subject: Re: Still need help engine running now Barley
Posted: Fri Apr 30, 2010 10:21 am 
Getting Side Ways
Offline

Posts: 2091

Joined: 3rd Apr 2008

Ride: EF Fairmont, XG Ute

Sounds like the low coolant level warning light. You either have no coolant, or the sensor is stuffed. I wouldn't pull the bulb out, just fix the problem.
Top
 Profile  
 
 
 Post subject: Re: Still need help engine running now Barley
Posted: Fri Apr 30, 2010 10:26 am 
QLD Cruise Moderator
Offline

Age: 52

Posts: 407

Joined: 20th Jul 2009

Gallery: 1 images

Ride: EF Ford Falcon Wagon

Location: Atkinsons Dam an hour out of Brisbane
QLD, Australia

Pull the bulb, mines been out for two years as their was no problem for it to be on and it doesent serve a purpose if my car goes to overheat the Radiator light comes on, so if you cant and dont have a problem with it over heating pull the bulb.
Top
 Profile  
 
 
 Post subject: Re: Still need help engine running now Barley
Posted: Fri Apr 30, 2010 10:52 am 
Getting Side Ways
Offline
User avatar

Posts: 887

Joined: 8th Aug 2006

Ride: Falcon

Location: Central Highlands
QLD, Australia

SV-Valiant wrote:
Pull the bulb, mines been out for two years as their was no problem for it to be on and it doesent serve a purpose if my car goes to overheat the Radiator light comes on, so if you cant and dont have a problem with it over heating pull the bulb.


I hope you realise that if your driving along and blow a hose your temp will go up to about 3/4 then come back down to about 1/2way as the coolant temp sensor begins to read air temp as no coolant left. That's why ford put the coolant low switch in.

Have you installed a radiator low switch in your tank or something, the red light above the temp gauge generally won't come on unless there is still water running passed the sensor, if no water left then as above will happen.

Cheers and have a nice day....

 

_________________

97 EL Fairmont 4l OHC .Silver.
Exhaust: Pacemaker's, 2.5" exhaust and Hiflow cat
Intake: FRAM AIRHOG , EL GT snorkel
XR6 300kpa fuel reg Stg 2 Auto Shift Kit.6DJA ECU
PM in Qld looking too buy Toyota 4*4 SR5 Dualcab Hilux 91-97 with 2.8l diesel engine/5spd manual

Top
 Profile  
 
 
 Post subject: Re: Still need help engine running now Barley
Posted: Fri Apr 30, 2010 11:24 am 
Tyre Shredder
Offline
User avatar

Age: 52

Posts: 358

Joined: 7th Jun 2007

Ride: NA Fairlane / FE LTD

Location: bayswater
VIC, Australia

Yep the dash sensor will only read water temp not air temp. Therefore if there is no water in the system, the guage wont show hot.The sensor for that light is in the recovery bottle and is a magnetic switch that does stuff up. Lower spec cars never had it so no drama to run without it, but from memory if you unplug it the light stays on.
Top
 Profile  
 
 
 Post subject: Re: Still need help engine running now Barley
Posted: Fri Apr 30, 2010 5:44 pm 
Stock as a Rock
Offline

Age: 33

Posts: 141

Joined: 17th Jun 2006

Ride: Falcon

Location: canberra
ACT, Australia

Those low level sensors have a habit of failing. I've changed about 4 or 5 of them.

 

_________________

Fords Rule. OK.

Top
 Profile  
 
Display posts from previous:
Sort by  
 Page 1 of 1  [ 7 posts ] 

Who is online

Users browsing this forum: No registered users and 14 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

 

 

It is currently Fri Dec 15, 2017 10:26 am All times are UTC + 11 hours

 

 

(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names