Fordmods Logo

Strange coolant problem. 


Page 3 of 3 [ 32 posts ] Go to page Previous  1, 2, 3

 Post subject: Re: Strange coolant problem.
Posted: Sun May 16, 2010 10:52 pm 
Getting Side Ways
User avatar

Age: 54

Posts: 1566

Joined: 12th Apr 2008

Gallery: 17 images

Ride: 5.0lt NF /351 ZD Fairlane

Location: Wattle Grove
NSW, Australia

Sweet dude! good luck and enjoy drivin' around 8-)



NF Fairlane with 5.0 and 5 speed goodness!
ZD build thread under construction at post1136180.html#p1136180

 Post subject: Re: Strange coolant problem.
Posted: Mon May 17, 2010 4:23 pm 
Fordmods Newbie

Age: 24

Posts: 4

Joined: 17th May 2010

Ride: 95 EF falcon 5Sp Manual

Location: Taree
NSW, Australia

I had Coolant problems with my EF too...
Replaced coolant tank- Old one was brown, All radiator hoses replaced- Blew a heater hose so got Ford to replace them, Top thermostat housing replaced, Heater tap and core replaced-While at ford they found the heater core was leaking...
This was all sorted.. Few weeks later the water pump s**t itself..
Few days later I was driving around, Stopped at my mates place for 10 minutes.. Got back into my car and the engine temp was on High, and it beeped at me.. I started it to get the coolant flowing and I found quite a big puddle of coolant underneath it.. When I got it home I noticed that the radiator had a split in it.
So I was talking to my Dad about it and he told me his old truck used to keep leaking coolant because of the wrong cap on the tank...
Went to Ford and bought a new cap which was a different pressure than the one I already had, Put the new Radiator in it and new cap on... Now i've had no leaks for 6 months..

I'm glad you got yours all sorted mate ;)
Display posts from previous:
Sort by  
 Page 3 of 3  [ 32 posts ]  Go to page Previous  1, 2, 3

Who is online

Users browsing this forum: No registered users and 19 guests

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum



It is currently Thu Oct 27, 2016 8:17 am All times are UTC + 11 hours



(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names