Fordmods Logo

strange fuel surge 

 

Page 1 of 1 [ 11 posts ] 

 
 Post subject: strange fuel surge
Posted: Sun Dec 27, 2009 11:25 pm 
Getting Side Ways
Offline
User avatar

Age: 28

Posts: 3374

Joined: 11th Mar 2008

Ride: EA SVO, AU2 Forte

Location: Bendigo
VIC, Australia

my eb s1 s pack is on dual fuel. on gas it runs fine.
now on petrol at idle it runs fine, under harsh acceleration it runs fine
but under light acceleration and cruising speeds it surges and carries on

what do you guys reckon?

 

_________________

Daily driver: AU2. 5 speed. 19" FG luxos. Full exhaust. Lowered. AU3 XR leather interior, converted to full power windows. 3.45 LSD. IN THE FUTURE: Tickford 6
Weekend driver: EA SVO AU motor. Built BTR. TCE 2800 stall. T76 turbo. Locked diff. On E85. approx 320rwkw. 11.5 @121mph

Top
 Profile  
 
 
 Post subject: Re: strange fuel surge
Posted: Sun Dec 27, 2009 11:41 pm 
Fordmods Junkie
Offline
User avatar

Posts: 11738

Joined: 17th May 2005

Gallery: 11 images

Ride: EL Fairmont, VFR400 racer

Power: 144 rwkw

Location: Melbourne
VIC, Australia

check fuel filter? could be blocked.

 

_________________

phongus = Post whore 2006
EL XR6 motor, EL ECU + J3 chip, WADE 1673 Camshaft, 3" S/S intake, Pacy 4480, 2.5" Hi flow cat, 2.5" Lukey exhaust.
Max Power = 144.6 rwkw (03/05/2008)

Top
 Profile  
 
 
 Post subject: Re: strange fuel surge
Posted: Sun Dec 27, 2009 11:41 pm 
Getting Side Ways
Offline
User avatar

Age: 46

Posts: 3763

Joined: 25th Nov 2004

Gallery: 6 images

Ride: EFII 5.8 NOS TerroristGhia

Power: 274 rwkw

Location: Sydney Australia
NSW, Australia

Fuel filter would be my first point of call

Brett

 

_________________

The Terrorist ED Retired due to RUST.
The TerrosistGhia, EF Ghia 351 EFI 5 Speed.
Millennium Falcon, Sleeper EL DOHC 6 Speed Manual EFI LPG
Member#1131
I didn't Vote for Multiculturalism, DID YOU!!!

Top
 Profile  
 
 
 Post subject: Re: strange fuel surge
Posted: Sun Dec 27, 2009 11:48 pm 
Getting Side Ways
Offline

Age: 36

Posts: 508

Joined: 28th Feb 2009

Gallery: 9 images

Ride: Ed v8 fairmont wagon, wr450f

Power: 137 rwkw

WILDEB wrote:
my eb s1 s pack is on dual fuel. on gas it runs fine.
now on petrol at idle it runs fine, under harsh acceleration it runs fine
but under light acceleration and cruising speeds it surges and carries on

what do you guys reckon?


i had eb xr6 dual fuel as well and notice it doing the same as well on fuel and it got worse and then started running rich with black smoke at idle.I changed fuel filter,leads still the same and then put a new o2 sensor in and it fixed it...

phill
Top
 Profile  
 
 
 Post subject: Re: strange fuel surge
Posted: Sun Dec 27, 2009 11:55 pm 
Getting Side Ways
Offline
User avatar

Age: 30

Posts: 3737

Joined: 22nd May 2006

Ride: BF F6 Tornado - #0077

Location: Bendigo
VIC, Australia

filter or pump

 

_________________

** For Sale ** http://www.fordmods.com/ford-parts-for-sale-f17/assorted-e-series-parts-t124697.html

F6 Tornado 2006 Build

Is it about sex? The engine in my car? Or a cure for cancer?
No?

Then f**k off

Top
 Profile  
 
 
 Post subject: Re: strange fuel surge
Posted: Mon Dec 28, 2009 12:09 am 
Getting Side Ways
Offline
User avatar

Age: 49

Posts: 6467

Joined: 18th Dec 2006

Ride: 93 ED sedan

Power: 161 rwkw

Location: Rockhampton
QLD, Australia

Check your MAP sensor hose for a split.

 

_________________

http://youtu.be/jJTh9F3Vgg0

Top
 Profile  
 
 
 Post subject: Re: strange fuel surge
Posted: Mon Dec 28, 2009 2:36 am 
Getting Side Ways
Offline
User avatar

Age: 28

Posts: 3374

Joined: 11th Mar 2008

Ride: EA SVO, AU2 Forte

Location: Bendigo
VIC, Australia

i am a apprentice mechanic by trade. so i have the knowledge but don't know everything. plugs are less than 10,000kms old. leads about 30,000kms. pump it a little noisy but if the pump was buggered it'd be worse when you tried to open it up a bit. fuel filter has about 30,000kms on it. probably due. map sensor has been changed and the hose is fine

it doesn't blow any smoke at idle. does the gas use the o2 sensor too?

 

_________________

Daily driver: AU2. 5 speed. 19" FG luxos. Full exhaust. Lowered. AU3 XR leather interior, converted to full power windows. 3.45 LSD. IN THE FUTURE: Tickford 6
Weekend driver: EA SVO AU motor. Built BTR. TCE 2800 stall. T76 turbo. Locked diff. On E85. approx 320rwkw. 11.5 @121mph

Top
 Profile  
 
 
 Post subject: Re: strange fuel surge
Posted: Mon Dec 28, 2009 10:07 am 
Getting Side Ways
Offline
User avatar

Age: 49

Posts: 6467

Joined: 18th Dec 2006

Ride: 93 ED sedan

Power: 161 rwkw

Location: Rockhampton
QLD, Australia

How are the dizzy and the coil????

 

_________________

http://youtu.be/jJTh9F3Vgg0

Top
 Profile  
 
 
 Post subject: Re: strange fuel surge
Posted: Mon Dec 28, 2009 10:12 am 
Getting Side Ways
Offline

Age: 36

Posts: 508

Joined: 28th Feb 2009

Gallery: 9 images

Ride: Ed v8 fairmont wagon, wr450f

Power: 137 rwkw

WILDEB wrote:
i am a apprentice mechanic by trade. so i have the knowledge but don't know everything. plugs are less than 10,000kms old. leads about 30,000kms. pump it a little noisy but if the pump was buggered it'd be worse when you tried to open it up a bit. fuel filter has about 30,000kms on it. probably due. map sensor has been changed and the hose is fine

it doesn't blow any smoke at idle. does the gas use the o2 sensor too?


think it depends on what brand of set up you have,mine did but it didnt play up on lpg and only on fuel and i changed everythink as i had a ea fairmont sitting beside it. I fitted a set of extractors up while still trying to sort it with a new 02 sensor and fixed it...

phill
Top
 Profile  
 
 
 Post subject: Re: strange fuel surge
Posted: Mon Dec 28, 2009 10:38 am 
Stock as a Rock
Offline

Age: 38

Posts: 177

Joined: 3rd Apr 2006

Location: gladstone
QLD, Australia

i would say fuel pump as my au was doing the same thing and i changed everything first and it was a weak noisey pump all along
Top
 Profile  
 
 
 Post subject: Re: strange fuel surge
Posted: Mon Dec 28, 2009 2:27 pm 
Getting Side Ways
Offline
User avatar

Age: 28

Posts: 3374

Joined: 11th Mar 2008

Ride: EA SVO, AU2 Forte

Location: Bendigo
VIC, Australia

i'll try a pump and filter after i go back to work

 

_________________

Daily driver: AU2. 5 speed. 19" FG luxos. Full exhaust. Lowered. AU3 XR leather interior, converted to full power windows. 3.45 LSD. IN THE FUTURE: Tickford 6
Weekend driver: EA SVO AU motor. Built BTR. TCE 2800 stall. T76 turbo. Locked diff. On E85. approx 320rwkw. 11.5 @121mph

Top
 Profile  
 
Display posts from previous:
Sort by  
 Page 1 of 1  [ 11 posts ] 

Who is online

Users browsing this forum: Google [Bot] and 29 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

 

 

It is currently Tue Dec 12, 2017 8:18 pm All times are UTC + 11 hours

 

 

(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names