Fordmods Logo

Strange problem with my el 

 

Page 1 of 1 [ 5 posts ] 

 
 Post subject: Strange problem with my el
Posted: Tue Apr 20, 2010 8:45 pm 
Oompa Loompa
Offline

Age: 27

Posts: 29

Joined: 5th Mar 2010

Ride: Ford El xr6

Location: Melbourne
VIC, Australia

Hi i have a el xr6 with after market race headers and JMM extractors when i reach around 4k revs i get this sound that is like theirs bits of metal flying around inside in ideas >?<
Top
 Profile  
 
 
 Post subject: Re: Strange problem with my el
Posted: Tue Apr 20, 2010 8:50 pm 
Fordmods Junkie
Offline
User avatar

Age: 35

Posts: 3045

Joined: 26th Nov 2008

Ride: 1975 XB Falcon 500

Location: In the drivers seat
SA, Australia

This should be posted in the 6 cylinder workshop mate, ill move it there for you.

 

_________________

Image
http://www.facebook.com/Ford1975

Top
 Profile  
 
 
 Post subject: Re: Strange problem with my el
Posted: Tue Apr 20, 2010 9:01 pm 
Getting Side Ways
Offline
User avatar

Posts: 887

Joined: 8th Aug 2006

Ride: Falcon

Location: Central Highlands
QLD, Australia

xrbabyboy531 wrote:
Hi i have a el xr6 with after market race headers and JMM extractors when i reach around 4k revs i get this sound that is like theirs bits of metal flying around inside in ideas >?<


Pinging(detonation) if the sound is coming from engine. Try a different servo, hi-octane fuel, new fuel filter and see if problem goes away.

Also check your ignition timing, might be too far advanced....Take out a few spark plugs and have a look a them, what spark plugs you running????

 

_________________

97 EL Fairmont 4l OHC .Silver.
Exhaust: Pacemaker's, 2.5" exhaust and Hiflow cat
Intake: FRAM AIRHOG , EL GT snorkel
XR6 300kpa fuel reg Stg 2 Auto Shift Kit.6DJA ECU
PM in Qld looking too buy Toyota 4*4 SR5 Dualcab Hilux 91-97 with 2.8l diesel engine/5spd manual

Top
 Profile  
 
 
 Post subject: Re: Strange problem with my el
Posted: Tue Apr 20, 2010 9:16 pm 
Oompa Loompa
Offline

Age: 27

Posts: 29

Joined: 5th Mar 2010

Ride: Ford El xr6

Location: Melbourne
VIC, Australia

I have noticed when i use 95 or above octane flue it is not as noticeable hoping that's the issue, With my spark plugs i have them replaced about a month ago with my last service i am not sure what brand they are :(
Top
 Profile  
 
 
 Post subject: Re: Strange problem with my el
Posted: Tue Apr 20, 2010 10:58 pm 
Getting Side Ways
Offline
User avatar

Posts: 887

Joined: 8th Aug 2006

Ride: Falcon

Location: Central Highlands
QLD, Australia

xrbabyboy531 wrote:
I have noticed when i use 95 or above octane flue it is not as noticeable hoping that's the issue, With my spark plugs i have them replaced about a month ago with my last service i am not sure what brand they are :(



xr6 engines run a colder plug then the standard EL's, maybe the mechanic put standard ones in. See if you can get a part no. of one of the spark plugs and google search it..

 

_________________

97 EL Fairmont 4l OHC .Silver.
Exhaust: Pacemaker's, 2.5" exhaust and Hiflow cat
Intake: FRAM AIRHOG , EL GT snorkel
XR6 300kpa fuel reg Stg 2 Auto Shift Kit.6DJA ECU
PM in Qld looking too buy Toyota 4*4 SR5 Dualcab Hilux 91-97 with 2.8l diesel engine/5spd manual

Top
 Profile  
 
Display posts from previous:
Sort by  
 Page 1 of 1  [ 5 posts ] 

Who is online

Users browsing this forum: Google Adsense [Bot] and 17 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

 

 

It is currently Tue Dec 19, 2017 7:57 am All times are UTC + 11 hours

 

 

(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names