Fordmods Logo

T5 manual conversion complete. Help needed desperately. 

 

Page 1 of 1 [ 13 posts ] 

 
 Post subject: T5 manual conversion complete. Help needed desperately.
Posted: Mon Jan 12, 2009 2:09 am 
Getting Side Ways
Offline

Posts: 597

Joined: 4th May 2007

Ride: 1992 EBII Fairmont

Location: Aga
VIC, Australia

Hey all.

I've just finished my T5 conversion however there's a few problems.

My mate only put one of the neg leads on the battery terminal and left the other off by accident.

We figured it out when it wouldn't turn over but by then we saw smoke emitting from around the map sensor area. Also with only 1 neg lead on the headlights came through the indicators however when we put the other lead on they returned to normal.

We corrected it and it starts fine and runs as normal however:

The interior light is always on when the keys in.
Cluster lights aren't on (couldn't see the needles in the dark). I can't remember but I don't think any dash lights worked.
The tail lights/brake lights don't work.

ALL THIS WAS WORKING PERFECTLY UNTIL THE BATTERY INCIDENT.

Also there was a bad smell coming from the car, when we returned from up the road
we found that the brake booster hose was disconnected. Could that explain the smell somehow? My mate drove it and was braking heavily without the booster. I hope to god that's it since I really really cannot be bothered taking the box off again.

On a positive note, the thing absolutely hammers.

Any help would be greatly greatly appreciated as I'm absolutely itching to drive the beast.
Top
 Profile  
 
 
Posted: Mon Jan 12, 2009 8:12 am 
Getting Side Ways
Offline
User avatar

Posts: 1140

Joined: 27th Feb 2005

Ride: Supercharged EF Fairmont

Location: T.I. Performance HQ
VIC, Australia

at a guess you blew up the bem. explains the smell too.
Top
 Profile  
 
 
Posted: Mon Jan 12, 2009 10:18 am 
Getting Side Ways
Offline
User avatar

Age: 28

Posts: 1110

Joined: 25th Mar 2007

Gallery: 7 images

Ride: BA MKII Fairlane GHIA

Location: Berwick
VIC, Australia

james did you end up putting the ed xr6 bem in the car or keep the the stock one...
btw you have spare clusters check them and see if that helps also check fuses and your wiring

good luck mate
Top
 Profile  
 
 
Posted: Mon Jan 12, 2009 10:40 am 
Getting Side Ways
Offline

Posts: 5582

Joined: 20th May 2005

Gallery: 11 images

Ride: EB1 Fairmont Ghia T5 Wagon

Location: Seven Hills, Sydney
NSW, Australia

Just a point to remember that the ECU and BEM/Central Controller are separate moduals.

To try and answer your question I need a bit more info.

What model car is it? EA, EB etc

What model type is it? Spac, Fairmont etc

What wiring are you using in the dash? Std or have you changed it?

What BEM are you using?

BenJ

 

_________________

BenJ's EB T5 DOHC Ghia Wagon - Current Ride
BenJ's EB GL Sedan - Previous Ride
My respect and thanks go to - snap0964, Paulmac, SWC and MRE-50L

Top
 Profile  
 
 
Posted: Mon Jan 12, 2009 11:51 am 
Getting Side Ways
Offline
User avatar

Age: 28

Posts: 1110

Joined: 25th Mar 2007

Gallery: 7 images

Ride: BA MKII Fairlane GHIA

Location: Berwick
VIC, Australia

BenJ wrote:
Just a point to remember that the ECU and BEM/Central Controller are separate moduals.

To try and answer your question I need a bit more info.

What model car is it? EA, EB etc

What model type is it? Spac, Fairmont etc

What wiring are you using in the dash? Std or have you changed it?

What BEM are you using?

BenJ

from what i no of the car its a ed gli with a ed xr6 cluster
i dont no if hes running the standard bem or the ed xr6 one..
standard ecu tho
Top
 Profile  
 
 
Posted: Mon Jan 12, 2009 2:57 pm 
Getting Side Ways
Offline

Posts: 597

Joined: 4th May 2007

Ride: 1992 EBII Fairmont

Location: Aga
VIC, Australia

Haha if all goes well today Kenny I'll take ya for a spin.

1994 ED Gli 4.0. Standard wiring no mods besides what they did for the LPG conversion.

With the T5 I used the manual loom.

BEM? Is that the smartlock module? Red or blue box?
Would that expain the smoke emitting form the MAP sensor area, something there is definitely fried.

Btw didn't touch the BEM so it's the Gli one? Didn't know the XR's were different.
Top
 Profile  
 
 
Posted: Mon Jan 12, 2009 4:30 pm 
Getting Side Ways
Offline

Posts: 597

Joined: 4th May 2007

Ride: 1992 EBII Fairmont

Location: Aga
VIC, Australia

I just checked the car again.

Interior light is fine my mate mustn't know how to work the thing haha.
Needles and everything in the cluster is fine.

So is smartlock, remote works too.

Only the taillights/cluster lights/number plate lights don't work.
I'm going to look over everything in the fuse box now.

Still worried about that smoke from around the map sensor. There's 2 diodes around there plugged into the loom (think they're diodes they look the same as the XR high beam diode that goes under the coolant bottle).

Also the park lamp fuse is blown, I've replaced it twice but it blows instantly after. I think this may be the problem.
Top
 Profile  
 
 
Posted: Mon Jan 12, 2009 4:34 pm 
Getting Side Ways
Offline

Posts: 5582

Joined: 20th May 2005

Gallery: 11 images

Ride: EB1 Fairmont Ghia T5 Wagon

Location: Seven Hills, Sydney
NSW, Australia

OK, so you have a red modual, which would be the smartlock, and a blue modual, which is the BEM, which being blue would be a Futura BEM

The BEM controls the electronics, such as washer and wiper, and couretesy lights, and I believe instrument cluster lighting/diming.

The smoke may be from some wiring, the map sensor itself, or possibly the wiper motor assembly.

If the BEM is fried that may explain why the dash lights are not working.

You should also check the headlight switch, as if it was trying to earth through the lights etc, it may be damaged.

Good Luck

BenJ

 

_________________

BenJ's EB T5 DOHC Ghia Wagon - Current Ride
BenJ's EB GL Sedan - Previous Ride
My respect and thanks go to - snap0964, Paulmac, SWC and MRE-50L

Top
 Profile  
 
 
Posted: Mon Jan 12, 2009 5:10 pm 
Getting Side Ways
Offline

Posts: 597

Joined: 4th May 2007

Ride: 1992 EBII Fairmont

Location: Aga
VIC, Australia

Hey mate that was off my XR.

The Gli apparently doesn't have one (according to gregorys) and instead has the wiper relay and another, the cluster lights are controlled somewhere else.
Top
 Profile  
 
 
Posted: Mon Jan 12, 2009 5:26 pm 
Getting Side Ways
Offline
User avatar

Age: 28

Posts: 1110

Joined: 25th Mar 2007

Gallery: 7 images

Ride: BA MKII Fairlane GHIA

Location: Berwick
VIC, Australia

any updates james or have you hit a wall
Top
 Profile  
 
 
Posted: Mon Jan 12, 2009 11:18 pm 
Stock as a Rock
Offline

Age: 28

Posts: 190

Joined: 25th Oct 2008

Ride: DC LTD V8

Location: melbourne
VIC, Australia

that car is so f**k annoying i tell ya what

 

_________________

DC LTD V8 pure style

Top
 Profile  
 
 
Posted: Tue Jan 13, 2009 2:31 am 
Getting Side Ways
Offline

Posts: 597

Joined: 4th May 2007

Ride: 1992 EBII Fairmont

Location: Aga
VIC, Australia

Yeah after all that I wish the car didn't have LPG and a column shift.

But mechanically it's done. I'm booking it into an auto electrician now.
Top
 Profile  
 
 
Posted: Tue Jan 13, 2009 10:30 am 
Getting Side Ways
Offline
User avatar

Age: 28

Posts: 1110

Joined: 25th Mar 2007

Gallery: 7 images

Ride: BA MKII Fairlane GHIA

Location: Berwick
VIC, Australia

james your car goes so fukin hard for what it is

gratz mate sorry i couldnt help you more
Top
 Profile  
 
Display posts from previous:
Sort by  
 Page 1 of 1  [ 13 posts ] 

Who is online

Users browsing this forum: No registered users and 29 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

 

 

It is currently Sat Dec 16, 2017 11:57 pm All times are UTC + 11 hours

 

 

(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names