Fordmods Logo

thermofan problems NEED HELP ASAP 

 

Page 1 of 1 [ 8 posts ] 

 
 Post subject: thermofan problems NEED HELP ASAP
Posted: Thu Sep 03, 2009 6:19 pm 
SA Cruise Moderator
Offline
User avatar

Age: 30

Posts: 1870

Joined: 14th Apr 2006

Ride: 1993 EBll xr6, 2003 ba xt

Power: 150 rwkw

Location: Whyalla
SA, Australia

i have spent all of today installing the el thermo fans in to a eb done all the wireing and the fans wont come on when the temp is up to half i have tried turning to knob on the thermo switch and nothing, but on the good side the air con one comes on when it should.



any ideas i need answer asap


this is the diogram that i used


thanks all

 

 

Attachments:
image007.jpg
image007.jpg [ 40.76 KiB | Viewed 45 times ]

 

_________________

Owning 1 of 84,847 ebII.
2x clarion subs 1200w, 1x clarion amp 400w, pioneer headunit, 16x8 roh reflex.
Clear side, front indicators, White dials, trip computer, boot spoiler, K & N air filter.
35% tint, paint code (z) stark white, 3" crome nudge bar, Xh snorkle

Top
 Profile  
 
 
 Post subject: Re: thermofan problems NEED HELP ASAP
Posted: Thu Sep 03, 2009 8:22 pm 
Getting Side Ways
Offline
User avatar

Age: 54

Posts: 844

Joined: 12th Aug 2007

Gallery: 22 images

Ride: AU2 XR8 ute & 91 EA bitsa

Location: Melbourne
VIC, Australia

Looks like a Davies Craig diagram. Have you checked for +12v at the fan & the relays when the aircon kicks in? Do both the fans run when connected directly to +12v?

 

_________________

AU2 XR8 with Raptor VL, ported Yella Terra GT40P heads, Scorpion 1.6 RRs, XE264HR-14 Comp Cam, ceramic coated Hurricane Headers, 60lb injectors, Walbro 255, 200cfi cats, 3" exhaust & Snow Performance water methanol injection

Top
 Profile  
 
 
 Post subject: Re: thermofan problems NEED HELP ASAP
Posted: Thu Sep 03, 2009 8:39 pm 
Getting Side Ways
Offline
User avatar

Age: 51

Posts: 918

Joined: 6th Aug 2007

Gallery: 4 images

Ride: BA XR8

Location: Kellyville
NSW, Australia

Do you have an ED,EF,EL, ECU?? If not this could be the problem why the wont cone on. If you using an aftermarket set-up, like shorty said, check you power to the fans.

Cheers

Daz

 

_________________

BA XR8 Boss 260
DAZFAB......Now Mobile
Mink = GAY
DAZFAB MEMBERS ,,,,DA22LE, XTT909, TERRORISTGHIA, TROYMAN, SWC, FAT245

Top
 Profile  
 
 
 Post subject: Re: thermofan problems NEED HELP ASAP
Posted: Thu Sep 03, 2009 9:01 pm 
SA Cruise Moderator
Offline
User avatar

Age: 30

Posts: 1870

Joined: 14th Apr 2006

Ride: 1993 EBll xr6, 2003 ba xt

Power: 150 rwkw

Location: Whyalla
SA, Australia

both fans worked today befor i started as i cheacked to make sure they worked, as for the ecu i am wiring them in to a ebll gli.

their is power and earth where its ment to be.

 

_________________

Owning 1 of 84,847 ebII.
2x clarion subs 1200w, 1x clarion amp 400w, pioneer headunit, 16x8 roh reflex.
Clear side, front indicators, White dials, trip computer, boot spoiler, K & N air filter.
35% tint, paint code (z) stark white, 3" crome nudge bar, Xh snorkle

Top
 Profile  
 
 
 Post subject: Re: thermofan problems NEED HELP ASAP
Posted: Fri Sep 04, 2009 2:48 pm 
Getting Side Ways
Offline
User avatar

Age: 54

Posts: 844

Joined: 12th Aug 2007

Gallery: 22 images

Ride: AU2 XR8 ute & 91 EA bitsa

Location: Melbourne
VIC, Australia

The EBII ECU won't operate the fans (if that's what you're trying to do). Maybe try using an EL ECU as they've got dedicated pins for the thermofans. Or, use a Davies Craig thermatic controller instead.

 

_________________

AU2 XR8 with Raptor VL, ported Yella Terra GT40P heads, Scorpion 1.6 RRs, XE264HR-14 Comp Cam, ceramic coated Hurricane Headers, 60lb injectors, Walbro 255, 200cfi cats, 3" exhaust & Snow Performance water methanol injection

Top
 Profile  
 
 
 Post subject: Re: thermofan problems NEED HELP ASAP
Posted: Fri Sep 04, 2009 3:21 pm 
Getting Side Ways
Offline
User avatar

Age: 35

Posts: 4285

Joined: 8th Dec 2004

Gallery: 25 images

Ride: EB2 Ghia,Mighty Boy,Eb1 Xr8 5spd

Location: ** In the Shed! **
VIC, Australia

You sure all the relay's are ok?

I built myself a circuit to operate my fan's that looks much like the one in the diagram. I have 3 relays and 3 power feeds running it, aircon only triggers passenger side fan, temp switch triggers both fans & the 2nd will start when temp get's hot enough & aircon is on.

Shortly after installing & testing i had issues with the fan's not working properly, turned out a relay i was using (2nd hand i had lying around) crapped itself.

Otherwise pull the wiring out of the car & lay it out on the ground, trace it & see what's up. Maybe there's a fault in it.

Cheers

ToranaGuy

 

_________________

I am the ToranaGuy!|74 Lh Torana Turbo|78 Hz PanelVan|86 Mighty Boy Ute|93 EB2 Ghia,GT Mockup,5spd,LPGI,Full Leather|2 x EB Xr8 5spd's|FS [VIC]: Wrecking - Eb XR8 - Parts available |Build Thread|Ebay Items - Ford Parts|

Top
 Profile  
 
 
 Post subject: Re: thermofan problems NEED HELP ASAP
Posted: Fri Sep 04, 2009 6:32 pm 
Smokin em up
Offline

Posts: 266

Joined: 1st Sep 2007

Location: melbourne
VIC, Australia

Mate
You need the adjustable temperature sensor switch that u can set when the fans come on they are about $60 buy from repco you need them to work independent from A/C

gassa

 

_________________

When the clutch drops the bull s**t stops!!!!!

Top
 Profile  
 
 
 Post subject: Re: thermofan problems NEED HELP ASAP
Posted: Fri Sep 04, 2009 8:32 pm 
SA Cruise Moderator
Offline
User avatar

Age: 30

Posts: 1870

Joined: 14th Apr 2006

Ride: 1993 EBll xr6, 2003 ba xt

Power: 150 rwkw

Location: Whyalla
SA, Australia

all sorted i didnt pick the correct ignition feed


thanks for all the help.

 

_________________

Owning 1 of 84,847 ebII.
2x clarion subs 1200w, 1x clarion amp 400w, pioneer headunit, 16x8 roh reflex.
Clear side, front indicators, White dials, trip computer, boot spoiler, K & N air filter.
35% tint, paint code (z) stark white, 3" crome nudge bar, Xh snorkle

Top
 Profile  
 
Display posts from previous:
Sort by  
 Page 1 of 1  [ 8 posts ] 

Who is online

Users browsing this forum: No registered users and 45 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

 

 

It is currently Mon Dec 11, 2017 5:33 pm All times are UTC + 11 hours

 

 

(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names