Fordmods Logo

These injectors fit?? 

 

Page 1 of 1 [ 4 posts ] 

 
 Post subject: These injectors fit??
Posted: Tue Dec 25, 2007 6:39 pm 
Tyre Shredder
Offline

Age: 32

Posts: 359

Joined: 10th Jul 2006

Ride: ED Fairmont

Location: Werribee
VIC, Australia

just a quick question, would AU injectors fit a ZL Fairlane EFI??

thanks again!

BTW feel free to reply to my quote i posted on another site, on a different matter:

Quote:
I just bought a ZL fairlane for something to waste what cash i don't have!, on it... my problem:

Won't idle, if it does.. it will, but stall once warmed up and won't idle until left for cooling down; and restarted ^ repeat process, will not idle with air flow meter plugged in, < runs REALLY rough

Will idle with out air flow meter plugged in, but at 2,000RPM, runs smooth.

car back fires sometimes when you thrash it in park, we 'tried' clearing injectors, fuel seems to be squirting in, as we connected direct power to each of them.

is not DRIVEABLE, it may idle, but as soon as I put it in Drive and try to take off it will stall, and/or barely go anywhere.

tried 3 different air flow meters...

It has PETROL & GAS, was started what appeared to be fine, ran fine with gas but it was pretty empty , now empty .. so we are not certain how it will run, but hopeful its fine.

car had not been started in about 8-12 months before we got to it, fuel was DEAD AWFUL, soaked up all the fuel in the tank and tried cleaning black oil that came from the off fuel? from bottom of tank, and added clean fuel.

only thing I have not changed are injectors, i'm certain it could be that.........or its still picking up dirty fuel??

any and all ideas welcome, i will have plenty of time to read replies as i won't be going back up to try get the car going until another week.

hopefully i can fix this problem so i can drive it to the servo to get fuel & gas and drive it home!



so far what i'll be trying when I go back up:

Change fuel injectors & rail
Put more fuel & injector cleaner in
Top
 Profile  
 
 
Posted: Tue Dec 25, 2007 8:37 pm 
Tyre Shredder
Offline

Age: 32

Posts: 353

Joined: 27th Nov 2005

Gallery: 9 images

Ride: AUII XR6 VCT

Location: Canning Vale
WA, Australia

Fuel filter?

 

_________________

www.aufalcon.com/dunkly

Top
 Profile  
 
 
Posted: Wed Dec 26, 2007 12:56 am 
Getting Side Ways
Offline
User avatar

Age: 49

Posts: 556

Joined: 10th Dec 2006

Gallery: 4 images

Ride: EAII Falcon S

Location: Brisbane
QLD, Australia

like dunkly said, lacking fuel or, the timing could be out. replace the fuel filter or check that your fuel pressure is regulated at the standard pressure cos it might even be a problem with the pump especialy as the previous owner may have run on lpg only.

the fuel filter is ment to pickup larger particles that wont go through the injector needles so its a slim chance it's a problem with the injectors.
backfire through the exhaust sugests its a timing problem.. either its fireing too late or your getting a slower burn from bad fuel.

edit: thought i might mention also that fuel has a use by date, it will loose octane over a period of time, even if you put new fuel in it still takes some time for the new fuel to get pumped from the tank into the injector rail. a long shot but worth a mention.

au injectors will fit and have a much better spray pattern but it mainly depends on the compatability of ohm's (resistace) of your current injectors.

hope this helps :)

 

_________________

Speed Safely! ;-)

Top
 Profile  
 
 
Posted: Wed Dec 26, 2007 11:55 am 
Tyre Shredder
Offline

Age: 32

Posts: 359

Joined: 10th Jul 2006

Ride: ED Fairmont

Location: Werribee
VIC, Australia

cheers buddy,

well i'm up here with the car again, I will be fitting the au injectors today, and if it fails to fix the problem I will try get another fuel filter, its like running on 4 cyl. no oil leaks or water leakes either.

if i cant get it going properly i will rip the fuel lines out and run on straight gas, damn cars :(
Top
 Profile  
 
Display posts from previous:
Sort by  
 Page 1 of 1  [ 4 posts ] 

Who is online

Users browsing this forum: Facebook [Bot] and 20 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

 

 

It is currently Fri Dec 15, 2017 12:36 am All times are UTC + 11 hours

 

 

(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names